Questions

How to stop Java update?

Tags:
+
0 Votes
Locked

How to stop Java update?

Healer
I unchecked the options of "Check for Updates Automatically" on the Java control Panel and then clicked on "OK". However every time I opened the Java Control Panel again, the option of "Check for Updates Automatically" still remained checked.

Then I went to select "Never Auto-Download" under JRE Auto-Download on the Advanced tab. It seemed to have done the similar job.

I still wonder why I can't have the option of "Check for Updates Automatically" remain unchecked. This scenario seems to occur on all Windows operating systems.
  • +
    0 Votes

    Try

    santeewelding

    "msconfig" in Run for the recalcitrant. "Services", too. There are also any number of third-party apps to squelch what offends thee.

    +
    0 Votes
    Healer

    I did disable the Java service. Is that all what I need to do? Don't I still need to ensure that the option of "Check for Updates Automatically" be remained unchecked?

    +
    0 Votes
    Jaqui

    java update doesn't work
    completely uninstall java.
    it's a garbage language that shouldn't be used anyway.

    +
    0 Votes
    Healer

    some applications and of some web sites do need the Java Runtime to work.

    +
    0 Votes
    santeewelding

    A Mozilla-based browser, like Firefox (which I do), the NoScript add-on allows you to throttle Java scripts at will with the option, "Temporarily allow all this page".

    +
    0 Votes
    seanferd

    It is best to know that Java and Javascript are no relation.

    +
    0 Votes
    santeewelding

    Nailed to wall.

    +
    0 Votes
    Healer

    between Java and JavaScript. I know most web sites use JavaScript and some do use Java as well. I have designed some web sites that involve both languages.

    +
    0 Votes
    Healer

    with the FireFox. However, I have found it so inconvenient that I eventually disabled or uninstalled it because most web sites use JavaScript.

    +
    0 Votes
    seanferd

    Although I've had some trouble keeping one or another Java function from auto-starting (because the settings seem to go back to the defaults with every update), I've always been able to kill them. Unfortunately, I'm stuck on a laptop with no Java installed for reference because the cable for my keyboard died, I believe you have found the three important bits to kill. (You might want to kill the Java quick start service, too.)

    You might have a registry permissions problem (setting doesn't save) even if you are the Administrator. Or, you might have security-type software that thinks it knows better than you about having auto update turned on (setting get changed back).

    The Sysinternals Autoruns app can help here, maybe by exposing a setting or by showing where you might not have have permissions to change a setting somehow.

    +
    0 Votes
    Healer

    Whatever I have done seems to have prevented the automatic update. I am just wondering why the option of "Check for Updates Automatically" appearing optional and the users having the choice of allowing or disallowing it, never can I remove the tick, i.e. deselect, for the option. It is somewhat weird.

    +
    0 Votes
    seanferd

    I had it do the same to me. I think if you kill the service or one of the other settings first, that setting is disabled but its appearance reflects the state of that setting before the code that controls it was killed. Or it is a permissions issue, but you've killed the service so it won't run anyway.

    edit: laptop keyboard & touchpad. grr

    +
    0 Votes
    Healer

    for reinforcing my thinking.

    +
    0 Votes
    Kenone

    Run C:\Program Files\Java\jre6\bin\javacpl.exe with Administrator priviledges. Uncheck "Check for updates Automatically" and click on "Never Check" - This usually works. Or
    You can disable the update at;
    HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy\EnableJavaUpdate
    Of course if we're talking 64 bit systems then everything will be different. But the 64 bit machines don't usually have this problem.

    +
    0 Votes
    Healer

    Thanks! It is very helpful and it works.

    Having run the C:\Program Files\Java\jre6\bin\javacpl.exe with Administrator privileges I managed to have the offending option remain de-selected.

    Also the settings seem to be user-specific, not global. One has to go through every user and do the same in order to completely prevent the automatic update.

    After I set HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy\EnableJavaUpdate to zero, the Update pane simply disappears. I am not too sure what it means though. Does it mean the update option is totally disabled and unavailable or the update option is hidden but whatever state it had been set would remain in effect?

    When it comes to x64 machine I have similar file structure under C:\Program Files\ and C:\Program Files (x86)\. The file javacpl.exe in both folders are different in size, so I suppose they are not identical.

    The HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy\EnableJavaUpdate only applies to C:\Program Files\Java\jre6\bin\javacpl.exe though.

    +
    0 Votes
    ganesan.kuppusamy

    Open your computer's control panel>double click on the icon "Java" and open it> click the top tab "Update">Untick the option "Check for updates automatically" - that's it

    Thanks and Regards,

    http://serveradministrators.blogspot.com/

    +
    0 Votes
    seanferd

    You didn't read the question or the rest of the thread, did you?

    +
    0 Votes
    Healer

    The option having been de-selected would have itself immediately selected again. Please see my posts above.

    +
    0 Votes
    Jaqui

    java update doesn't work
    completely uninstall java.
    it's a garbage language that shouldn't be used anyway.

    +
    0 Votes
    seanferd

    Although I've had some trouble keeping one or another Java function from auto-starting (because the settings seem to go back to the defaults with every update), I've always been able to kill them. Unfortunately, I'm stuck on a laptop with no Java installed for reference because the cable for my keyboard died, I believe you have found the three important bits to kill. (You might want to kill the Java quick start service, too.)

    You might have a registry permissions problem (setting doesn't save) even if you are the Administrator. Or, you might have security-type software that thinks it knows better than you about having auto update turned on (setting get changed back).

    The Sysinternals Autoruns app can help here, maybe by exposing a setting or by showing where you might not have have permissions to change a setting somehow.

    +
    0 Votes
    Kenone

    Run C:\Program Files\Java\jre6\bin\javacpl.exe with Administrator priviledges. Uncheck "Check for updates Automatically" and click on "Never Check" - This usually works. Or
    You can disable the update at;
    HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy\EnableJavaUpdate
    Of course if we're talking 64 bit systems then everything will be different. But the 64 bit machines don't usually have this problem.

    +
    0 Votes
    ganesan.kuppusamy

    Open your computer's control panel>double click on the icon "Java" and open it> click the top tab "Update">Untick the option "Check for updates automatically" - that's it

    Thanks and Regards,

    http://serveradministrators.blogspot.com/

  • +
    0 Votes

    Try

    santeewelding

    "msconfig" in Run for the recalcitrant. "Services", too. There are also any number of third-party apps to squelch what offends thee.

    +
    0 Votes
    Healer

    I did disable the Java service. Is that all what I need to do? Don't I still need to ensure that the option of "Check for Updates Automatically" be remained unchecked?

    +
    0 Votes
    Jaqui

    java update doesn't work
    completely uninstall java.
    it's a garbage language that shouldn't be used anyway.

    +
    0 Votes
    Healer

    some applications and of some web sites do need the Java Runtime to work.

    +
    0 Votes
    santeewelding

    A Mozilla-based browser, like Firefox (which I do), the NoScript add-on allows you to throttle Java scripts at will with the option, "Temporarily allow all this page".

    +
    0 Votes
    seanferd

    It is best to know that Java and Javascript are no relation.

    +
    0 Votes
    santeewelding

    Nailed to wall.

    +
    0 Votes
    Healer

    between Java and JavaScript. I know most web sites use JavaScript and some do use Java as well. I have designed some web sites that involve both languages.

    +
    0 Votes
    Healer

    with the FireFox. However, I have found it so inconvenient that I eventually disabled or uninstalled it because most web sites use JavaScript.

    +
    0 Votes
    seanferd

    Although I've had some trouble keeping one or another Java function from auto-starting (because the settings seem to go back to the defaults with every update), I've always been able to kill them. Unfortunately, I'm stuck on a laptop with no Java installed for reference because the cable for my keyboard died, I believe you have found the three important bits to kill. (You might want to kill the Java quick start service, too.)

    You might have a registry permissions problem (setting doesn't save) even if you are the Administrator. Or, you might have security-type software that thinks it knows better than you about having auto update turned on (setting get changed back).

    The Sysinternals Autoruns app can help here, maybe by exposing a setting or by showing where you might not have have permissions to change a setting somehow.

    +
    0 Votes
    Healer

    Whatever I have done seems to have prevented the automatic update. I am just wondering why the option of "Check for Updates Automatically" appearing optional and the users having the choice of allowing or disallowing it, never can I remove the tick, i.e. deselect, for the option. It is somewhat weird.

    +
    0 Votes
    seanferd

    I had it do the same to me. I think if you kill the service or one of the other settings first, that setting is disabled but its appearance reflects the state of that setting before the code that controls it was killed. Or it is a permissions issue, but you've killed the service so it won't run anyway.

    edit: laptop keyboard & touchpad. grr

    +
    0 Votes
    Healer

    for reinforcing my thinking.

    +
    0 Votes
    Kenone

    Run C:\Program Files\Java\jre6\bin\javacpl.exe with Administrator priviledges. Uncheck "Check for updates Automatically" and click on "Never Check" - This usually works. Or
    You can disable the update at;
    HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy\EnableJavaUpdate
    Of course if we're talking 64 bit systems then everything will be different. But the 64 bit machines don't usually have this problem.

    +
    0 Votes
    Healer

    Thanks! It is very helpful and it works.

    Having run the C:\Program Files\Java\jre6\bin\javacpl.exe with Administrator privileges I managed to have the offending option remain de-selected.

    Also the settings seem to be user-specific, not global. One has to go through every user and do the same in order to completely prevent the automatic update.

    After I set HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy\EnableJavaUpdate to zero, the Update pane simply disappears. I am not too sure what it means though. Does it mean the update option is totally disabled and unavailable or the update option is hidden but whatever state it had been set would remain in effect?

    When it comes to x64 machine I have similar file structure under C:\Program Files\ and C:\Program Files (x86)\. The file javacpl.exe in both folders are different in size, so I suppose they are not identical.

    The HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy\EnableJavaUpdate only applies to C:\Program Files\Java\jre6\bin\javacpl.exe though.

    +
    0 Votes
    ganesan.kuppusamy

    Open your computer's control panel>double click on the icon "Java" and open it> click the top tab "Update">Untick the option "Check for updates automatically" - that's it

    Thanks and Regards,

    http://serveradministrators.blogspot.com/

    +
    0 Votes
    seanferd

    You didn't read the question or the rest of the thread, did you?

    +
    0 Votes
    Healer

    The option having been de-selected would have itself immediately selected again. Please see my posts above.

    +
    0 Votes
    Jaqui

    java update doesn't work
    completely uninstall java.
    it's a garbage language that shouldn't be used anyway.

    +
    0 Votes
    seanferd

    Although I've had some trouble keeping one or another Java function from auto-starting (because the settings seem to go back to the defaults with every update), I've always been able to kill them. Unfortunately, I'm stuck on a laptop with no Java installed for reference because the cable for my keyboard died, I believe you have found the three important bits to kill. (You might want to kill the Java quick start service, too.)

    You might have a registry permissions problem (setting doesn't save) even if you are the Administrator. Or, you might have security-type software that thinks it knows better than you about having auto update turned on (setting get changed back).

    The Sysinternals Autoruns app can help here, maybe by exposing a setting or by showing where you might not have have permissions to change a setting somehow.

    +
    0 Votes
    Kenone

    Run C:\Program Files\Java\jre6\bin\javacpl.exe with Administrator priviledges. Uncheck "Check for updates Automatically" and click on "Never Check" - This usually works. Or
    You can disable the update at;
    HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy\EnableJavaUpdate
    Of course if we're talking 64 bit systems then everything will be different. But the 64 bit machines don't usually have this problem.

    +
    0 Votes
    ganesan.kuppusamy

    Open your computer's control panel>double click on the icon "Java" and open it> click the top tab "Update">Untick the option "Check for updates automatically" - that's it

    Thanks and Regards,

    http://serveradministrators.blogspot.com/