Questions

HP laptops won't image

+
0 Votes
Locked

HP laptops won't image

lfruchter
Hello Sages,

I run a school network of laptops, mostly Dell Latitudes (with some incredibly annoying Lenovo r60s thrown in), imaging, wiping and restoring them all with a slow but tried and true Ghost 8 CD and external HD to hold the images. (Yes, some day I will graduate to doing this over a network, but up to now I've been keeping up this way.)

With budget cuts, I thought I'd save the school money by purchasing some less expensive (did I say "cheaper"?) HP laptops, the ProBook 6440b. The trouble is, these machines won't play nicely with my Ghost CD.

I can start a machine up from the CD with the external USB HD plugged in and launch Ghost 8.0, but when I try to use it to create an image of the ProBook's HD, the only local source drive that shows up on the menu is my USB drive. Likewise, if I proceed as if I were trying to restore an image to the ProBook from the USB drive, Ghost displays all the local drives including the ProBook's 2 partitions as possible sources, but after I select an image from my USB drive, only the USB drive is offered as a local destination drive, not the ProBook's HD.

Has HP configured these ProBooks so that they cannot be Ghosted? Is there a way to change these settings so that I can backup my laptop? If there's no way to force these HPs to cooperate with Ghost 8, is there a more powerful imaging tool with which I could kick their butts into conformity?

Thanks much for any advice,
Lev in Brooklyn

Clarifications

bobspipe

Did you ever get an answer that worked for you? We're having a similar problem here with our new ProBook 6440b laptops. We also use Ghost 8.2 and an external HD to hold our images. Going into BIOS and changing from AHCI to IDE does not solve the problem.

  • +
    0 Votes
    OH Smeg

    Ghost 8 is getting more than a bit long in the tooth these days so it's probably the problem here.

    I would say that it doesn't have support for the SATA Driver that is used in these devices and you would have to add it to the Boot Option just like you have to add the USB Support. But instead of the USB Driver chose the SATA Driver to add.

    Perhaps there is someone here with a lot more Ghost Experience than me who knows more about this but it really sounds like the Cloning Utility doesn't support the M'Board Chip Set.

    Col

    +
    0 Votes
    markp24

    Hello,
    I have run accriss similar issues, found that i needed to add the SATA drivers in the Intel storage matrix for HP download.
    I changed to use Drive image XML (freeware) from a UBCD4win (Freeware). I used an HP windows XP cd with SP# sliptreamed along with the Drivers for HP and Dells (did it with "NLITE"), so it had all the ones it needs.

    You may want to take a look at acronis for a newer imaging solution.

    hope that helps.

    hope that helps

    +
    0 Votes
    dave

    Can't say for the Dell laptops, but I have used Ghost 8.0 with newer Dell desktops with SATA drives by going in to the BIOS and setting the drives to compatibility mode, ghosting, then turning the setting back to default. Don't know if there is a similar setting in the laptops. Really though, the ghost version is a bit old.

    +
    0 Votes
    jdaughtry

    You can run the computer in compatibility/IDE mode if the image has those drivers built into it, but you give up the ability to attach eSATA drives. Alternatively I found that the very latest UBCD4Win utility contains the AHCI drivers so that may solve the problem too.

    +
    0 Votes
    brian

    Be sure that the hard drive options in BIOS are set to SATA and not to AHCI. While using Ghost 2003 on Dell Systems, I have ran into that exact problem, changed the hard drive settings in BIOS from AHCI to SATA and works like a charm.

    +
    0 Votes
    NoisePollution

    We recently switched from another brand to the HP EliteBook 8440w and ran into the same issue. The problem is with the drivers for the SATA drive.
    You can switch to IDE compatiblity mode in the BIOS, and then you should be able to image/access the local hard drive without having the SATA drivers. However, I have found that the performance of these laptops is fairly degraded in IDE compatibility mode, and has a very negative impact on boot times if connected to a docking station.
    If you install under compatibility mode, you are supposed to be able to update the driver with the SATA drivers, reboot, swith back to SATA/AHCI in the BIOS and then you will be running in SATA instead of compbatility mode. However, I have yet to have any luck with switching back.
    In my opinion the best thing to do is to slipstream/inject the SATA drivers into your ISO and install it native in SATA mode.
    The simplest solution is to use the CDs from HP to install the OS, because they have already added the SATA drivers to it. Then change the product key to your volume key, if needed. Clean up the install and create your image with it.
    If you contact HP they can send you instructions for adding SATA support/drivers (converting from IDE Compat mode to SATA, via Sysprep, ISO, local machine, RIS, etc).

  • +
    0 Votes
    OH Smeg

    Ghost 8 is getting more than a bit long in the tooth these days so it's probably the problem here.

    I would say that it doesn't have support for the SATA Driver that is used in these devices and you would have to add it to the Boot Option just like you have to add the USB Support. But instead of the USB Driver chose the SATA Driver to add.

    Perhaps there is someone here with a lot more Ghost Experience than me who knows more about this but it really sounds like the Cloning Utility doesn't support the M'Board Chip Set.

    Col

    +
    0 Votes
    markp24

    Hello,
    I have run accriss similar issues, found that i needed to add the SATA drivers in the Intel storage matrix for HP download.
    I changed to use Drive image XML (freeware) from a UBCD4win (Freeware). I used an HP windows XP cd with SP# sliptreamed along with the Drivers for HP and Dells (did it with "NLITE"), so it had all the ones it needs.

    You may want to take a look at acronis for a newer imaging solution.

    hope that helps.

    hope that helps

    +
    0 Votes
    dave

    Can't say for the Dell laptops, but I have used Ghost 8.0 with newer Dell desktops with SATA drives by going in to the BIOS and setting the drives to compatibility mode, ghosting, then turning the setting back to default. Don't know if there is a similar setting in the laptops. Really though, the ghost version is a bit old.

    +
    0 Votes
    jdaughtry

    You can run the computer in compatibility/IDE mode if the image has those drivers built into it, but you give up the ability to attach eSATA drives. Alternatively I found that the very latest UBCD4Win utility contains the AHCI drivers so that may solve the problem too.

    +
    0 Votes
    brian

    Be sure that the hard drive options in BIOS are set to SATA and not to AHCI. While using Ghost 2003 on Dell Systems, I have ran into that exact problem, changed the hard drive settings in BIOS from AHCI to SATA and works like a charm.

    +
    0 Votes
    NoisePollution

    We recently switched from another brand to the HP EliteBook 8440w and ran into the same issue. The problem is with the drivers for the SATA drive.
    You can switch to IDE compatiblity mode in the BIOS, and then you should be able to image/access the local hard drive without having the SATA drivers. However, I have found that the performance of these laptops is fairly degraded in IDE compatibility mode, and has a very negative impact on boot times if connected to a docking station.
    If you install under compatibility mode, you are supposed to be able to update the driver with the SATA drivers, reboot, swith back to SATA/AHCI in the BIOS and then you will be running in SATA instead of compbatility mode. However, I have yet to have any luck with switching back.
    In my opinion the best thing to do is to slipstream/inject the SATA drivers into your ISO and install it native in SATA mode.
    The simplest solution is to use the CDs from HP to install the OS, because they have already added the SATA drivers to it. Then change the product key to your volume key, if needed. Clean up the install and create your image with it.
    If you contact HP they can send you instructions for adding SATA support/drivers (converting from IDE Compat mode to SATA, via Sysprep, ISO, local machine, RIS, etc).