Questions

IBM R40 Laptop numlock on when XP starts

Tags:
+
0 Votes
Locked

IBM R40 Laptop numlock on when XP starts

bitbucketboy
Help a geek out - I've tried setting the numlock to off and auto in the BIOS to no avail. The numlock comes on at about the same time you first see the desktop. I can find no setting to control this behavior, although I am suspicious of the IBM Thinkpad bundled software...

It is running XP pro in a domain, no group policy, no roaming profile.

Thanks in advance.
  • +
    0 Votes

    Have a look in "control panel > keyboard > settings", you might be able to change it there. the other way is in the "bios" but make sure that you have selected "disable" and then "save and exit", if you did not do the latter then it would not be saved. Hope this helps you. Please post back if you have anymore problems or questions.

    +
    0 Votes
    O/Siris

    I realize you posted this a long time ago, but maybe this helps someone else searching:

    There is a Registry Entry that can be set to enable auto-numlock, and it overrides BIOS settings.

    Start REGEDIT, and then go to HKEY_USERS/.DEFAULT/Control Panel/Keyboard.

    You should see an item called InitialKeyboardIndicators. It's probably at 2. Set it to 0. 2 turns it on automatically at logon. 0 should turn it off. Even if BIOS is set to auto or on.

    +
    0 Votes

    Try this out..

    The numeric keypad on the keyboard is enabled. To enable or disable the keypad, press and hold the Shift key, and press the NumLk (ScrLk) key.

    Please post back if you have any more problems or questions.
    If this information is useful, please mark as helpful. Thanks.

  • +
    0 Votes

    Have a look in "control panel > keyboard > settings", you might be able to change it there. the other way is in the "bios" but make sure that you have selected "disable" and then "save and exit", if you did not do the latter then it would not be saved. Hope this helps you. Please post back if you have anymore problems or questions.

    +
    0 Votes
    O/Siris

    I realize you posted this a long time ago, but maybe this helps someone else searching:

    There is a Registry Entry that can be set to enable auto-numlock, and it overrides BIOS settings.

    Start REGEDIT, and then go to HKEY_USERS/.DEFAULT/Control Panel/Keyboard.

    You should see an item called InitialKeyboardIndicators. It's probably at 2. Set it to 0. 2 turns it on automatically at logon. 0 should turn it off. Even if BIOS is set to auto or on.

    +
    0 Votes

    Try this out..

    The numeric keypad on the keyboard is enabled. To enable or disable the keypad, press and hold the Shift key, and press the NumLk (ScrLk) key.

    Please post back if you have any more problems or questions.
    If this information is useful, please mark as helpful. Thanks.