Questions

IE8 Homepage not getting set by GPO

+
0 Votes
Locked

IE8 Homepage not getting set by GPO

Bizzo
Hi Guys,

Not posted here for a while, I hope you can help me.

I have a domain with 2 DCs and numerous member servers, the DCs are 2003, and the servers are mixed 2003/2008.

I have a requirement to amend the IE homepage for anyone logging on to any server, from say http://old.site.com to http://new.site.com. So I amended the existing GPO(User Configuration -> Windows Settings -> Internet Explorer Maintenance -> URLs -> Important URLs -> Home page URL) to http://new.site.com

Logged onto one of the 2003 servers with IE6, and the change worked, the new home page was OK. Logged onto a 2008 server with IE8, was still showing the old one.

I've run gpupdate /force with no effect, I'm unable to reboot the servers as they are in production.

RSOP says the homepage is correct (http://new.site.com), and it's picking it up from the correct GPO, but IE8 still opens http://old.site.com.
I've checked the inetres.adm file on the server, and it appears to be the correct one for IE8, in fact I've copied the file from another server c:\windows\ie8 to make sure it's the right one, and the template is showing as installed in the GPO editor.

So the upshot is:
2003 with IE6 works OK
2003 with IE8 fails
2008 with IE8 fails

I've run gpresult, and checked the GPOs that are applied, none of them have the URL defined.

So I'm assuming it's an IE8 problem, and unless I'm missing something glaringly obvious, I've come to an end.

Any ideas?

Thanks.
  • +
    1 Votes
    scndtnr

    ...did you import settings? Configuring GP for IE can be a minefield if not done correctly. My suggestion is to configure IE 8 as you want it, then make sure you import the settings when you edit the GP. It will be easier to do this if you're running GPM on the same DC as the one running IE 8.

    +
    0 Votes
    Bizzo

    Thanks for that, I'll check it out tomorrow and let you know how I get on.

    +
    0 Votes
    vincentjzhu

    A bit late in responding, you've probably solved this by now, but I figure I'll post this alternate option for anyone else looking for another option.

    If your users don't need to set their own homepages, edit your favorite GPO as follows:
    User Configuration -> Windows Components -> Internet Explorer -> Disable changing home page settings (Enabled with http://new.site.com as the chosen home page).

  • +
    1 Votes
    scndtnr

    ...did you import settings? Configuring GP for IE can be a minefield if not done correctly. My suggestion is to configure IE 8 as you want it, then make sure you import the settings when you edit the GP. It will be easier to do this if you're running GPM on the same DC as the one running IE 8.

    +
    0 Votes
    Bizzo

    Thanks for that, I'll check it out tomorrow and let you know how I get on.

    +
    0 Votes
    vincentjzhu

    A bit late in responding, you've probably solved this by now, but I figure I'll post this alternate option for anyone else looking for another option.

    If your users don't need to set their own homepages, edit your favorite GPO as follows:
    User Configuration -> Windows Components -> Internet Explorer -> Disable changing home page settings (Enabled with http://new.site.com as the chosen home page).