Questions

Keyboard types uppercase when caps lock not on

Tags:
+
0 Votes
Locked

Keyboard types uppercase when caps lock not on

joshuakmbl
Keyboard types uppercase when caps lock not on and types lowercase when I hold down the shift key, again with caps lock not on. Even types out the symbols above the numbers like caps lock is on or shift key being held. It does the opposite of what it is supposed to do. Just started recently and it's a laptop.
  • +
    0 Votes
    HAL 9000 Moderator

    Plug in that External Keyboard that was being used and turn off the Caps Lock and things should be back to normal.

    Col

    +
    0 Votes
    cdoubleu99

    I am having the same problem but I have never used an external keyboard. The problem usually happens right after I boot up the computer or if it has been on stand-by for a while. Any ideas on how to stop this from happening??

    +
    0 Votes
    HAL 9000 Moderator

    And see if the problem persists. If it does you have a hardware problem which could be a faulty keyboard but is more likely to be the Keyboard IO Interface.

    If the problem doesn't happen with Linux running off a CD then you have a Windows problem with your keyboard drivers.

    If you like you should be able to walk into any Newsagent and get a Linux Mag with a Live Linux as a cover CD or if you want the flexibility of being able to use a Live Linux to repair Windows Problems then I suggest that you either download or buy a copy of Knoppix STD which is available from here.

    http://tinyurl.com/23nmq

    Col

    +
    0 Votes
    joshuakmbl

    Thanks.

    +
    0 Votes
    kandy2kane

    Hi, I'm having this same issue on a number of Dell 620 machines. Issue is sporatic. Sometime it happens and sometimes it doesn't. Keyboard would all of the sudden type in upper case, when the CAPS lock is not on. Even more strange, is when you press one of the number on the number rows on top, the symbols comes out, like if the shift key is stuck. In addition, when I click on 1 file to select it, it selects all the files. Like i'm selecting multiple files, but I only want to select just 1. Only a reboot temporary fixes the problem. then it just randomly comes back.

    Anyone have Any suggestions?

    +
    0 Votes
    sgt_shultz

    look in Control Panel/Accessibility Options

    +
    0 Votes
    kandy2kane

    Thanks for you reply. But the sticky key feature is off and disabled.

    +
    0 Votes
    HAL 9000 Moderator

    So it wouldn't hurt to try a Live Linux and see if the problem persists. If it dose you have a Faulty Keyboard Interface and need a new M'Board for each of the affected machines.

    You can download a Live Linux from here and boot off the CD without affecting your installed OS in any way and it's a good Hardware Test.

    http://preview.tinyurl.com/23nmq

    If you want something quick & fast Puppy Linux will do nicely to test several machines on but if you want a tool that you can use to repair Windows Installations with Knoppix STD would be your best choice.

    Col

    +
    0 Votes
    blastocyst04

    try this steps first, if you have another keyboard, try use it in your computer. maybe your keyboard is damaged so you have need to replace it.

    +
    0 Votes
    kandy2kane

    It seems to be an issue with Dell 620. Other users are having this problem as well. Some suggested replacing the external PS2 keyboard with a USB keyboard and it worked for them.

    My scenario is similar, all the people that are having this issue are using PS2 keyboards. The users with Dell 620 that are not having this issue have USB keybaords. Even though we tried giving the user a new laptop, and with another PS2 keyboard, the issue would still re-appear. Didn't think it would be a USB/PS2 issue.

    Going to try and replace the keyboards with USB keyboards and see if the issue comes back for those users. I'll keep you posted on the result.

    http://www.dellcommunity.com/supportforums/board/message?board.id=insp_general&view=by_date_ascending&message.id=241782&c=us&l=en&cs=&s=gen

    Want to thank all that respondes. This is my 1st time using this Forum, and it has been very helpful, you have been very helpful.

    Thanks.

    +
    0 Votes

    I havnt read all the post someone my have alredy suggested this! Sounds like you have sticky keys on. Press shift 5 times this will allow you to turn it on & off

    +
    2 Votes
    whalens

    This just happened to me on my husband's laptop. Holding down both shift keys at the same time fixed it.

    I don't know why. I thought I'd post just in case that works for anyone else who ends up having this problem.

    +
    0 Votes
    alphatech9

    On my HP DV5000 laptop, this happens on occasion. For me it generally goes back to normal when I either click out of whatever interface I'm in (blog, MS_WORD etc...) and in the worst case scenarios I need to reboot...

    I don't know what causes it, or what fixes it...

    +
    0 Votes
    ctwyatt

    I have run across this problem a few times. One of the Shift keys is stuck down, although it may not appear so. It makes it appear that caps lock is doing the opposite of what it should. An easy check is to hit tab key, it will go backwards. I am also guessing here, but it is probable that depending on what app you are in both shift keys down would cancel each other.

    +
    0 Votes
    tbtech2003

    I was just having this problem on my PC and holding both shift keys down worked. Thanks

    +
    1 Votes
    MSVideoPro05

    I had the same problem. I read someone else's response to this and they said to depress both shift keys at the same time. This works! My keyboard is back to normal again. Try it!

    +
    0 Votes
    epchav

    It worked perfectly on my 710m. I keep having the same problem. I guarantee this will fix th eproblem. At first I thought I had a trojan or a keylogger on my system. I don't know what causes this, but it seems to be a problem with most DELLS INSPIRON LAPTOPS UP TO 710m.

    +
    1 Votes
    bam66

    Holding down both shift keys at the same time worked for me.
    I tried;
    unchecking sticky keys from accessibility options
    Esc button
    hitting shift 5 times
    shutting down all programs and docs
    restarting
    Nothing else worked except pushing both shift keys at one time. My next option was to try a different keyboard. I don't know how I got into this but it's gone now.
    I am thanking God I found this site and this answer. I am in the 11th hour of my college classes with the final due today. Thanks so much.

    +
    0 Votes
    abcshova

    Yes it also worked for me, thanks for everyone.Hope this won't come back again.

  • +
    0 Votes
    HAL 9000 Moderator

    Plug in that External Keyboard that was being used and turn off the Caps Lock and things should be back to normal.

    Col

    +
    0 Votes
    cdoubleu99

    I am having the same problem but I have never used an external keyboard. The problem usually happens right after I boot up the computer or if it has been on stand-by for a while. Any ideas on how to stop this from happening??

    +
    0 Votes
    HAL 9000 Moderator

    And see if the problem persists. If it does you have a hardware problem which could be a faulty keyboard but is more likely to be the Keyboard IO Interface.

    If the problem doesn't happen with Linux running off a CD then you have a Windows problem with your keyboard drivers.

    If you like you should be able to walk into any Newsagent and get a Linux Mag with a Live Linux as a cover CD or if you want the flexibility of being able to use a Live Linux to repair Windows Problems then I suggest that you either download or buy a copy of Knoppix STD which is available from here.

    http://tinyurl.com/23nmq

    Col

    +
    0 Votes
    joshuakmbl

    Thanks.

    +
    0 Votes
    kandy2kane

    Hi, I'm having this same issue on a number of Dell 620 machines. Issue is sporatic. Sometime it happens and sometimes it doesn't. Keyboard would all of the sudden type in upper case, when the CAPS lock is not on. Even more strange, is when you press one of the number on the number rows on top, the symbols comes out, like if the shift key is stuck. In addition, when I click on 1 file to select it, it selects all the files. Like i'm selecting multiple files, but I only want to select just 1. Only a reboot temporary fixes the problem. then it just randomly comes back.

    Anyone have Any suggestions?

    +
    0 Votes
    sgt_shultz

    look in Control Panel/Accessibility Options

    +
    0 Votes
    kandy2kane

    Thanks for you reply. But the sticky key feature is off and disabled.

    +
    0 Votes
    HAL 9000 Moderator

    So it wouldn't hurt to try a Live Linux and see if the problem persists. If it dose you have a Faulty Keyboard Interface and need a new M'Board for each of the affected machines.

    You can download a Live Linux from here and boot off the CD without affecting your installed OS in any way and it's a good Hardware Test.

    http://preview.tinyurl.com/23nmq

    If you want something quick & fast Puppy Linux will do nicely to test several machines on but if you want a tool that you can use to repair Windows Installations with Knoppix STD would be your best choice.

    Col

    +
    0 Votes
    blastocyst04

    try this steps first, if you have another keyboard, try use it in your computer. maybe your keyboard is damaged so you have need to replace it.

    +
    0 Votes
    kandy2kane

    It seems to be an issue with Dell 620. Other users are having this problem as well. Some suggested replacing the external PS2 keyboard with a USB keyboard and it worked for them.

    My scenario is similar, all the people that are having this issue are using PS2 keyboards. The users with Dell 620 that are not having this issue have USB keybaords. Even though we tried giving the user a new laptop, and with another PS2 keyboard, the issue would still re-appear. Didn't think it would be a USB/PS2 issue.

    Going to try and replace the keyboards with USB keyboards and see if the issue comes back for those users. I'll keep you posted on the result.

    http://www.dellcommunity.com/supportforums/board/message?board.id=insp_general&view=by_date_ascending&message.id=241782&c=us&l=en&cs=&s=gen

    Want to thank all that respondes. This is my 1st time using this Forum, and it has been very helpful, you have been very helpful.

    Thanks.

    +
    0 Votes

    I havnt read all the post someone my have alredy suggested this! Sounds like you have sticky keys on. Press shift 5 times this will allow you to turn it on & off

    +
    2 Votes
    whalens

    This just happened to me on my husband's laptop. Holding down both shift keys at the same time fixed it.

    I don't know why. I thought I'd post just in case that works for anyone else who ends up having this problem.

    +
    0 Votes
    alphatech9

    On my HP DV5000 laptop, this happens on occasion. For me it generally goes back to normal when I either click out of whatever interface I'm in (blog, MS_WORD etc...) and in the worst case scenarios I need to reboot...

    I don't know what causes it, or what fixes it...

    +
    0 Votes
    ctwyatt

    I have run across this problem a few times. One of the Shift keys is stuck down, although it may not appear so. It makes it appear that caps lock is doing the opposite of what it should. An easy check is to hit tab key, it will go backwards. I am also guessing here, but it is probable that depending on what app you are in both shift keys down would cancel each other.

    +
    0 Votes
    tbtech2003

    I was just having this problem on my PC and holding both shift keys down worked. Thanks

    +
    1 Votes
    MSVideoPro05

    I had the same problem. I read someone else's response to this and they said to depress both shift keys at the same time. This works! My keyboard is back to normal again. Try it!

    +
    0 Votes
    epchav

    It worked perfectly on my 710m. I keep having the same problem. I guarantee this will fix th eproblem. At first I thought I had a trojan or a keylogger on my system. I don't know what causes this, but it seems to be a problem with most DELLS INSPIRON LAPTOPS UP TO 710m.

    +
    1 Votes
    bam66

    Holding down both shift keys at the same time worked for me.
    I tried;
    unchecking sticky keys from accessibility options
    Esc button
    hitting shift 5 times
    shutting down all programs and docs
    restarting
    Nothing else worked except pushing both shift keys at one time. My next option was to try a different keyboard. I don't know how I got into this but it's gone now.
    I am thanking God I found this site and this answer. I am in the 11th hour of my college classes with the final due today. Thanks so much.

    +
    0 Votes
    abcshova

    Yes it also worked for me, thanks for everyone.Hope this won't come back again.