Questions

Micosoft Windows network (XP HOME)

Tags:
+
0 Votes
Locked

Micosoft Windows network (XP HOME)

Dillon.damien
Hi,
I am trying to set up a home network to share files in 'My Network Places'.

I am using a Netgear router and two laptops (both running XP Home) connected via wireless to the router.

I have run the network setup wizard on both laptops. File/printer sharing is turned on and both laptops are on the same workgroup ('Computerroom').

Laptop 1: In 'My Network Places-Entire Network-Microsoft windows network-computerroom' I can see laptop 2 but cannot access it.

Laptop 2: In 'My Network Places-Entire Network-Microsoft windows network' I cannot access the computerroom folder at all.

I am running McAfee on both laptops and the network has been flagged as trusted.

Can anyone give me an insight into what I might have missed in order to access the shared folders on both laptops?

Thanks!
  • +
    0 Votes
    robo_dev

    there are two types of file sharing, normal and simple. Unless you choose 'simple' then you must have a userid that has a password on each PC for data to be shared.

    There is a 'simple file sharing mode' that does not need a password.

    Do you have a defined userid for each PC that has a password?

    http://www.practicallynetworked.com/sharing/xp/filesharing.htm

    Can each PC ping the other one via both IP and hostname?

    +
    0 Votes
    dixon

    1)Make sure McAfee's excepions list includes the IPs of the two machines. 2) Compare the network protocol list for each machine's network connection, and make sure they match exactly. That's a really common source of the exact problem you're describing, especially with XP Home. Good luck!

    +
    0 Votes
    computechdan

    xp pro supports both types

    +
    0 Votes
    dixon

    ...but, although it's a bit of a pain, you can log on in Safe Mode as Administrator and find that many of the Pro style sharing and permissions options are then magically enabled in Windows Explorer. I've used that trick quite a bit in solving weird XP Home networking problems.

    +
    0 Votes
    computechdan

    the "shared" folder is intended to be shared only with other users of the SAME computer.

    if you wish to share a folder either create a new folder on each laptop or choose an existing folder then right click the folder, left click sharing and security, then check the box to "share this folder on the network".

    if you want to be able to write to the folder u have to check the box "allow network users to change my files"

    after this is done you should have access to it from the other computer.

    don't forget to "mark as helpful" any post that u find useful.

    +
    0 Votes
    Dillon.damien

    Thanks for all your tips. But it is still not working.

    McAfee is set to trust all IP addresses between 192.168.1.0 - 192.168.1.255. How do I compare the network protocol lists?

    I have shared a folder in 'My Documents' (Sharing and Security - Share this folder on the network) but it was still not available on the other laptop (in 'My Network Places').

    This is the second Home network I am trying to set up. The first one I set up worked perfectly. As far as I am aware I followed the same procedure. The only difference is the router (Linksys worked, Netgear did not).

    Laptop 1 will be used on both networks. Laptop 1 currently works perfectly on the first LAN (All shared docs can be seen and accessed by other computers on the network. I can print 'wirelessly' over the network as well via a PC which is connected to the router through ethernet). However when I try it on the second LAN the other computers cannot see these same shared docs.

    Is it possible that something needs to be configured on the wireless router?

    +
    0 Votes
    dixon

    Start --> Control Panel --> Network Connections --> Local Area Connection --> Properties. Look at the list in the box labeled "This connection uses the following items." Make sure both machines are using the same list. Disable or enable as needed until they match. To simplify things, you might start by using only "Client for Microsoft Networks", "File and Printer Sharing for Microsoft Networks", "QoS Packet Scheduler", and "Internet Protocol (TCP/IP)" on both machines.

    +
    0 Votes
    dixon

    ...that, if that doesn't help, try the following, on both machines: Start --> Control Panel --> Network Connections --> Local Area Connection --> Properties --> Install --> Protocol. Select "NW Link IPX/SPX/NetBIOS Compatible Transport Protocol" and click "OK". I've had a few cases over the years where that fixed your kind of problem

    +
    0 Votes
    Dillon.damien

    I will check those, I won't have access to the LAN in question today but will post back the results.

    +
    0 Votes
    computechdan

    on each of the machines...
    start, run, msinfo32, note the system name

    then start, run, cmd and attempt to ping the other machine by it's name

    in the cmd window type: ping computername then hit enter.
    replace computername with the system name of the other computer as u noted above

    if it replies u have connectivity.

    if not attempt to ping it by it's ip address.

    using the same cmd window type ipconfig and hit enter.

    this will give u the ip address of the machine.

    then attempt to ping that address from the other machine.

    post your results back here

    +
    0 Votes
    LuisJR02

    Although you mentioned that you set your network in McAfee as a trusted site, you must also individually set each computer as trusted. In the manage network section you will find the illustrated map of your network where you must click on each computer to set it as trusted. The program will display two playing cards that you must verify on the opposite computer to validate the sharing between computers on the network. This must be done for every computer on your network.

    +
    0 Votes
    Dillon.damien

    The version of McAfee I have does not have the option on the manage network screen to set each computer as trusted (Is this a feature of McAfee EasyNetwork, I am not using this feature).

    However, when I select 'Configure - Internet & Network - Advanced - Networks' I can set a range of IP addresses as 'Trusted', 'Public' or 'Standard'.
    I have 192.168.1.0 - 192.168.1.255 set to 'trusted' as the router assigns computers on the network an IP address between these (usually only 1-5 in the fourth octet). I would assume this should be sufficient.

    I will have access to the LAN again tomorrow and will recheck the McAfee settings then along with pinging the other computers on the network and checking the network protocol lists.

    I will repost with an update then.

    Thanks.

    +
    0 Votes
    Dillon.damien

    McAfee was the issue!

    I had the range of IP addresses being used on the network set to trusted on LAN 1 but when I connected to the wireless with same computer on LAN 2 McAfee listed the same range again (it appeared to be a duplicate of the first entry) but set it to Public automatically. I changed this to trusted and hey presto it worked.

    It always seems so simple after the issue has been solved.

    Many thanks for all your help guys!!!

    +
    0 Votes
    computechdan

    i noticed in your previous post u mentioned setting a range from 0-255.

    0 and 255 are not available for use so it likely macafee didn't recognize that as a vaild range.

    however it would recognize 1-254.

    +
    0 Votes
    dixon

    ...you're back in business.

  • +
    0 Votes
    robo_dev

    there are two types of file sharing, normal and simple. Unless you choose 'simple' then you must have a userid that has a password on each PC for data to be shared.

    There is a 'simple file sharing mode' that does not need a password.

    Do you have a defined userid for each PC that has a password?

    http://www.practicallynetworked.com/sharing/xp/filesharing.htm

    Can each PC ping the other one via both IP and hostname?

    +
    0 Votes
    dixon

    1)Make sure McAfee's excepions list includes the IPs of the two machines. 2) Compare the network protocol list for each machine's network connection, and make sure they match exactly. That's a really common source of the exact problem you're describing, especially with XP Home. Good luck!

    +
    0 Votes
    computechdan

    xp pro supports both types

    +
    0 Votes
    dixon

    ...but, although it's a bit of a pain, you can log on in Safe Mode as Administrator and find that many of the Pro style sharing and permissions options are then magically enabled in Windows Explorer. I've used that trick quite a bit in solving weird XP Home networking problems.

    +
    0 Votes
    computechdan

    the "shared" folder is intended to be shared only with other users of the SAME computer.

    if you wish to share a folder either create a new folder on each laptop or choose an existing folder then right click the folder, left click sharing and security, then check the box to "share this folder on the network".

    if you want to be able to write to the folder u have to check the box "allow network users to change my files"

    after this is done you should have access to it from the other computer.

    don't forget to "mark as helpful" any post that u find useful.

    +
    0 Votes
    Dillon.damien

    Thanks for all your tips. But it is still not working.

    McAfee is set to trust all IP addresses between 192.168.1.0 - 192.168.1.255. How do I compare the network protocol lists?

    I have shared a folder in 'My Documents' (Sharing and Security - Share this folder on the network) but it was still not available on the other laptop (in 'My Network Places').

    This is the second Home network I am trying to set up. The first one I set up worked perfectly. As far as I am aware I followed the same procedure. The only difference is the router (Linksys worked, Netgear did not).

    Laptop 1 will be used on both networks. Laptop 1 currently works perfectly on the first LAN (All shared docs can be seen and accessed by other computers on the network. I can print 'wirelessly' over the network as well via a PC which is connected to the router through ethernet). However when I try it on the second LAN the other computers cannot see these same shared docs.

    Is it possible that something needs to be configured on the wireless router?

    +
    0 Votes
    dixon

    Start --> Control Panel --> Network Connections --> Local Area Connection --> Properties. Look at the list in the box labeled "This connection uses the following items." Make sure both machines are using the same list. Disable or enable as needed until they match. To simplify things, you might start by using only "Client for Microsoft Networks", "File and Printer Sharing for Microsoft Networks", "QoS Packet Scheduler", and "Internet Protocol (TCP/IP)" on both machines.

    +
    0 Votes
    dixon

    ...that, if that doesn't help, try the following, on both machines: Start --> Control Panel --> Network Connections --> Local Area Connection --> Properties --> Install --> Protocol. Select "NW Link IPX/SPX/NetBIOS Compatible Transport Protocol" and click "OK". I've had a few cases over the years where that fixed your kind of problem

    +
    0 Votes
    Dillon.damien

    I will check those, I won't have access to the LAN in question today but will post back the results.

    +
    0 Votes
    computechdan

    on each of the machines...
    start, run, msinfo32, note the system name

    then start, run, cmd and attempt to ping the other machine by it's name

    in the cmd window type: ping computername then hit enter.
    replace computername with the system name of the other computer as u noted above

    if it replies u have connectivity.

    if not attempt to ping it by it's ip address.

    using the same cmd window type ipconfig and hit enter.

    this will give u the ip address of the machine.

    then attempt to ping that address from the other machine.

    post your results back here

    +
    0 Votes
    LuisJR02

    Although you mentioned that you set your network in McAfee as a trusted site, you must also individually set each computer as trusted. In the manage network section you will find the illustrated map of your network where you must click on each computer to set it as trusted. The program will display two playing cards that you must verify on the opposite computer to validate the sharing between computers on the network. This must be done for every computer on your network.

    +
    0 Votes
    Dillon.damien

    The version of McAfee I have does not have the option on the manage network screen to set each computer as trusted (Is this a feature of McAfee EasyNetwork, I am not using this feature).

    However, when I select 'Configure - Internet & Network - Advanced - Networks' I can set a range of IP addresses as 'Trusted', 'Public' or 'Standard'.
    I have 192.168.1.0 - 192.168.1.255 set to 'trusted' as the router assigns computers on the network an IP address between these (usually only 1-5 in the fourth octet). I would assume this should be sufficient.

    I will have access to the LAN again tomorrow and will recheck the McAfee settings then along with pinging the other computers on the network and checking the network protocol lists.

    I will repost with an update then.

    Thanks.

    +
    0 Votes
    Dillon.damien

    McAfee was the issue!

    I had the range of IP addresses being used on the network set to trusted on LAN 1 but when I connected to the wireless with same computer on LAN 2 McAfee listed the same range again (it appeared to be a duplicate of the first entry) but set it to Public automatically. I changed this to trusted and hey presto it worked.

    It always seems so simple after the issue has been solved.

    Many thanks for all your help guys!!!

    +
    0 Votes
    computechdan

    i noticed in your previous post u mentioned setting a range from 0-255.

    0 and 255 are not available for use so it likely macafee didn't recognize that as a vaild range.

    however it would recognize 1-254.

    +
    0 Votes
    dixon

    ...you're back in business.