Questions

Microsoft Outlook Web Access

+
0 Votes
Locked

Microsoft Outlook Web Access

rrivera
Hello all-

I have a question regarding Microsoft Outlook Web Access which is our webmail service. Upon accepting the policy you are required to authenticate (login/password) which is fine. But upon opening an email attachment (doc, xml, etc) you are again prompted to authenticate but even though you authenticate or cancel out the document opens anyways. According to a client this never used to be the case as she/he was able to open the document without being prompted to authenticate. So my question is if there is any option I am overlooking in terms of removing authentication upon opening attachments?

Info:
*Exhange server 2003
*MS Office suite 2007
*Office XP
*IE Explorer v7
  • +
    0 Votes
    vamsichrisraj

    With Outlook Web Access, you can block users from opening, sending, or receiving specified attachment types. In particular, you can do the following: ? Prevent users from accessing certain file type attachments. By default, all new Exchange 2003 installations block attachments of Levels 1 and 2 file types and Levels 1 and 2 MIME types. This feature is particularly useful in stopping Outlook Web Access users from opening attachments at public Internet terminals. Opening attachments at public Internet terminals could potentially compromise corporate security. If an attachment is blocked, a warning message indicating that the user cannot open the attachment appears in the InfoBar of the e-mail message. Outlook Web Access users who are working in their offices or who are connected to the corporate network from home can open and read attachments. You can enable full intranet access to attachments by providing the URL to the back-end servers and permitting attachments on the Exchange back-end servers.
    ? Prevent users from sending or receiving attachments with specific file name extensions that could contain viruses. This feature in Outlook Web Access matches the attachment blocking functionality in Outlook. For received messages, a warning message indicating that an attachment is blocked appears in the InfoBar of the e-mail message. For sent messages, users cannot upload any files with extensions that appear on the block list.
    To change the attachment blocking settings, you must modify the registry settings on the server.

    Note In a front-end / back-end configuration, the registry modifications should be made on the back-end server.

    To do this, follow these steps.

    Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.1. On the Exchange computer, log on by using the Exchange administrator account, and then start Registry Editor.
    2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA
    3. On the Edit menu, point to New, and then click DWORD Value.
    4. Type DisableAttachments for the name of the DWORD value, and then press ENTER.
    5. Right-click the DisableAttachments DWORD value, and then click Modify.
    6. Under Base, click Decimal.
    7. In the Value data box, type one of the following numbers: ? To permit all attachments, type 0.
    ? To permit no attachments, type 1.
    ? To permit attachments from back-end servers only, type 2.

    8. Click OK.
    9. Open a command prompt, type net stop w3svc, and then press ENTER.
    10. After the services stop, type net start w3svc, and then press ENTER.

    +
    0 Votes
    jayramnair

    When ever opening any attachments like doc,xls, it prompt password in OWA,
    We have already had a registry entry in exchange server "DisableAttachments" with value "0"


    Please help me on this

    +
    0 Votes
    jwynder

    Hi,

    I'm having the exact same symptoms you describe in your post. Did the registry edit suggested by 'vamsichrisraj' fix the problem?

    I'm also curious as to why according to staff, they were able to open Word and/or Excel attachements before.

    Thanks.

    +
    0 Votes
    donnie.leeper

    I was just wondering if anyone has figured this out. I am having the same issue.

    +
    0 Votes
    jmchristy

    I have just upgraded from ISA server 2000 to ISA server 2006. Everything worked great with the OWA implementation, except for this annoying password prompt that I keep getting when opening certain attachments. This is happening for all users, and it's only certain attachments. It seems to be happening more with Excel documents then Word documents but it?s just to erratic to really say. I am running Exchange 2003 SP2, and I have made no changes to this since I migrated to ISA Server 2006. I didn't have this issue when running ISA Server 2000.

    I have checked the following settings
    -HTTP Policy for my OWA rule is set to Allow all extensions
    -Under the properties of my OWA rule, under application settings, I have both Public and Private Computers unchecked to allow attachments thru for both
    -On my Exchange 2003, I installed the OWAAdmin tool and verified the attachment settings there
    -FreeDocs is enabled, although I believe that affects Public Folders only

    One thing that is different, is in my OWA rule I removed the /Exchange* /Public* and /ExchWeb* paths and replaced them with just /*. I was getting a 403 error forbidden URL with all 3 paths in place, I believe that is because of a miss-configuration on my Exchange 2003 SP2 box from my previous ISA Server 2000 OWA setup. I?m guessing this is where the problem lies at least in my case? I don?t? know if I need to make changes to my IIS Directory Security or not. My directory security for the Default Web Site is set to enable anonymous access under Authentication and Access control, and my Exchange path is checked off for Integrated Windows authentication (something I changed to try to get rid of this problem which is didn?t) and basic authentication with the default domain set to my default domain name. ExchangeWeb is set to enable anonymous access.

    I also verified that ISA Server is set to Require 128 bit security over the HTTPS port and so my IIS is also requiring 128 bit security, I?m at a loss here!!

  • +
    0 Votes
    vamsichrisraj

    With Outlook Web Access, you can block users from opening, sending, or receiving specified attachment types. In particular, you can do the following: ? Prevent users from accessing certain file type attachments. By default, all new Exchange 2003 installations block attachments of Levels 1 and 2 file types and Levels 1 and 2 MIME types. This feature is particularly useful in stopping Outlook Web Access users from opening attachments at public Internet terminals. Opening attachments at public Internet terminals could potentially compromise corporate security. If an attachment is blocked, a warning message indicating that the user cannot open the attachment appears in the InfoBar of the e-mail message. Outlook Web Access users who are working in their offices or who are connected to the corporate network from home can open and read attachments. You can enable full intranet access to attachments by providing the URL to the back-end servers and permitting attachments on the Exchange back-end servers.
    ? Prevent users from sending or receiving attachments with specific file name extensions that could contain viruses. This feature in Outlook Web Access matches the attachment blocking functionality in Outlook. For received messages, a warning message indicating that an attachment is blocked appears in the InfoBar of the e-mail message. For sent messages, users cannot upload any files with extensions that appear on the block list.
    To change the attachment blocking settings, you must modify the registry settings on the server.

    Note In a front-end / back-end configuration, the registry modifications should be made on the back-end server.

    To do this, follow these steps.

    Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.1. On the Exchange computer, log on by using the Exchange administrator account, and then start Registry Editor.
    2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA
    3. On the Edit menu, point to New, and then click DWORD Value.
    4. Type DisableAttachments for the name of the DWORD value, and then press ENTER.
    5. Right-click the DisableAttachments DWORD value, and then click Modify.
    6. Under Base, click Decimal.
    7. In the Value data box, type one of the following numbers: ? To permit all attachments, type 0.
    ? To permit no attachments, type 1.
    ? To permit attachments from back-end servers only, type 2.

    8. Click OK.
    9. Open a command prompt, type net stop w3svc, and then press ENTER.
    10. After the services stop, type net start w3svc, and then press ENTER.

    +
    0 Votes
    jayramnair

    When ever opening any attachments like doc,xls, it prompt password in OWA,
    We have already had a registry entry in exchange server "DisableAttachments" with value "0"


    Please help me on this

    +
    0 Votes
    jwynder

    Hi,

    I'm having the exact same symptoms you describe in your post. Did the registry edit suggested by 'vamsichrisraj' fix the problem?

    I'm also curious as to why according to staff, they were able to open Word and/or Excel attachements before.

    Thanks.

    +
    0 Votes
    donnie.leeper

    I was just wondering if anyone has figured this out. I am having the same issue.

    +
    0 Votes
    jmchristy

    I have just upgraded from ISA server 2000 to ISA server 2006. Everything worked great with the OWA implementation, except for this annoying password prompt that I keep getting when opening certain attachments. This is happening for all users, and it's only certain attachments. It seems to be happening more with Excel documents then Word documents but it?s just to erratic to really say. I am running Exchange 2003 SP2, and I have made no changes to this since I migrated to ISA Server 2006. I didn't have this issue when running ISA Server 2000.

    I have checked the following settings
    -HTTP Policy for my OWA rule is set to Allow all extensions
    -Under the properties of my OWA rule, under application settings, I have both Public and Private Computers unchecked to allow attachments thru for both
    -On my Exchange 2003, I installed the OWAAdmin tool and verified the attachment settings there
    -FreeDocs is enabled, although I believe that affects Public Folders only

    One thing that is different, is in my OWA rule I removed the /Exchange* /Public* and /ExchWeb* paths and replaced them with just /*. I was getting a 403 error forbidden URL with all 3 paths in place, I believe that is because of a miss-configuration on my Exchange 2003 SP2 box from my previous ISA Server 2000 OWA setup. I?m guessing this is where the problem lies at least in my case? I don?t? know if I need to make changes to my IIS Directory Security or not. My directory security for the Default Web Site is set to enable anonymous access under Authentication and Access control, and my Exchange path is checked off for Integrated Windows authentication (something I changed to try to get rid of this problem which is didn?t) and basic authentication with the default domain set to my default domain name. ExchangeWeb is set to enable anonymous access.

    I also verified that ISA Server is set to Require 128 bit security over the HTTPS port and so my IIS is also requiring 128 bit security, I?m at a loss here!!