Questions

Mount partition in linux

+
0 Votes
Locked

Mount partition in linux

linux003
Hi,

I am having following partition table.

hdb1 - boot
hdb2 - root

hdc1 - boot
hdc2 - root

Both the HDDs have same distribution OEL5.I can only mount the hdb1 if i boot from hdc or mount only hdc1 if i boot from hdb.When I try to mount root partition,it says that file system is wrong.I use the following command.At this time my booting HDD is hdc.

I create a folder /mnt/hdb2

mount -t ext2 /dev/hdb2 /mnt/hdb2

I am not getting any error for following command.

mount -t ext2 /dev/hdb1 /mnt/hdb1

No issues to view the content of /mnt/hdb1.

Can anybody clear this? Pl
  • +
    0 Votes
    open.suse

    try to use the following syntax as root

    mkdir /mnt/hdb1
    mkdir /mnt/hdb2
    mkdir /mnt/hdc1
    mkdir /mnt/hdc2
    mount -s -v /dev/hdb1 /mnt/hdb1
    mount -s -v /dev/hdb2 /mnt/hdb2
    mount -s -v /dev/hdc1 /mnt/hdc1
    mount -s -v /dev/hdc2 /mnt/hdc2

    the -s option will allow sloppy mounting (ie : a partition with a bad superblock) and the -v will give you a verbose listing as to what is being done to troubleshoot the process.

    The only thing I can think of right off is to ask if you are using a ramdisk for an ISO mount. (Live filesystem).

    Have a lot of fun!

    +
    0 Votes
    open.suse

    In your boot record, make sure that your root=XXX does not point to the correct HD and that they are not both pointing to the same root drive.

    +
    0 Votes
    linux003

    Can you please explain how to identify about the option you are explaining?

    +
    0 Votes
    linux003

    When I try the commands you mentioned,I get the following response.

    mount: you didn't specify a filesystem type for /dev/hdb2
    I will try all types mentioned in /etc/filesystems or /proc/filesystems
    Trying hfsplus
    mount: you must specify the filesystem type

  • +
    0 Votes
    open.suse

    try to use the following syntax as root

    mkdir /mnt/hdb1
    mkdir /mnt/hdb2
    mkdir /mnt/hdc1
    mkdir /mnt/hdc2
    mount -s -v /dev/hdb1 /mnt/hdb1
    mount -s -v /dev/hdb2 /mnt/hdb2
    mount -s -v /dev/hdc1 /mnt/hdc1
    mount -s -v /dev/hdc2 /mnt/hdc2

    the -s option will allow sloppy mounting (ie : a partition with a bad superblock) and the -v will give you a verbose listing as to what is being done to troubleshoot the process.

    The only thing I can think of right off is to ask if you are using a ramdisk for an ISO mount. (Live filesystem).

    Have a lot of fun!

    +
    0 Votes
    open.suse

    In your boot record, make sure that your root=XXX does not point to the correct HD and that they are not both pointing to the same root drive.

    +
    0 Votes
    linux003

    Can you please explain how to identify about the option you are explaining?

    +
    0 Votes
    linux003

    When I try the commands you mentioned,I get the following response.

    mount: you didn't specify a filesystem type for /dev/hdb2
    I will try all types mentioned in /etc/filesystems or /proc/filesystems
    Trying hfsplus
    mount: you must specify the filesystem type