Questions

My DOS windows are always full-screen, how to fix?

Tags:
+
0 Votes
Locked

My DOS windows are always full-screen, how to fix?

shmooth
So, at least for the very first time i run every command from the Start->Run menu in Windows Vista, I get a full screen of black, until my command finally materializes - let's use 'cmd' as an example.

So, if I say run 'cmd', my it'll take over the entire screen until I ALT-ENTER it. Then, to prevent it from happening in the future, I have to go into Properties->Options->Display Options and switch the setting from 'Full screen' to 'Window'. How do I make 'Window' the default, because it continues to pop up in unexpected places - say, when I'm running an executable from within other applications - like running a PERL script from within Textpad.

Thanks.
  • +
    0 Votes
    deepsand

    Go to "Start > Programs > Accessories," right click on "Command Prompt," select "Properties > Shortcut," and select "Normal Window" in the "Run" field.

    Then, return to "Command Prompt" per above, and, using a right click, create a Shortcut on your Desktop, moving a copy to the Quick Launch area of the Taskbar as well if desired.

    From then on, use the Shortcut rather than "Start > Run" to launch a Command window.

    If you find this helpful, please mark this reply accordingly.

    +
    0 Votes
    deepsand

    If so, please mark it here as being helpful, so that other who have the same or a similar question will know that.

    Thank you.

    +
    0 Votes
    pjnjhm

    This one drove me nuts for a while - you can control whether cmd.exe starts as fullscreen or in a window with a shortcut but some programs run child processes using cmd.exe directly. Whenever a program did this I would have a fullscreen DOS popup when I was in the middle of working - very annoying! I finally found a solution - run cmd.exe and allow it to start fullscreen then use ALT + ENTER to switch it to a window. Right click on the top bar of that window and select Properties. Select the Options tab - you should find that the display options are set to run in a window but this is just the current position of the window. If you now click on OK you should be presented with a popup with 2 options - one of which is 'Save properties for future windows with same title' - select this and click on OK and you should find cmd.exe runs as a window from now on.

    +
    0 Votes
    accident

    i tried that aswell, but that didn't stop the dos windows started by applications from being full screen.

    i finally stopped it by right clicking on the dos window's title bar, selecting Defaults from the context menu and then setting Display Options to Window in that.

    +
    0 Votes
    prbennett

    Dude, this has been a pain in my *** for some time now (kind of not quite enough of a problem to pull out all the stops on). Thanks for posting!

    +
    0 Votes
    deepsand

    If so, please mark it here as being helpful, so that other who have the same or a similar question will know that.

    Thank you.

    +
    0 Votes
    pjnjhm

    This one drove me nuts for a while - you can control whether cmd.exe starts as fullscreen or in a window with a shortcut but some programs run child processes using cmd.exe directly. Whenever a program did this I would have a fullscreen DOS popup when I was in the middle of working - very annoying! I finally found a solution - run cmd.exe and allow it to start fullscreen then use ALT + ENTER to switch it to a window. Right click on the top bar of that window and select Properties. Select the Options tab - you should find that the display options are set to run in a window but this is just the current position of the window. If you now click on OK you should be presented with a popup with 2 options - one of which is 'Save properties for future windows with same title' - select this and click on OK and you should find cmd.exe runs as a window from now on.

  • +
    0 Votes
    deepsand

    Go to "Start > Programs > Accessories," right click on "Command Prompt," select "Properties > Shortcut," and select "Normal Window" in the "Run" field.

    Then, return to "Command Prompt" per above, and, using a right click, create a Shortcut on your Desktop, moving a copy to the Quick Launch area of the Taskbar as well if desired.

    From then on, use the Shortcut rather than "Start > Run" to launch a Command window.

    If you find this helpful, please mark this reply accordingly.

    +
    0 Votes
    deepsand

    If so, please mark it here as being helpful, so that other who have the same or a similar question will know that.

    Thank you.

    +
    0 Votes
    pjnjhm

    This one drove me nuts for a while - you can control whether cmd.exe starts as fullscreen or in a window with a shortcut but some programs run child processes using cmd.exe directly. Whenever a program did this I would have a fullscreen DOS popup when I was in the middle of working - very annoying! I finally found a solution - run cmd.exe and allow it to start fullscreen then use ALT + ENTER to switch it to a window. Right click on the top bar of that window and select Properties. Select the Options tab - you should find that the display options are set to run in a window but this is just the current position of the window. If you now click on OK you should be presented with a popup with 2 options - one of which is 'Save properties for future windows with same title' - select this and click on OK and you should find cmd.exe runs as a window from now on.

    +
    0 Votes
    accident

    i tried that aswell, but that didn't stop the dos windows started by applications from being full screen.

    i finally stopped it by right clicking on the dos window's title bar, selecting Defaults from the context menu and then setting Display Options to Window in that.

    +
    0 Votes
    prbennett

    Dude, this has been a pain in my *** for some time now (kind of not quite enough of a problem to pull out all the stops on). Thanks for posting!

    +
    0 Votes
    deepsand

    If so, please mark it here as being helpful, so that other who have the same or a similar question will know that.

    Thank you.

    +
    0 Votes
    pjnjhm

    This one drove me nuts for a while - you can control whether cmd.exe starts as fullscreen or in a window with a shortcut but some programs run child processes using cmd.exe directly. Whenever a program did this I would have a fullscreen DOS popup when I was in the middle of working - very annoying! I finally found a solution - run cmd.exe and allow it to start fullscreen then use ALT + ENTER to switch it to a window. Right click on the top bar of that window and select Properties. Select the Options tab - you should find that the display options are set to run in a window but this is just the current position of the window. If you now click on OK you should be presented with a popup with 2 options - one of which is 'Save properties for future windows with same title' - select this and click on OK and you should find cmd.exe runs as a window from now on.