Questions

Need to connect to internet using wireless usb EVDO modem from PC to PS3

+
0 Votes
Locked

Need to connect to internet using wireless usb EVDO modem from PC to PS3

bimal_kumar_sanghi
I want to connect to the internet using my wireless usb EVDO modem which I use for the desktop PC. Can connect to the PC without any problems. For first time setup I insert the wireless usb evdo modem into a USB port on the PC and it prompts to install the connection software. After installing I need to update the username and password in the settings of the connection. Which helps me connect to the internet

But I cannot do the same in my Playstation 3 as it does not auto allow the installation

I read some forums. I had to use my PC to connect to the PS3. There it was said I had to go the properties-advanced tab of the connection in network connections (I have Windows Xp)and under internet sharing had to check the first option which said to "Allow other network users....". And uncheck the other two options
I connected a CAT5E patch cable from my pc ethernet port to my PS3 ethernet port.
I do not see any of the link lights blinking on the ethernet side of the PC or the PS3 and am still not able to connect to the internet in my PS3

When I go to my PS3 and try to connect it is says "Ethernet cable not connected". I used my PS3 before for a wired internet connection and it used to work and since then there have been no changes and I pretty sure there is nothing wrong with the cable or the ethernet port on the PS3

Would there be some other settings I need to try to make the ethernet cable get detected by the PS3? And should the link lights blink if I have connected the ends to the PC and PS3
  • +
    0 Votes
    TobiF

    1. You probably need a crossed ethernet cable when you connect two devices directly, without a hub between them.

    2. When you activate ICS (Internet Connection Sharing), the IP address of the ethernet interface of your computer is changed to 192.168.0.1 (Think I'm right, but double check). I don't thinkg you have any DHCP server on your computer, so you may need to manually enter IP address, subnet mask, gateway address and dns server addresses in your PS3. Use these settings:
    - IP address: one number higher than the ethernet address of your computer.
    - Subnet mask. Same as on the computers ethernet interface. (i.e. 255.255.255.0)
    - Gateway IP. The ethernet address of your computer.
    - DNS. Any working dns servers. Either look up what dns servers you get on your evdo connection, or use some public dns service. Google-dns, for instance, has 8.8.8.8 and 8.8.4.4

    Good luck

    +
    0 Votes
    OH Smeg

    Computer and PS3 you need a Crossover Cable not a Straight Cable. If there is any distance between these two units you can insert a short Crossover and Cat5 Joiner to get the same effect without needing to waste money on long Crossover Cables. or you can follow the advice here and make your own Crossover Cable

    http://blogs.techrepublic.com.com/networking/?p=3442&tag=content;leftCol

    Col

    +
    0 Votes
    bimal_kumar_sanghi

    Yes. It is a direct connection between the PC and the PS3
    I will try the above steps and will check and will let you know
    Thanks

    +
    0 Votes
    bimal_kumar_sanghi

    I got a crossover cable but still does not seem to work

    Now my PC and PS3 are detecting the ethernet cable

    I have the cable running directly from the PC to the PS3.

    A icon in the right hand bottom corner where the time is located shows the icon with the two computers and it says "local area connection, speed: 100 mbps, status: connected" (I have Windows Xp)

    I have two icons in the network connections (If I go to start, control panel and then network connections)-
    One says "MY ISP" and the second says "Local area connection"

    When I went to "MY ISP"'s properties in network connections and then the advanced tab and clicked under Internet connection sharing "Allow other network users...." it did change the ethernet ip address to 192.168.0.1 and the subnet mask to 255.255.255.0" which I confirmed when I went to "Local Area Connection" icon properties in the network connections and double click on Internet protocol

    But when I go to my PS3 menu - network settings and then click on internet connections settings and then ok, the icon on the PC on the right hand bottom corner immediately says "a network cable is unplugged".
    Everytime I choose some settings it says "a network cable is unplugged" and then If I wait sometime it goes back to "Connected"
    I finally came to the screen where it asks me to choose "Easy" or "Custom", waited for some time and then the icon on the PC said it was connected. But when I chose Easy it gave the same message again saying "a network cable is unplugged" and then it said checking network configuration, please wait and then it gave me a message saying "The attempt to obtain a Ip address timed out"

    I tried the custom option

    Here is what it asks me
    Wired Connection or Wireless - I chose Wired Connection
    Select the operation mode of the network device. In most cases, select auto-detect.
    Auto detect or Manual settings

    Method 1 - Here I selected auto-detected

    It asks me Ip address setting
    Automatic, Manual or PPPoE (Chose Automatic)

    Set the DHCP Host name. In most cases the settings does not need to be changed
    Do Not Set Or Set (Chose Do Not Set)

    DNS setting
    Automatic or Manual - Chose Automatic

    MTU (Don't Know what that stands for)
    Automatic or Manual - Chose Automatic

    Proxy Server
    Do not use or Use - Chose Do not use

    UPnP
    Enable or Disable - Chose Enable

    Then it asked me to press the x button to save settings which I did

    And then it said Save completed.

    Gave me an option of "Test Connection"

    Here on the PC it was showing Local Area Connection on the right hand bottom corner and it was connected

    The moment I pressed test connection it again said "A network cable is unplugged" on the PC and the Checking Ip address on the PS3 failed

    Method 2 - Here I selected manual settings after wired connection in the beginning

    After selecting manual settings

    first it asks me speed and duplex
    options are Auto-detect, 10Base-T Half Duplex, 10Base-T Full Duplex, 100 base with the half and full and 1000 base with the half and full (Chose Auto Detect)

    Ip address setting
    Automatic, Manual, PPPoE (Chose Manual)

    Here it asks me for
    IP address, Subnet Mask, Default Router,
    Primary DNS and Secondary DNS

    Ip address I put one more than the ethernet ip address that is 192.168.0.2, Subnet Mask - 255.255.255.0, for default router I put the ip address of the PPP adaptor (type cmd in run box and then type ipconfig and then get the ip address for the PPP adaptor which varies everytime I connect and disconnect), for primary and secondary dns I chose the one for open dns that is 208.67.222.222 and 208.67.220.220

    Then MTU, Proxy Server, UPnP and then it asks me to save settings. (The same settings I chose as for method 1)

    I save the settings and then test connection.
    It says Obtain Ip address: Succeeded but the next line says Internet connection: Failed

    And a message on the bottom says "An error occured during communication with the server. This is a DNS error (80710102)

    Thanks in advance if anybody can help

    +
    0 Votes
    OH Smeg

    If it's at the computer end you need to run the Network Setup Wizard which in XP can be found in the Start, All Programs Accessories, Communications.

    Don't allow the computer to Automatically select your Internet Connection manually select this yourself and then as you work your way through the Setup Procedure tell the system that it connects directly to the Internet and that other computers on the Network connect through it.

    By your description of things the computer is getting confused and isn't sharing the Internet Connection It's looking for another connection to share.

    Anyway after you setup the computer go to the PS3 and use the Easy option to configure it.

    Col

    +
    0 Votes
    seanferd

    If it isn't off, no matter what you configured elsewhere, it will try to use a wireless connection, and then claim a cable is unplugged.

    This may be one of the problems.

    <i>, for default router I put the ip address of the PPP adaptor (type cmd in run box and then type ipconfig and then get the ip address for the PPP adaptor which varies everytime I connect and disconnect),</i>

    You may want to set this to Static. If you mean the Public IP, you are using the wrong IP.

    +
    0 Votes
    TobiF

    You were very close with your second attempt.

    Default gateway address shall be 192.168.0.1
    UPnP - Better to turn off in this configuration (but it wouldn't break anything if enabled...)

    +
    0 Votes
    bimal_kumar_sanghi

    I tried the network setup wizard but still does not connect

    There are two icons on the right hand bottom corner. One is my internet connection which I get from my EVDO wireless USB modem and it connects once I use the software and able to browse the internet on the PC.

    The other icon is the Local Area Connection. Where it says connected in the right hand bottom corner (PC to PS3). The moment I start configuring the PS3 starting from Internet connection settings menu, the moment I press the button to start the configuration. I get the message on my PC saying "a network cable is unplugged" and it happens everytime I try to choose to select something on the PS3. After a few seconds it goes back to connected

    My desktop is not wireless. So I guess it is turned off. And I am trying to use the wired option in the PS3 so don't know if there is a way to turn off the wireless on the PS3

    When I type cmd in the run box and then type ipconfig the PPP adaptor is my wireless USB EVDO modem. I get different IP addresses everytime I connnect or disconnect. I do not know how to make it static

    Default gateway should be updated where? Is the Default router field?

    Thanks

    +
    0 Votes
    bimal_kumar_sanghi

    Do not know how
    But what I did was uninstall the ethernet adaptor from my PC, uninstalled the EVDO modem software from the PC. Restarted the computer. Reinstalled the EVDO modem software.

    Made the changes to the default router in PS3 to the one indicated by Tobif. Shut the PS3 down. And after sometime when I wanted to play the Heavy Rain disc it started saying that version 2.0 was available for Heavy rain and it started downloading the data. I have not checked everything but it seems to be connected.

    Thanks for everybody's help

    +
    0 Votes
    bimal_kumar_sanghi

    I tried playing Uncharted 2 online but it says the settings are not correct and I need to check the NAT type in Internet Connection Test

    It seems that the PS3 is connected to the internet if I use the browser, able to download system and game updates, able to use playstation store

    When I go to Internet Connection Test it does the same thing, it gives me an error saying ip address obtained but internet connection failed and on the PC it says network cable unplugged. Can someone please give me step by step instructions so I can start over?

    +
    0 Votes
    Who Am I Really

    did you configure the firewall (windows or other product)
    to allow the PS3 to pass through the XP system unhindered?

    these might help,

    How to Configure ICS
    http://support.microsoft.com/kb/306126

    Troubleshooting ICS
    http://support.microsoft.com/kb/308006

    windows Firewall Info
    http://www.microsoft.com/windowsxp/using/networking/expert/crawford_02july01.mspx

    +
    0 Votes
    TobiF

    It's very possible, that your mobile modem doesn't get any public ip, but a private one (which is behind a firewall).

    As I'm writing this, I'm on a mobile internet connection myseilf. Let's see... (command prompt, ipconfig/all ... Huawei...)
    Yes, my assigned IP address is 10.242.190.204. Anything that begins with 10. is a private address.
    I.e. when I connect somewhere, the other side will see a different ip address, which I share with quite a few other people on this mobile network.
    (Just to check... Let's visit my very own checkip page on my web site,,, Yes: begins with 80.227)

    Many games need to be accessible in "server mode", i.e. they need to be able declare that "incoming traffic to a certain ip address and a specific port, will reach this application".
    In a home setting, where your router has received a public IP, this can be achieved by instructing the router to forward incoming traffic that arrive at a certain port to your computer on the internal network. This is called "port forwarding/virtual server". Can be configured in the settings of most routers, or requested automagically if the router supports uPnP.

    But a mobile operator can't let you play with port forwarding. If they allowed uPnP, then some gamers would start fighting about access to different ports...

    So what you've left, is just typical <a href="http://en.wikipedia.org/w/index.php?title=Network_address_translation">NAT, Network Address Translation</a>, but, due to a large number of users on a shared address, this NAT needs to be more aggressive than a home router would be. So common techniques to virtually punch a hole through the NAT with help of an external server (Over on the wikipedia page for NAT, follow links for NAT traversal towards the end of the page if you got hooked.) may not work very well.

    So far, we've discussed that you may have problems playing some games on your laptop. But <b>there's even more</b> to it.

    >>Your PS3 is isolated from the internet by yet one layer. Your laptop may have a (private) 10.something address upstream. But downstream, it acts as a router with the internal address 192.168.1.1 (or similar).

    So, when PS3 tries to create a channel for responses from the internet, it has to "traverse" two routers.

    There seems to be possible to set up port forwarding on your laptop, in order to support the first step of NAT traversal. http://forum.portforward.com/YaBB.cgi?num=1134525903

    So, try configure this, then try again to see if your game will succeed in the NAT traversal.

  • +
    0 Votes
    TobiF

    1. You probably need a crossed ethernet cable when you connect two devices directly, without a hub between them.

    2. When you activate ICS (Internet Connection Sharing), the IP address of the ethernet interface of your computer is changed to 192.168.0.1 (Think I'm right, but double check). I don't thinkg you have any DHCP server on your computer, so you may need to manually enter IP address, subnet mask, gateway address and dns server addresses in your PS3. Use these settings:
    - IP address: one number higher than the ethernet address of your computer.
    - Subnet mask. Same as on the computers ethernet interface. (i.e. 255.255.255.0)
    - Gateway IP. The ethernet address of your computer.
    - DNS. Any working dns servers. Either look up what dns servers you get on your evdo connection, or use some public dns service. Google-dns, for instance, has 8.8.8.8 and 8.8.4.4

    Good luck

    +
    0 Votes
    OH Smeg

    Computer and PS3 you need a Crossover Cable not a Straight Cable. If there is any distance between these two units you can insert a short Crossover and Cat5 Joiner to get the same effect without needing to waste money on long Crossover Cables. or you can follow the advice here and make your own Crossover Cable

    http://blogs.techrepublic.com.com/networking/?p=3442&tag=content;leftCol

    Col

    +
    0 Votes
    bimal_kumar_sanghi

    Yes. It is a direct connection between the PC and the PS3
    I will try the above steps and will check and will let you know
    Thanks

    +
    0 Votes
    bimal_kumar_sanghi

    I got a crossover cable but still does not seem to work

    Now my PC and PS3 are detecting the ethernet cable

    I have the cable running directly from the PC to the PS3.

    A icon in the right hand bottom corner where the time is located shows the icon with the two computers and it says "local area connection, speed: 100 mbps, status: connected" (I have Windows Xp)

    I have two icons in the network connections (If I go to start, control panel and then network connections)-
    One says "MY ISP" and the second says "Local area connection"

    When I went to "MY ISP"'s properties in network connections and then the advanced tab and clicked under Internet connection sharing "Allow other network users...." it did change the ethernet ip address to 192.168.0.1 and the subnet mask to 255.255.255.0" which I confirmed when I went to "Local Area Connection" icon properties in the network connections and double click on Internet protocol

    But when I go to my PS3 menu - network settings and then click on internet connections settings and then ok, the icon on the PC on the right hand bottom corner immediately says "a network cable is unplugged".
    Everytime I choose some settings it says "a network cable is unplugged" and then If I wait sometime it goes back to "Connected"
    I finally came to the screen where it asks me to choose "Easy" or "Custom", waited for some time and then the icon on the PC said it was connected. But when I chose Easy it gave the same message again saying "a network cable is unplugged" and then it said checking network configuration, please wait and then it gave me a message saying "The attempt to obtain a Ip address timed out"

    I tried the custom option

    Here is what it asks me
    Wired Connection or Wireless - I chose Wired Connection
    Select the operation mode of the network device. In most cases, select auto-detect.
    Auto detect or Manual settings

    Method 1 - Here I selected auto-detected

    It asks me Ip address setting
    Automatic, Manual or PPPoE (Chose Automatic)

    Set the DHCP Host name. In most cases the settings does not need to be changed
    Do Not Set Or Set (Chose Do Not Set)

    DNS setting
    Automatic or Manual - Chose Automatic

    MTU (Don't Know what that stands for)
    Automatic or Manual - Chose Automatic

    Proxy Server
    Do not use or Use - Chose Do not use

    UPnP
    Enable or Disable - Chose Enable

    Then it asked me to press the x button to save settings which I did

    And then it said Save completed.

    Gave me an option of "Test Connection"

    Here on the PC it was showing Local Area Connection on the right hand bottom corner and it was connected

    The moment I pressed test connection it again said "A network cable is unplugged" on the PC and the Checking Ip address on the PS3 failed

    Method 2 - Here I selected manual settings after wired connection in the beginning

    After selecting manual settings

    first it asks me speed and duplex
    options are Auto-detect, 10Base-T Half Duplex, 10Base-T Full Duplex, 100 base with the half and full and 1000 base with the half and full (Chose Auto Detect)

    Ip address setting
    Automatic, Manual, PPPoE (Chose Manual)

    Here it asks me for
    IP address, Subnet Mask, Default Router,
    Primary DNS and Secondary DNS

    Ip address I put one more than the ethernet ip address that is 192.168.0.2, Subnet Mask - 255.255.255.0, for default router I put the ip address of the PPP adaptor (type cmd in run box and then type ipconfig and then get the ip address for the PPP adaptor which varies everytime I connect and disconnect), for primary and secondary dns I chose the one for open dns that is 208.67.222.222 and 208.67.220.220

    Then MTU, Proxy Server, UPnP and then it asks me to save settings. (The same settings I chose as for method 1)

    I save the settings and then test connection.
    It says Obtain Ip address: Succeeded but the next line says Internet connection: Failed

    And a message on the bottom says "An error occured during communication with the server. This is a DNS error (80710102)

    Thanks in advance if anybody can help

    +
    0 Votes
    OH Smeg

    If it's at the computer end you need to run the Network Setup Wizard which in XP can be found in the Start, All Programs Accessories, Communications.

    Don't allow the computer to Automatically select your Internet Connection manually select this yourself and then as you work your way through the Setup Procedure tell the system that it connects directly to the Internet and that other computers on the Network connect through it.

    By your description of things the computer is getting confused and isn't sharing the Internet Connection It's looking for another connection to share.

    Anyway after you setup the computer go to the PS3 and use the Easy option to configure it.

    Col

    +
    0 Votes
    seanferd

    If it isn't off, no matter what you configured elsewhere, it will try to use a wireless connection, and then claim a cable is unplugged.

    This may be one of the problems.

    <i>, for default router I put the ip address of the PPP adaptor (type cmd in run box and then type ipconfig and then get the ip address for the PPP adaptor which varies everytime I connect and disconnect),</i>

    You may want to set this to Static. If you mean the Public IP, you are using the wrong IP.

    +
    0 Votes
    TobiF

    You were very close with your second attempt.

    Default gateway address shall be 192.168.0.1
    UPnP - Better to turn off in this configuration (but it wouldn't break anything if enabled...)

    +
    0 Votes
    bimal_kumar_sanghi

    I tried the network setup wizard but still does not connect

    There are two icons on the right hand bottom corner. One is my internet connection which I get from my EVDO wireless USB modem and it connects once I use the software and able to browse the internet on the PC.

    The other icon is the Local Area Connection. Where it says connected in the right hand bottom corner (PC to PS3). The moment I start configuring the PS3 starting from Internet connection settings menu, the moment I press the button to start the configuration. I get the message on my PC saying "a network cable is unplugged" and it happens everytime I try to choose to select something on the PS3. After a few seconds it goes back to connected

    My desktop is not wireless. So I guess it is turned off. And I am trying to use the wired option in the PS3 so don't know if there is a way to turn off the wireless on the PS3

    When I type cmd in the run box and then type ipconfig the PPP adaptor is my wireless USB EVDO modem. I get different IP addresses everytime I connnect or disconnect. I do not know how to make it static

    Default gateway should be updated where? Is the Default router field?

    Thanks

    +
    0 Votes
    bimal_kumar_sanghi

    Do not know how
    But what I did was uninstall the ethernet adaptor from my PC, uninstalled the EVDO modem software from the PC. Restarted the computer. Reinstalled the EVDO modem software.

    Made the changes to the default router in PS3 to the one indicated by Tobif. Shut the PS3 down. And after sometime when I wanted to play the Heavy Rain disc it started saying that version 2.0 was available for Heavy rain and it started downloading the data. I have not checked everything but it seems to be connected.

    Thanks for everybody's help

    +
    0 Votes
    bimal_kumar_sanghi

    I tried playing Uncharted 2 online but it says the settings are not correct and I need to check the NAT type in Internet Connection Test

    It seems that the PS3 is connected to the internet if I use the browser, able to download system and game updates, able to use playstation store

    When I go to Internet Connection Test it does the same thing, it gives me an error saying ip address obtained but internet connection failed and on the PC it says network cable unplugged. Can someone please give me step by step instructions so I can start over?

    +
    0 Votes
    Who Am I Really

    did you configure the firewall (windows or other product)
    to allow the PS3 to pass through the XP system unhindered?

    these might help,

    How to Configure ICS
    http://support.microsoft.com/kb/306126

    Troubleshooting ICS
    http://support.microsoft.com/kb/308006

    windows Firewall Info
    http://www.microsoft.com/windowsxp/using/networking/expert/crawford_02july01.mspx

    +
    0 Votes
    TobiF

    It's very possible, that your mobile modem doesn't get any public ip, but a private one (which is behind a firewall).

    As I'm writing this, I'm on a mobile internet connection myseilf. Let's see... (command prompt, ipconfig/all ... Huawei...)
    Yes, my assigned IP address is 10.242.190.204. Anything that begins with 10. is a private address.
    I.e. when I connect somewhere, the other side will see a different ip address, which I share with quite a few other people on this mobile network.
    (Just to check... Let's visit my very own checkip page on my web site,,, Yes: begins with 80.227)

    Many games need to be accessible in "server mode", i.e. they need to be able declare that "incoming traffic to a certain ip address and a specific port, will reach this application".
    In a home setting, where your router has received a public IP, this can be achieved by instructing the router to forward incoming traffic that arrive at a certain port to your computer on the internal network. This is called "port forwarding/virtual server". Can be configured in the settings of most routers, or requested automagically if the router supports uPnP.

    But a mobile operator can't let you play with port forwarding. If they allowed uPnP, then some gamers would start fighting about access to different ports...

    So what you've left, is just typical <a href="http://en.wikipedia.org/w/index.php?title=Network_address_translation">NAT, Network Address Translation</a>, but, due to a large number of users on a shared address, this NAT needs to be more aggressive than a home router would be. So common techniques to virtually punch a hole through the NAT with help of an external server (Over on the wikipedia page for NAT, follow links for NAT traversal towards the end of the page if you got hooked.) may not work very well.

    So far, we've discussed that you may have problems playing some games on your laptop. But <b>there's even more</b> to it.

    >>Your PS3 is isolated from the internet by yet one layer. Your laptop may have a (private) 10.something address upstream. But downstream, it acts as a router with the internal address 192.168.1.1 (or similar).

    So, when PS3 tries to create a channel for responses from the internet, it has to "traverse" two routers.

    There seems to be possible to set up port forwarding on your laptop, in order to support the first step of NAT traversal. http://forum.portforward.com/YaBB.cgi?num=1134525903

    So, try configure this, then try again to see if your game will succeed in the NAT traversal.