Questions

Networking issues XP pro

Tags:
+
0 Votes
Locked

Networking issues XP pro

Jazzy_Azy
My husband and I run a small business from our home. We've finally got tired of working out of every room in the house, and so have designated a single room as work space. The idea was to network our computers together with a 10/100 5 port ethernet switch so that both of us could use the net in the same room from the same cable modem. For whatever reason this isn't working. In fact, not only do we not have a simultaneous internet connection, we can't even see one another in the workgroup. It's like we're not connected at all.

It's getting frustrating. We've tried repairing the network connection, but it tells us that it's unable to renew the ip address. When we look in the configurations it says that it can't reach the DHCP server and that the connection is timed out. I've seen about a thousand people with the same issue; yet I've not seen a viable solution, nor have I seen a reasonable explanation as to why it's happening. Furthermore, most people are trying to connect either Desktop to Laptop or XP Pro to XP home.

I have two XP Pro, desktop computers sitting not a full foot apart with every cable in place, and for whatever reason I can't get the bloody things to connect. Not even a GLIMMER of connection.

If anyone can explain this phenomena to me, or better yet, provide a solution, a step-by-step, or even some kind of oracle clue as to how I can mend it, I would be grateful.

Take care,
Azy!
  • +
    0 Votes
    retro77

    You need to buy a router that the internet connection will go into and then supply you with DCHP private addresses.

    These can be purchased online or at your local tech shop.

    +
    0 Votes
    OH Smeg

    Installed and working the 2 computers should be able to find the Internet without any help.

    Go to the Computer Management and look at the Ethernet Ports and make sure that they are installed and configured correctly. Then can you tell me why the system is looking for a DHCP Server as this is wrong.

    Try unplugging the Hub for 30 seconds and then plug it back in and see if that improves things.

    As for the Network how did you set this up? You should have chosen Workgroup and not Domain when you originally attempted to setup this service but without knowing what you have done it's very hard to tell you what you need to do.

    But with a XP Pro Workgroup they should be very easy to set up God only knows that I've setup thousands of them without problems.

    Col

    +
    0 Votes
    Langlier

    Most Cable companies will provide you with only one IP address for your household (some DSL companies do this as well but most will provide more). This IP address will be assigned to the first device that requests it until it is released by that device manually or it has not been used (the machine is off) for a predetermined set of time. When using a hub to connect multiple machines to your modem the first device to be turned on will likely be assigned that ip address and thus be the only machine that can go online. There are a few solutions to this problem. The "best" solution is to purchase a router to put in place of your hub. A decent residential use router is about $30 - $40. Set up of a router differs little from a hub and is most often pretty intuiative.

    If aquiring another piece of hardware does not suit you, the next option is to request an additional IP address from your cable company. This normally comes with a small additional monthly fee.

    As far as your networking problems and not being able to see one another make sure both computers are set to the same workgroup. then remove the modem from the configuration. Now make sure you can see each PC in network neighborhood.

    Hope this helps.

    +
    0 Votes
    Absolutely

    The easiest solution I see is to buy one more network interface card, install it in the XP Pro machine, and configure Internet Connection Sharing, etc.

    +
    0 Votes
    sridhar_reddapani

    Just give ip address manually, they shoul be in same subnet means 192.168.1.2-192.168.1.254(any two ip addresses from this range) and give DNS address as your ISP's DNS address, you can find this information when one computer is connected to network run command ipconfig /all you can see the ISP's DNS address use that address.

    I hope this will fix the prob

    Sridhar.

    +
    0 Votes
    vishal6828

    hey jazzy ,, may be i can help you on this topic.

    do these steps

    1. make sure that your cat 5 cables are properly crimpted.

    2. disconnect your internet cable from cpu.
    3. take lan switch and connect both the pc to the switch through the cat 5 cables.
    4. now make sure that your lan card led are glowing and your switch led are also glowing.
    5. form the property menu of your lan connection , make your both the pc in same workgroup.
    6.check that you are able to ping both the pcs.
    7. now take one lan card and connect to one of your pc , connect your internet cable to that card.
    8. from property of that lan card go to authenticate tab and tick to internet sharing checkbox.
    9. go to the property of the other pc's lan card and put the gateway ip same as your 1 st pc's TCP/IP.
    10. close every thing and try to surf internet.
    bye

    +
    0 Votes
    david_horn

    Azy, for your own sake please do not listen to some of the 'long winded' explanations and setiing changes and NIC card driver checks etc etc.. You have two XP Pro PCs.. Sorted. You have a DSL or ADSL router/modem.. Sorted. You have installed a Switch and connected both PC's to it and the switch to the router/modem.. sorted. you added both PC's to a workgroup and have followed the Network Wizard setup... sorted.
    This should work. But you get a DHCP error.. In that case you DO need a Rouet/Modem for your DSL or ADSL Boradband that can do NAT'ing (look it up in Wikipedia) so that you can turn your ISP IP address into many internal IP adresses and have the router act as a DHCP.

    Then you are sorted. Your config and evrything sounds fine.. just need to get the router setup for DHCP. Sometimes (if you spent good oney on it) the Sitch might have some Layer2 functionality and be able to do this??

    Bon Chance

    +
    0 Votes
    ozi Eagle

    Hi,
    I concur with this.
    My experience with broadband kits is that the ISP includes a modem, full stop. As Retro said you need a router, to allow the sharing of your IP address.
    I wouldn't bother with trying to get it working by internet sharing, for one reason that you need both computers on to be able to use the internet from the "slave" (can't think of a better word) computer. With a router only the PC that wishes to access the net needs to be on ( as well as the modem and router)

    Herb

    +
    0 Votes
    louislewis

    Hi Jazzy,

    I think you should attack this problem starting from small to big. Firstly as i gather you have all the needed hardware to get it to work.

    Firstly lets start by unplugging all cables. Then first connect only one computer to the modem ethernet port(If it has one) or by whatever means it does connect. Start the computer and go to the control panel. Click on network connections and look for your local area connection. Right click on it and select properties. Browse down the list in the second text box to internet protocol(TCP/IP), then double click on it and make sure that both options say obtain automatically. Then click on ok and close the network connections properties box. Then right click the local area connection and select repair. It should repair with no problem.

    If it does not i would check the ethernet cable.

    If it does, open internet explorer and click stop. Then click on the tools menu and select internet options. Click on connections and make sure that it there is a check mark under the LAN section: detect setting automatically. Then click ok and close the window. Exit explorer and go in again. At this point you should be able to browse the internet. Check a website or two to make sure.

    If you get this working or not contact me or post another reply witch i will watch and help you further.

    Enjoy...

    +
    0 Votes
    Jazzy_Azy

    Thank all of you who've offered their advice and such. I'll be taking the advice of the general consensus and discussing the router thing with darling hubby. We have one; I know we have one because I've seen it. So, the minute he gets out of the bath tub, and, of course, once I've had my wicked way with his oh-so-sexy self, I will drop the suggestion in hopes that in a moment of post-passionate love blindness he'll just cave and agree to giving it a go.

    Again, I do so thank you all. The next time I have a situation such as this I won't hesitate to mention it here.

    Take care,
    Azy!

  • +
    0 Votes
    retro77

    You need to buy a router that the internet connection will go into and then supply you with DCHP private addresses.

    These can be purchased online or at your local tech shop.

    +
    0 Votes
    OH Smeg

    Installed and working the 2 computers should be able to find the Internet without any help.

    Go to the Computer Management and look at the Ethernet Ports and make sure that they are installed and configured correctly. Then can you tell me why the system is looking for a DHCP Server as this is wrong.

    Try unplugging the Hub for 30 seconds and then plug it back in and see if that improves things.

    As for the Network how did you set this up? You should have chosen Workgroup and not Domain when you originally attempted to setup this service but without knowing what you have done it's very hard to tell you what you need to do.

    But with a XP Pro Workgroup they should be very easy to set up God only knows that I've setup thousands of them without problems.

    Col

    +
    0 Votes
    Langlier

    Most Cable companies will provide you with only one IP address for your household (some DSL companies do this as well but most will provide more). This IP address will be assigned to the first device that requests it until it is released by that device manually or it has not been used (the machine is off) for a predetermined set of time. When using a hub to connect multiple machines to your modem the first device to be turned on will likely be assigned that ip address and thus be the only machine that can go online. There are a few solutions to this problem. The "best" solution is to purchase a router to put in place of your hub. A decent residential use router is about $30 - $40. Set up of a router differs little from a hub and is most often pretty intuiative.

    If aquiring another piece of hardware does not suit you, the next option is to request an additional IP address from your cable company. This normally comes with a small additional monthly fee.

    As far as your networking problems and not being able to see one another make sure both computers are set to the same workgroup. then remove the modem from the configuration. Now make sure you can see each PC in network neighborhood.

    Hope this helps.

    +
    0 Votes
    Absolutely

    The easiest solution I see is to buy one more network interface card, install it in the XP Pro machine, and configure Internet Connection Sharing, etc.

    +
    0 Votes
    sridhar_reddapani

    Just give ip address manually, they shoul be in same subnet means 192.168.1.2-192.168.1.254(any two ip addresses from this range) and give DNS address as your ISP's DNS address, you can find this information when one computer is connected to network run command ipconfig /all you can see the ISP's DNS address use that address.

    I hope this will fix the prob

    Sridhar.

    +
    0 Votes
    vishal6828

    hey jazzy ,, may be i can help you on this topic.

    do these steps

    1. make sure that your cat 5 cables are properly crimpted.

    2. disconnect your internet cable from cpu.
    3. take lan switch and connect both the pc to the switch through the cat 5 cables.
    4. now make sure that your lan card led are glowing and your switch led are also glowing.
    5. form the property menu of your lan connection , make your both the pc in same workgroup.
    6.check that you are able to ping both the pcs.
    7. now take one lan card and connect to one of your pc , connect your internet cable to that card.
    8. from property of that lan card go to authenticate tab and tick to internet sharing checkbox.
    9. go to the property of the other pc's lan card and put the gateway ip same as your 1 st pc's TCP/IP.
    10. close every thing and try to surf internet.
    bye

    +
    0 Votes
    david_horn

    Azy, for your own sake please do not listen to some of the 'long winded' explanations and setiing changes and NIC card driver checks etc etc.. You have two XP Pro PCs.. Sorted. You have a DSL or ADSL router/modem.. Sorted. You have installed a Switch and connected both PC's to it and the switch to the router/modem.. sorted. you added both PC's to a workgroup and have followed the Network Wizard setup... sorted.
    This should work. But you get a DHCP error.. In that case you DO need a Rouet/Modem for your DSL or ADSL Boradband that can do NAT'ing (look it up in Wikipedia) so that you can turn your ISP IP address into many internal IP adresses and have the router act as a DHCP.

    Then you are sorted. Your config and evrything sounds fine.. just need to get the router setup for DHCP. Sometimes (if you spent good oney on it) the Sitch might have some Layer2 functionality and be able to do this??

    Bon Chance

    +
    0 Votes
    ozi Eagle

    Hi,
    I concur with this.
    My experience with broadband kits is that the ISP includes a modem, full stop. As Retro said you need a router, to allow the sharing of your IP address.
    I wouldn't bother with trying to get it working by internet sharing, for one reason that you need both computers on to be able to use the internet from the "slave" (can't think of a better word) computer. With a router only the PC that wishes to access the net needs to be on ( as well as the modem and router)

    Herb

    +
    0 Votes
    louislewis

    Hi Jazzy,

    I think you should attack this problem starting from small to big. Firstly as i gather you have all the needed hardware to get it to work.

    Firstly lets start by unplugging all cables. Then first connect only one computer to the modem ethernet port(If it has one) or by whatever means it does connect. Start the computer and go to the control panel. Click on network connections and look for your local area connection. Right click on it and select properties. Browse down the list in the second text box to internet protocol(TCP/IP), then double click on it and make sure that both options say obtain automatically. Then click on ok and close the network connections properties box. Then right click the local area connection and select repair. It should repair with no problem.

    If it does not i would check the ethernet cable.

    If it does, open internet explorer and click stop. Then click on the tools menu and select internet options. Click on connections and make sure that it there is a check mark under the LAN section: detect setting automatically. Then click ok and close the window. Exit explorer and go in again. At this point you should be able to browse the internet. Check a website or two to make sure.

    If you get this working or not contact me or post another reply witch i will watch and help you further.

    Enjoy...

    +
    0 Votes
    Jazzy_Azy

    Thank all of you who've offered their advice and such. I'll be taking the advice of the general consensus and discussing the router thing with darling hubby. We have one; I know we have one because I've seen it. So, the minute he gets out of the bath tub, and, of course, once I've had my wicked way with his oh-so-sexy self, I will drop the suggestion in hopes that in a moment of post-passionate love blindness he'll just cave and agree to giving it a go.

    Again, I do so thank you all. The next time I have a situation such as this I won't hesitate to mention it here.

    Take care,
    Azy!