Questions

No connection from Mac OSX 10.6 VPN to Cisco ASA 5505

+
0 Votes
Locked

No connection from Mac OSX 10.6 VPN to Cisco ASA 5505

ctkmac
Just got an ASA 5505 to replace our old firewall/vpn device. It's a steep learning curve and I have been able to work through most of the initial issues, however this Mac VPN connection issue is leaving me stumped. When I try to connect via the built in Mac OSX 10.6 Cisco IPSec connection I get the following: "A configuration error occured. Verify your settings and try reconnecting". I can confirm that the host, pre-shared key, group name, and user name are correct. It does not even get to the point where it prompts for a password.

Using the VPN Client on Windows XP it connects without issue.

I have tried using debug crypto isakmp and debug crypto ipsec but no information is collected when attempting to connect on a Mac.

Here is the config on the ASA 5505:
ASA Version 8.2(1)
!
hostname ciscoasa
enable password xxx encrypted
passwd xxx encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.5.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 207.148.xxx.xxx 255.255.255.252
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns domain-lookup outside
dns domain-lookup inside
dns server-group DefaultDNS
name-server 207.148.192.11
name-server 207.148.192.12
dns server-group VPNDNS
name-server 192.168.5.2
access-list SplitTunnel_InternalNtwks standard permit 192.168.5.0 255.255.255.0
access-list inside_access_in extended permit ip any any
access-list no_nat extended permit ip 192.168.5.0 255.255.255.0 192.168.50.192 255.255.255.192
access-list inside_nat0_outbound extended permit ip any 192.168.50.192 255.255.255.224
access-list outside_access_in extended permit ip any any
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
ip local pool CTVPN-Pool 192.168.50.192-192.168.50.220 mask 255.255.255.192
ipv6 access-list inside_access_ipv6_in permit ip any any
ipv6 access-list outside_access_ipv6_in permit ip any any
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (outside) 0 access-list no_nat
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group outside_access_in in interface outside
access-group outside_access_ipv6_in in interface outside
access-group inside_access_in in interface inside
access-group inside_access_ipv6_in in interface inside
route outside 0.0.0.0 0.0.0.0 207.148.xxx.xxx 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa-server CT-LDAP protocol ldap
aaa-server CT-LDAP (inside) host 192.168.5.2
timeout 5
ldap-base-dn cn=users,dc=xxx,dc=xxx,dc=xxx
ldap-scope subtree
ldap-naming-attribute uid
aaa authentication ssh console LOCAL
http server enable
http 192.168.5.0 255.255.255.0 inside
snmp-server group No_Authentication_No_Encryption v3 noauth
snmp-server user authOnlyUser No_Authentication_No_Encryption v3
snmp-server host inside 192.168.5.14 community xxx
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption aes-256
hash sha
group 2
lifetime 86400
crypto isakmp policy 30
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh 192.168.5.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
dhcpd dns 192.168.5.2
!
dhcpd address 192.168.5.100-192.168.5.199 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy DefaultRAGroup internal
group-policy DefaultRAGroup attributes
dns-server value 192.168.5.2
vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
split-tunnel-policy tunnelspecified
split-tunnel-network-list value SplitTunnel_InternalNtwks
username admin password xxx encrypted privilege 15
tunnel-group DefaultRAGroup general-attributes
address-pool CTVPN-Pool
default-group-policy DefaultRAGroup
tunnel-group DefaultRAGroup ipsec-attributes
pre-shared-key *
tunnel-group DefaultRAGroup ppp-attributes
authentication ms-chap-v2
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context