Questions

OSPF and RIPv2 convergence

+
0 Votes
Locked

OSPF and RIPv2 convergence

musrosine
Hi,
I am comparing convergence time of OSPF and RIPv2 in the network of seven routers. All routers are in the same area (area 0).
Can any one please, tell me why OSPF is having slow convergence than RIPv2.
Cheers.
  • +
    0 Votes
    BFilmFan

    Did you specify the reverse masks correctly on the segments?

    http://www.go2log.com/blog/?p=107

    +
    0 Votes
    musrosine

    Thank you for your help.
    Here are configuration I made on one router. I am not sure if the reverse mask are correct.
    Thank you.

    conf t
    hostname CHD
    interface FastEthernet0/0
    ip address 172.16.3.7 255.255.255.0
    no shutdown
    exit

    interface FastEthernet0/1
    ip address 172.16.2.8 255.255.255.0
    no shutdown
    exit

    interface Serial0/0/1
    bandwidth 64
    ip address 192.168.1.8 255.255.255.0
    clock rate 64000
    no shutdown
    exit


    interface Serial0/0/0
    bandwidth 64
    ip address 172.16.7.8 255.255.255.0
    clock rate 64000
    no shutdown
    exit

    router ospf 1
    network 172.16.2.0 0.0.0.255 area 0
    network 172.16.3.0 0.0.0.255 area 0
    network 172.16.7.0 0.0.0.255 area 0
    network 192.168.1.0 0.0.0.255 area 0
    exit

  • +
    0 Votes
    BFilmFan

    Did you specify the reverse masks correctly on the segments?

    http://www.go2log.com/blog/?p=107

    +
    0 Votes
    musrosine

    Thank you for your help.
    Here are configuration I made on one router. I am not sure if the reverse mask are correct.
    Thank you.

    conf t
    hostname CHD
    interface FastEthernet0/0
    ip address 172.16.3.7 255.255.255.0
    no shutdown
    exit

    interface FastEthernet0/1
    ip address 172.16.2.8 255.255.255.0
    no shutdown
    exit

    interface Serial0/0/1
    bandwidth 64
    ip address 192.168.1.8 255.255.255.0
    clock rate 64000
    no shutdown
    exit


    interface Serial0/0/0
    bandwidth 64
    ip address 172.16.7.8 255.255.255.0
    clock rate 64000
    no shutdown
    exit

    router ospf 1
    network 172.16.2.0 0.0.0.255 area 0
    network 172.16.3.0 0.0.0.255 area 0
    network 172.16.7.0 0.0.0.255 area 0
    network 192.168.1.0 0.0.0.255 area 0
    exit