Questions

Outlook 2007 Can't "Send to mail recipient"

+
1 Votes
Locked

Outlook 2007 Can't "Send to mail recipient"

fardy316
Hi all,
I can't use the function "Send to mail recipient" using Windows XP Pro SP2 and Outlook 2007. I know that some post suggest to make Outlook as my default mail client and it's done nothing good on my side. I've tried to set Outlook Express as the default and the option works, but as soon as I put Outlook 2007 the function simply doesn't work. I've also tried the "regsvr32 sendmail.dll" command without success.

Thanks for your time !
  • +
    1 Votes
    rnewby

    Try deleting the outlook.ost file associated with your outlook account from

    C:\Documents and Settings\username\local settings\application data\microsoft\outlook

    Where username is your windows/network username

    Outlook must be closed when deleting this. The file will rebuild itself after you open Outlook again, your emails and folders will not have changed.

    +
    1 Votes
    rnewby

    Try deleting the outlook.ost file associated with your outlook account from

    C:\Documents and Settings\username\local settings\application data\microsoft\outlook

    Where username is your windows/network username

    Outlook must be closed when deleting this. The file will rebuild itself after you open Outlook again, your emails and folders will not have changed.

    +
    0 Votes
    twist944

    Hey,

    I have tried the above, i have even given myself a completley fresh profile yet i still cant use the send to mail recipient function.

    Work around is:

    Use the send to mail function when outlook is shut (should work ok). Then open outlook and it works fine???? Next time you re-boot log off etc... you have to do this again.

    ANYONE GOT ANY MORE SUGGESTIONS AS THIS IS DRIVING ME MAD... ha

    Cheers

    +
    0 Votes
    ThumbsUp2

    Where are you trying to click the "send to mail recipient" from? A web page? What are you using for your DEFAULT browser? Not just the one you fired up, but the DEFAULT?

    When you click the START button in Windows, do you see Outlook listed as the email client on the partial start menu that pops up, right below the Internet Explorer icon? If you do not, Outlook has NOT been set as your default email program.

    What is your de

    +
    0 Votes
    twist944

    Where are you trying to click the "send to mail recipient" from?

    Document saved on Windows Desktop

    A web page? What are you using for your DEFAULT browser?

    Not relevent but IE7

    When you click the START button in Windows, do you see Outlook listed as the email client on the partial start menu that pops up, right below the Internet Explorer icon? If you do not, Outlook has NOT been set as your default email program.

    No, But it does appear in programs, mircrosoft office. I have checked on tools, options, other, and outlook is set as default. Is there another way??


    What is your de

    I do not know what you mean.. Cheers

    +
    0 Votes
    ThumbsUp2

    Sorry about that last line. I started to type another question and changed my mind, then forgot to delete it.

    RE: "Not relevent but IE7"

    Yes, it matters. Believe it or not, IE is integrated throughout the system. If something there isn't working right, it can affect many other programs, Outlook included.

    RE: "No, but it does appear in programs, microsoft office."

    Sorry, I forgot you can set any program to show up on the Start Menu as your email program, but that does not set it as DEFAULT email program. The default is set through Internet Options in IE7, or control panel if you prefer to go that route. Since you probably already have your browser (IE7) open while reading this, click Tools -> Options -> Programs and make sure Outlook 2007 is set as your DEFAULT mail program. Click OK to exit that window. Now, try the right click and send to option for that file on your desktop.

    If it still doesn't work, read on......

    I haven't been able to find an article specific to Outlook 2007, but I did find one for Outlook 2003 which MIGHT be related to your problem. MS says that if you've set a custom FORM to be used for your email instead of the default form, the "Send To Mail Recipient" command will no longer function. Specifically, this paragraph:

    "The SendTo feature in the operating system

    To use the SendTo feature in Windows, right-click a file, click Send To, and then click Mail Recipient in the File menu. However, you cannot use this feature for a custom form that was created by using the Forms Administrator utility. To work around this limitation, you can add a new Send To entry so that a user can use the custom form that was created by using the Forms Administrator utility.

    Optionally, you can remove the existing Mail Recipient option in the Send To folder. The Send To folder is located in the following file system location:
    C:\Documents and Settings\<USER PROFILE>\SendTo
    Additionally, the Send To folder is a hidden system folder.
    "

    Be VERY carefull using any of the registry tweaks mentioned in this article (link below) because it is not specifically written for Office 2007. The paths will be different. However, the article might give you a few places to start looking to see if you can find why the Send To Mail Recipient command is not functioning properly.

    http://support.microsoft.com/kb/241235/en-us

    Another thing I located while searching was that you should have a system icon, not a shortcut with an arrow on it, in your SendTo folder called MapiMail. If that is no longer a system icon (no arrow indicating it's a shortcut), or if the program that normally opens your MapiMail has been , the Send To Mail Recipient won't function correctly. If you right click that icon and choose properties, you should see NO program associated with it. It should say "Opens With: Unknown application". If you see anything else, something has set itself to the default MAPI application.

    Let us know what you find.

    +
    0 Votes
    twist944

    Hello! Thanks for all this info by the way...

    Right..

    "Yes, it matters. Believe it or not, IE is integrated throughout the system. If something there isn't working right, it can affect many other programs, Outlook included."

    I have checked the settings in IE7 as you suggested and the default is set to Microsoft Outlook.. The option for Outlook 2007 is not there..

    I am not using any forms, templates, etc.. just the plain old text format.

    I have checked the Mapi file and it is not associated with any applications, i thought as a test i would try to assoctiate it with Outlook 2007 but it wouldnt let me.. ha Oh well.

    I really am stuck. I can use the work around for the time being. Everyone here who has been migrated to outlook 07 seems to have the issue and i cant work out why!

    Let me know if you think of anything else. Thanks again for your help.

    +
    0 Votes
    alokjain

    i am facing a similar issue and wondering if you have found a fix. Query the web hasn't given any result.

    +
    0 Votes
    bangquackadoodle

    C:\Program Files (x86)\Microsoft Office\Office12\Outlook.exe should be a shortcut in your send to folder... you'll need to tag the end something like the above with a %1 - not sure about that detail. Then when you send to... just select the outlook link and send to there. Who knows why MS removed the feature? yikes!

    +
    1 Votes
    twist944

    Still using the work around at the minute.. Does that work for you?

    +
    0 Votes
    jrosnow

    I also do not have an .ost file in C:\Documents and Settings\username\local settings\application data\microsoft\outlook. I have .pst files for each account in Outlook, but no .ost file.

    When I chose to send a file, it is defaulting to Outlook Express, even though my default in both Outlook, and IE7 is Outlook. Also, my default browser is Firefox and I do not see anyplace to set program options in Firefox for your default mail handler.

    +
    2 Votes
    jrosnow

    After a lot of searching, I found something on a Mozilla Forum. http://forums.mozillazine.org/viewtopic.php?p=257603&sid=160721b251b3438601fb406e54a50b7d

    It was explaining how to set Outlook Express as a default, but I managed to get it working with Outlook 2007.

    If you go to Control Panel> Add or Remove Programs> Set program access & Defaults (one the left side bottom) you can choose if you a Computer Manufacturer, Microsoft Windows, Non-Microsoft, or Custom solution. Clicking the double arrows on the right lets you see the option. Choosing one of the 4 and hitting OK will apply the settings. I used custom and after an initial error of having to go into Outlook 2007 again and set it as my default (it already was), it works fine.

    +
    0 Votes
    robert_stewart65

    After up grading Office 2003 to Office 2007 with the Exchange mangement tools installed, i was getting the "mapi32.dll invalid extended mapi library" when using the send to function in word. the fix is pretty easy. Close your Outlook, in the System 32 Directory run the Fixmapi.exe, then open Outlook and try the send too function in Word... this solution worked for

    +
    0 Votes
    vuhn

    I lost the ability to "Send to Mail Recipient" and the command C:\WINDOWS\system32\fixmapi.exe has restored the function.
    Thanks a lot!

    +
    0 Votes
    marc.pichel

    Nice little fix, which is not really advertised by MS, so thanks indeed!

    +
    0 Votes
    ATLTEK

    Thank you very much! Spent 6 hours tracking down this article.
    Go figure... you have a MAPI error, just run the fixMAPI.exe. duh. if only they all were this easy.
    Cheers!
    Stevens

    +
    2 Votes

    If you goto "c:\documents and settings\(username)\sendto" and make a new shortcut with the target pointing to

    "c:\program files\Microsoft Office\Office12\outlook.exe" /a

    Name it whatever you want and then try to right click on a file and choose the shortcut and it should work.

    +
    0 Votes
    DBlayney

    However, what does seem to work, based on a few tests at least is simply to take the precaution of opening Outlook first. I did find that I had to fix the Email Recipient shortcut in "Sendto" as it was pointing at nothing.

    +
    0 Votes
    chennad

    This post made me think. I lost my SEND TO Outlook link when I installed Thunderbird. TO fix (thanks to this post). I copied the Mail recipient Shortcut (MAPAPI) from another user SEND TO folder on my PC to my USER SEND TO folder and it was repaired. THANKS!

    +
    1 Votes
    robo_dev

    some sort of record here. IF the poor old sod has been waiting for four years for our help, he's more patient than me,,,

  • +
    1 Votes
    rnewby

    Try deleting the outlook.ost file associated with your outlook account from

    C:\Documents and Settings\username\local settings\application data\microsoft\outlook

    Where username is your windows/network username

    Outlook must be closed when deleting this. The file will rebuild itself after you open Outlook again, your emails and folders will not have changed.

    +
    1 Votes
    rnewby

    Try deleting the outlook.ost file associated with your outlook account from

    C:\Documents and Settings\username\local settings\application data\microsoft\outlook

    Where username is your windows/network username

    Outlook must be closed when deleting this. The file will rebuild itself after you open Outlook again, your emails and folders will not have changed.

    +
    0 Votes
    twist944

    Hey,

    I have tried the above, i have even given myself a completley fresh profile yet i still cant use the send to mail recipient function.

    Work around is:

    Use the send to mail function when outlook is shut (should work ok). Then open outlook and it works fine???? Next time you re-boot log off etc... you have to do this again.

    ANYONE GOT ANY MORE SUGGESTIONS AS THIS IS DRIVING ME MAD... ha

    Cheers

    +
    0 Votes
    ThumbsUp2

    Where are you trying to click the "send to mail recipient" from? A web page? What are you using for your DEFAULT browser? Not just the one you fired up, but the DEFAULT?

    When you click the START button in Windows, do you see Outlook listed as the email client on the partial start menu that pops up, right below the Internet Explorer icon? If you do not, Outlook has NOT been set as your default email program.

    What is your de

    +
    0 Votes
    twist944

    Where are you trying to click the "send to mail recipient" from?

    Document saved on Windows Desktop

    A web page? What are you using for your DEFAULT browser?

    Not relevent but IE7

    When you click the START button in Windows, do you see Outlook listed as the email client on the partial start menu that pops up, right below the Internet Explorer icon? If you do not, Outlook has NOT been set as your default email program.

    No, But it does appear in programs, mircrosoft office. I have checked on tools, options, other, and outlook is set as default. Is there another way??


    What is your de

    I do not know what you mean.. Cheers

    +
    0 Votes
    ThumbsUp2

    Sorry about that last line. I started to type another question and changed my mind, then forgot to delete it.

    RE: "Not relevent but IE7"

    Yes, it matters. Believe it or not, IE is integrated throughout the system. If something there isn't working right, it can affect many other programs, Outlook included.

    RE: "No, but it does appear in programs, microsoft office."

    Sorry, I forgot you can set any program to show up on the Start Menu as your email program, but that does not set it as DEFAULT email program. The default is set through Internet Options in IE7, or control panel if you prefer to go that route. Since you probably already have your browser (IE7) open while reading this, click Tools -> Options -> Programs and make sure Outlook 2007 is set as your DEFAULT mail program. Click OK to exit that window. Now, try the right click and send to option for that file on your desktop.

    If it still doesn't work, read on......

    I haven't been able to find an article specific to Outlook 2007, but I did find one for Outlook 2003 which MIGHT be related to your problem. MS says that if you've set a custom FORM to be used for your email instead of the default form, the "Send To Mail Recipient" command will no longer function. Specifically, this paragraph:

    "The SendTo feature in the operating system

    To use the SendTo feature in Windows, right-click a file, click Send To, and then click Mail Recipient in the File menu. However, you cannot use this feature for a custom form that was created by using the Forms Administrator utility. To work around this limitation, you can add a new Send To entry so that a user can use the custom form that was created by using the Forms Administrator utility.

    Optionally, you can remove the existing Mail Recipient option in the Send To folder. The Send To folder is located in the following file system location:
    C:\Documents and Settings\<USER PROFILE>\SendTo
    Additionally, the Send To folder is a hidden system folder.
    "

    Be VERY carefull using any of the registry tweaks mentioned in this article (link below) because it is not specifically written for Office 2007. The paths will be different. However, the article might give you a few places to start looking to see if you can find why the Send To Mail Recipient command is not functioning properly.

    http://support.microsoft.com/kb/241235/en-us

    Another thing I located while searching was that you should have a system icon, not a shortcut with an arrow on it, in your SendTo folder called MapiMail. If that is no longer a system icon (no arrow indicating it's a shortcut), or if the program that normally opens your MapiMail has been , the Send To Mail Recipient won't function correctly. If you right click that icon and choose properties, you should see NO program associated with it. It should say "Opens With: Unknown application". If you see anything else, something has set itself to the default MAPI application.

    Let us know what you find.

    +
    0 Votes
    twist944

    Hello! Thanks for all this info by the way...

    Right..

    "Yes, it matters. Believe it or not, IE is integrated throughout the system. If something there isn't working right, it can affect many other programs, Outlook included."

    I have checked the settings in IE7 as you suggested and the default is set to Microsoft Outlook.. The option for Outlook 2007 is not there..

    I am not using any forms, templates, etc.. just the plain old text format.

    I have checked the Mapi file and it is not associated with any applications, i thought as a test i would try to assoctiate it with Outlook 2007 but it wouldnt let me.. ha Oh well.

    I really am stuck. I can use the work around for the time being. Everyone here who has been migrated to outlook 07 seems to have the issue and i cant work out why!

    Let me know if you think of anything else. Thanks again for your help.

    +
    0 Votes
    alokjain

    i am facing a similar issue and wondering if you have found a fix. Query the web hasn't given any result.

    +
    0 Votes
    bangquackadoodle

    C:\Program Files (x86)\Microsoft Office\Office12\Outlook.exe should be a shortcut in your send to folder... you'll need to tag the end something like the above with a %1 - not sure about that detail. Then when you send to... just select the outlook link and send to there. Who knows why MS removed the feature? yikes!

    +
    1 Votes
    twist944

    Still using the work around at the minute.. Does that work for you?

    +
    0 Votes
    jrosnow

    I also do not have an .ost file in C:\Documents and Settings\username\local settings\application data\microsoft\outlook. I have .pst files for each account in Outlook, but no .ost file.

    When I chose to send a file, it is defaulting to Outlook Express, even though my default in both Outlook, and IE7 is Outlook. Also, my default browser is Firefox and I do not see anyplace to set program options in Firefox for your default mail handler.

    +
    2 Votes
    jrosnow

    After a lot of searching, I found something on a Mozilla Forum. http://forums.mozillazine.org/viewtopic.php?p=257603&sid=160721b251b3438601fb406e54a50b7d

    It was explaining how to set Outlook Express as a default, but I managed to get it working with Outlook 2007.

    If you go to Control Panel> Add or Remove Programs> Set program access & Defaults (one the left side bottom) you can choose if you a Computer Manufacturer, Microsoft Windows, Non-Microsoft, or Custom solution. Clicking the double arrows on the right lets you see the option. Choosing one of the 4 and hitting OK will apply the settings. I used custom and after an initial error of having to go into Outlook 2007 again and set it as my default (it already was), it works fine.

    +
    0 Votes
    robert_stewart65

    After up grading Office 2003 to Office 2007 with the Exchange mangement tools installed, i was getting the "mapi32.dll invalid extended mapi library" when using the send to function in word. the fix is pretty easy. Close your Outlook, in the System 32 Directory run the Fixmapi.exe, then open Outlook and try the send too function in Word... this solution worked for

    +
    0 Votes
    vuhn

    I lost the ability to "Send to Mail Recipient" and the command C:\WINDOWS\system32\fixmapi.exe has restored the function.
    Thanks a lot!

    +
    0 Votes
    marc.pichel

    Nice little fix, which is not really advertised by MS, so thanks indeed!

    +
    0 Votes
    ATLTEK

    Thank you very much! Spent 6 hours tracking down this article.
    Go figure... you have a MAPI error, just run the fixMAPI.exe. duh. if only they all were this easy.
    Cheers!
    Stevens

    +
    2 Votes

    If you goto "c:\documents and settings\(username)\sendto" and make a new shortcut with the target pointing to

    "c:\program files\Microsoft Office\Office12\outlook.exe" /a

    Name it whatever you want and then try to right click on a file and choose the shortcut and it should work.

    +
    0 Votes
    DBlayney

    However, what does seem to work, based on a few tests at least is simply to take the precaution of opening Outlook first. I did find that I had to fix the Email Recipient shortcut in "Sendto" as it was pointing at nothing.

    +
    0 Votes
    chennad

    This post made me think. I lost my SEND TO Outlook link when I installed Thunderbird. TO fix (thanks to this post). I copied the Mail recipient Shortcut (MAPAPI) from another user SEND TO folder on my PC to my USER SEND TO folder and it was repaired. THANKS!

    +
    1 Votes
    robo_dev

    some sort of record here. IF the poor old sod has been waiting for four years for our help, he's more patient than me,,,