Questions

Outlook 2007 - rules do not run automatically

Tags:
+
0 Votes
Locked

Outlook 2007 - rules do not run automatically

mkotzev
We have recently upgraded to Outlook 2007, but when an employee makes a rule to be applied to a Collaboration Server account, the rules are not applied whenever messages arrive, only when we manually do "run rules now". This is a great annoyance and I have seen this bug on some other forums (unanswered). Has anyone else had this problem... any ideas?

~Miro
  • +
    0 Votes

    This is copied from the Microsoft website, i hope this helps you or at least takes you in the right direction.

    WORKAROUND
    To work around this issue, follow these steps.

    Step 1: Modify Outlook message rules to reduce client-only conditions
    Modify your message rules to try to reduce client-only conditions. For example, if a message rule contains a client-only condition such as with specific words in the recipient's address, modify it so that it uses one of the following server-side conditions instead:
    ? with specific words in the message header
    ? sent to people or distribution list
    To modify a message rule in Outlook, follow these steps:
    1. Start Outlook.
    2. On the Tools menu, click Rules and Alerts.
    3. On the E-mail Rules tab, click the client-only rule that you want to modify, and then click Edit Rule Settings on the Change Rule menu.
    4. Under Step 1: Select condition(s), click to clear the check box for the client-only condition. For example, click to clear the with specific words in the recipient's address check box.
    5. Click to select the check box for the server-side condition that you want to use. For example, click to select the sent to people or distribution list check box.
    6. Under Step 2: Edit the rule description (click and underlined value), click the underlined value that corresponds to the rule condition that you want to configure. For example, click people or distribution list.
    7. Click or type the value that you want to configure as the rule condition, and then click OK.
    8. After you finish changing client-only conditions to server-side conditions, click Finish.

    Step 2: Put server-side rules ahead of client-only rules in Outlook
    Try to arrange message rules in Outlook so that all the server-side message rules are processed before client-only message rules are processed. To do this, follow these steps:
    1. Start Outlook.
    2. On the Tools menu, click Rules and Alerts.
    3. On the E-mail Rules tab, click the client-only rule that you want to modify. For example, click rule name (client-only).
    4. Repeatedly, click the Move Down button that appears as a down arrow to move this rule under other rules in the Rule (applied in the order shown) list.
    5. When you are finished moving client-only rules to the bottom of the Rule (applied in the order shown) list, click OK.

    Please post back if you have anymore problems or questions.

    +
    0 Votes
    BPaulsen51

    Three men traveling in a helicopter were lost. They came upon an office building, & held up a sign that said, "Where are we?" In reply, the men in the office building held up a sign that said, "You're in a helicopter." Right away the men knew that they were at the Microsoft headquarters, in Bell/Red, WA, because the answer was yet another technically correct, but absolutely useless instruction.

    Sorry, I couldn't resist. I always appreciate people who take the time to help semi-computer savvy dumbos like me :)

    +
    1 Votes
    dennisr.schwabe

    I have recenly spend a few days researching possibly similar issues. What I relized today, once you create the rule in 2007 you may have not reviewed some "optons" outside of the rule itself. Select Rules and Alerts, choose your rule and pick change rule. You will notice below the Edit Rule Settings selection (to start editing your rule) there are other options. See if Move to Folder or Copy To Folder looks highlighted (selected/turned on). If you pick one of these and it turns colors this option is turned on, if no color its turned off.

    +
    0 Votes
    medullaoblongata

    I know this is an old post but I figured I'd give my solution in case others have run into the same problem.

    I have resolved the rules problem by turning off the Use Cached Exchange Mode in Outlook 2007. Here are the steps:
    1. Click on the Tools > Options menu.
    2. Click on the Mail Setup tab.
    3. Click on the Email Accounts button.
    4. Under the Email tab, select the name of your email account.
    5. Click the Change option, which is located above the account names.
    6. Uncheck the option called Use Cached Exchange Mode.

    Unchecking this box will also resolve problems with Out of Office messages not working correctly. The negative effect I've seen by turning off the option is that if your email server goes down you are not able to access any of your email messages because they are not being cached to your machine.

    +
    0 Votes
    dzinehaus_inf

    This is what I did and it seemed to resolve my rules issue...

    Go into your rules manager (Rules and Alerts) and then click on the options button and export your rules to a file.

    Next... select all your rules, and delete them. Now you should have 0 rules.

    Exit outlook and go back into it. Remember you have no rules right now.

    Open the Rules and Alerts window, click the options button and import that rules list from the file you just exported.

    This should resolve the issue.

    +
    0 Votes
    jbub

    I have this same problem. I was able to get my rules to work automatically by fixing them in OWA. Not a great answer but a workaround at least. When I checked out my rules in OWA they were all in error becuase they didn't have a folder specified.

    +
    0 Votes
    hdsmis01

    I have a COLLABORATION account and some rules run and some do not. Does anyone know why this happens?

    +
    0 Votes
    knownsense

    Hint as highlighted by "dennisr.schwabe@...'s " lead to the solution of my problem.
    Here is what i did
    (in OL 2007) I went to Tools-Rules, then selected the rule in question. Clicked the Change Rule option above it. Right below the Change Rule option you see a list with other probable options (namely Rename Rule, Display in the New Item Alert Window, Play a sound etc.. etc...)
    Depending upon the nature of our rule, one of these options gets highlighted by default, while we create the rule.
    What i found was that Move to folder option was highlighted in my case which was rightly highlighted during the rule creation. All i did was uncheck it, which changed the rule, i had to click Change Rule again and then click Edit Rule Settings, redifine my incomplete rule (by providing the folder path again, in my case) and it did the job.

  • +
    0 Votes

    This is copied from the Microsoft website, i hope this helps you or at least takes you in the right direction.

    WORKAROUND
    To work around this issue, follow these steps.

    Step 1: Modify Outlook message rules to reduce client-only conditions
    Modify your message rules to try to reduce client-only conditions. For example, if a message rule contains a client-only condition such as with specific words in the recipient's address, modify it so that it uses one of the following server-side conditions instead:
    ? with specific words in the message header
    ? sent to people or distribution list
    To modify a message rule in Outlook, follow these steps:
    1. Start Outlook.
    2. On the Tools menu, click Rules and Alerts.
    3. On the E-mail Rules tab, click the client-only rule that you want to modify, and then click Edit Rule Settings on the Change Rule menu.
    4. Under Step 1: Select condition(s), click to clear the check box for the client-only condition. For example, click to clear the with specific words in the recipient's address check box.
    5. Click to select the check box for the server-side condition that you want to use. For example, click to select the sent to people or distribution list check box.
    6. Under Step 2: Edit the rule description (click and underlined value), click the underlined value that corresponds to the rule condition that you want to configure. For example, click people or distribution list.
    7. Click or type the value that you want to configure as the rule condition, and then click OK.
    8. After you finish changing client-only conditions to server-side conditions, click Finish.

    Step 2: Put server-side rules ahead of client-only rules in Outlook
    Try to arrange message rules in Outlook so that all the server-side message rules are processed before client-only message rules are processed. To do this, follow these steps:
    1. Start Outlook.
    2. On the Tools menu, click Rules and Alerts.
    3. On the E-mail Rules tab, click the client-only rule that you want to modify. For example, click rule name (client-only).
    4. Repeatedly, click the Move Down button that appears as a down arrow to move this rule under other rules in the Rule (applied in the order shown) list.
    5. When you are finished moving client-only rules to the bottom of the Rule (applied in the order shown) list, click OK.

    Please post back if you have anymore problems or questions.

    +
    0 Votes
    BPaulsen51

    Three men traveling in a helicopter were lost. They came upon an office building, & held up a sign that said, "Where are we?" In reply, the men in the office building held up a sign that said, "You're in a helicopter." Right away the men knew that they were at the Microsoft headquarters, in Bell/Red, WA, because the answer was yet another technically correct, but absolutely useless instruction.

    Sorry, I couldn't resist. I always appreciate people who take the time to help semi-computer savvy dumbos like me :)

    +
    1 Votes
    dennisr.schwabe

    I have recenly spend a few days researching possibly similar issues. What I relized today, once you create the rule in 2007 you may have not reviewed some "optons" outside of the rule itself. Select Rules and Alerts, choose your rule and pick change rule. You will notice below the Edit Rule Settings selection (to start editing your rule) there are other options. See if Move to Folder or Copy To Folder looks highlighted (selected/turned on). If you pick one of these and it turns colors this option is turned on, if no color its turned off.

    +
    0 Votes
    medullaoblongata

    I know this is an old post but I figured I'd give my solution in case others have run into the same problem.

    I have resolved the rules problem by turning off the Use Cached Exchange Mode in Outlook 2007. Here are the steps:
    1. Click on the Tools > Options menu.
    2. Click on the Mail Setup tab.
    3. Click on the Email Accounts button.
    4. Under the Email tab, select the name of your email account.
    5. Click the Change option, which is located above the account names.
    6. Uncheck the option called Use Cached Exchange Mode.

    Unchecking this box will also resolve problems with Out of Office messages not working correctly. The negative effect I've seen by turning off the option is that if your email server goes down you are not able to access any of your email messages because they are not being cached to your machine.

    +
    0 Votes
    dzinehaus_inf

    This is what I did and it seemed to resolve my rules issue...

    Go into your rules manager (Rules and Alerts) and then click on the options button and export your rules to a file.

    Next... select all your rules, and delete them. Now you should have 0 rules.

    Exit outlook and go back into it. Remember you have no rules right now.

    Open the Rules and Alerts window, click the options button and import that rules list from the file you just exported.

    This should resolve the issue.

    +
    0 Votes
    jbub

    I have this same problem. I was able to get my rules to work automatically by fixing them in OWA. Not a great answer but a workaround at least. When I checked out my rules in OWA they were all in error becuase they didn't have a folder specified.

    +
    0 Votes
    hdsmis01

    I have a COLLABORATION account and some rules run and some do not. Does anyone know why this happens?

    +
    0 Votes
    knownsense

    Hint as highlighted by "dennisr.schwabe@...'s " lead to the solution of my problem.
    Here is what i did
    (in OL 2007) I went to Tools-Rules, then selected the rule in question. Clicked the Change Rule option above it. Right below the Change Rule option you see a list with other probable options (namely Rename Rule, Display in the New Item Alert Window, Play a sound etc.. etc...)
    Depending upon the nature of our rule, one of these options gets highlighted by default, while we create the rule.
    What i found was that Move to folder option was highlighted in my case which was rightly highlighted during the rule creation. All i did was uncheck it, which changed the rule, i had to click Change Rule again and then click Edit Rule Settings, redifine my incomplete rule (by providing the folder path again, in my case) and it did the job.