Questions

OWA does not work on Exchange Server 2003

Tags:
+
0 Votes
Locked

OWA does not work on Exchange Server 2003

yangshaopeng
All of sudden, OWA does not work on our Exchange Server 2003. It was working before though.

When I open the OWA page: http:\\domain\exchange, and then the username and password window appear, after type the username and password, then one page appeared with one message saying ' Cannot find this page' HTTP 440 Error.

The exchange server working well itself, and there is no error message on the IIS as well. What is the problem?

Appreciate your advice.

Peter
  • +
    0 Votes
    BFilmFan

    Check to make sure the World Wide WEb service is started.

    Increase the IIS logging, so that you can see what errors are heppening.

    Also recommended is http://searchexchange.techtarget.com/featuredTopic/0,290042,sid43_gci1084130,00.html.

    +
    0 Votes
    BdeJong

    Hi,

    Do you get a 404 page not found or a 440.

    the 440 error is caused by an authentication timeout/failure.

    What this "could" mean is that:

    1. you are actually getting timed out
    or
    2. your IUSR_(servername) and IWAM_(servername) are locked out or out of sync.
    (I have only seen this on a SBS server. But I do not recognize any SBS specifics in the solution so it should work for you.)

    Always check the account locked out checkbox on the account properties page first.

    If that seems to be in order you may want to try this (use with caution):

    1) Open AD Users & Computers. search for the IUSR_(servername) account and select "Reset password" Reset the password to anything you want, be sure that is a secure password though. Also, make sure that "Password never expires" and 'User cannot change password' are selected.

    2)Repeat steps 1 & 2 for the IWAM_(servername) account. Close AD Users & Computers.

    3)Open Internet Information Services (Start - Administrative Tools), Expand (servername) - Web Sites.

    4) Right-click on "Default Web Site" and select Properties.

    5) Go to the "Directory Security" tab and click the Edit button under "Authentication & Access Control"

    6) Enter the new password for the IUSR_(servername) account and click OK. Enter the password again to confirm and click OK. Click OK

    7) Open a command prompt and enter iisreset

    At the command prompt, enter the following:
    cd c:\inetpub\adminscripts

    adsutil SET w3svc/WAMUserPass "password" ("password" = the password you entered for the IWAM_(servername) account in step 2)

    c:\windows\system32\cscript.exe "c:\inetpub\adminscripts\synciwam.vbs" -v

    9) to finish up type another "iisreset" at the command prompt.

    This did the trick for the SBS server that had the issue and it probably will for you.


    Regards

    +
    0 Votes
    BdeJong

    Out of intrest I was looking up similar issues and I came accross this:

    The access rights on the file or folder;
    "C:\Program Files\Exchsrvr\exchweb\bin\auth\owalogon.asp" could be lost or changed.

    Checking those might give a quickfix.

    +
    0 Votes
    BdeJong

    Hi,

    Do you get a 404 page not found or a 440.

    the 440 error is caused by an authentication timeout/failure.

    What this "could" mean is that:

    1. you are actually getting timed out
    or
    2. your IUSR_(servername) and IWAM_(servername) are locked out or out of sync.
    (I have only seen this on a SBS server. But I do not recognize any SBS specifics in the solution so it should work for you.)

    Always check the account locked out checkbox on the account properties page first.

    If that seems to be in order you may want to try this (use with caution):

    1) Open AD Users & Computers. search for the IUSR_(servername) account and select "Reset password" Reset the password to anything you want, be sure that is a secure password though. Also, make sure that "Password never expires" and 'User cannot change password' are selected.

    2)Repeat steps 1 & 2 for the IWAM_(servername) account. Close AD Users & Computers.

    3)Open Internet Information Services (Start - Administrative Tools), Expand (servername) - Web Sites.

    4) Right-click on "Default Web Site" and select Properties.

    5) Go to the "Directory Security" tab and click the Edit button under "Authentication & Access Control"

    6) Enter the new password for the IUSR_(servername) account and click OK. Enter the password again to confirm and click OK. Click OK

    7) Open a command prompt and enter iisreset

    At the command prompt, enter the following:
    cd c:\inetpub\adminscripts

    adsutil SET w3svc/WAMUserPass "password" ("password" = the password you entered for the IWAM_(servername) account in step 2)

    c:\windows\system32\cscript.exe "c:\inetpub\adminscripts\synciwam.vbs" -v

    9) to finish up type another "iisreset" at the command prompt.

    This did the trick for the SBS server that had the issue and it probably will for you.


    Regards

  • +
    0 Votes
    BFilmFan

    Check to make sure the World Wide WEb service is started.

    Increase the IIS logging, so that you can see what errors are heppening.

    Also recommended is http://searchexchange.techtarget.com/featuredTopic/0,290042,sid43_gci1084130,00.html.

    +
    0 Votes
    BdeJong

    Hi,

    Do you get a 404 page not found or a 440.

    the 440 error is caused by an authentication timeout/failure.

    What this "could" mean is that:

    1. you are actually getting timed out
    or
    2. your IUSR_(servername) and IWAM_(servername) are locked out or out of sync.
    (I have only seen this on a SBS server. But I do not recognize any SBS specifics in the solution so it should work for you.)

    Always check the account locked out checkbox on the account properties page first.

    If that seems to be in order you may want to try this (use with caution):

    1) Open AD Users & Computers. search for the IUSR_(servername) account and select "Reset password" Reset the password to anything you want, be sure that is a secure password though. Also, make sure that "Password never expires" and 'User cannot change password' are selected.

    2)Repeat steps 1 & 2 for the IWAM_(servername) account. Close AD Users & Computers.

    3)Open Internet Information Services (Start - Administrative Tools), Expand (servername) - Web Sites.

    4) Right-click on "Default Web Site" and select Properties.

    5) Go to the "Directory Security" tab and click the Edit button under "Authentication & Access Control"

    6) Enter the new password for the IUSR_(servername) account and click OK. Enter the password again to confirm and click OK. Click OK

    7) Open a command prompt and enter iisreset

    At the command prompt, enter the following:
    cd c:\inetpub\adminscripts

    adsutil SET w3svc/WAMUserPass "password" ("password" = the password you entered for the IWAM_(servername) account in step 2)

    c:\windows\system32\cscript.exe "c:\inetpub\adminscripts\synciwam.vbs" -v

    9) to finish up type another "iisreset" at the command prompt.

    This did the trick for the SBS server that had the issue and it probably will for you.


    Regards

    +
    0 Votes
    BdeJong

    Out of intrest I was looking up similar issues and I came accross this:

    The access rights on the file or folder;
    "C:\Program Files\Exchsrvr\exchweb\bin\auth\owalogon.asp" could be lost or changed.

    Checking those might give a quickfix.

    +
    0 Votes
    BdeJong

    Hi,

    Do you get a 404 page not found or a 440.

    the 440 error is caused by an authentication timeout/failure.

    What this "could" mean is that:

    1. you are actually getting timed out
    or
    2. your IUSR_(servername) and IWAM_(servername) are locked out or out of sync.
    (I have only seen this on a SBS server. But I do not recognize any SBS specifics in the solution so it should work for you.)

    Always check the account locked out checkbox on the account properties page first.

    If that seems to be in order you may want to try this (use with caution):

    1) Open AD Users & Computers. search for the IUSR_(servername) account and select "Reset password" Reset the password to anything you want, be sure that is a secure password though. Also, make sure that "Password never expires" and 'User cannot change password' are selected.

    2)Repeat steps 1 & 2 for the IWAM_(servername) account. Close AD Users & Computers.

    3)Open Internet Information Services (Start - Administrative Tools), Expand (servername) - Web Sites.

    4) Right-click on "Default Web Site" and select Properties.

    5) Go to the "Directory Security" tab and click the Edit button under "Authentication & Access Control"

    6) Enter the new password for the IUSR_(servername) account and click OK. Enter the password again to confirm and click OK. Click OK

    7) Open a command prompt and enter iisreset

    At the command prompt, enter the following:
    cd c:\inetpub\adminscripts

    adsutil SET w3svc/WAMUserPass "password" ("password" = the password you entered for the IWAM_(servername) account in step 2)

    c:\windows\system32\cscript.exe "c:\inetpub\adminscripts\synciwam.vbs" -v

    9) to finish up type another "iisreset" at the command prompt.

    This did the trick for the SBS server that had the issue and it probably will for you.


    Regards