Questions

Ping on DNS name is intermittent

+
0 Votes
Locked

Ping on DNS name is intermittent

mellow52
We have a remote client that access our SBS 2003 R2 network via VPN. The VPN connection is good and stable. The client computer runs XP Pro and for most part everything works great. The problem is that some software need to communicate with another local client (not the server) the thing is it needs to do this via DNS name resolution and not via the IP of the client. It is intermittent, I can ping the IP all the time but ability to ping via name comes and goes for no apparent reason. I did set the primary DNS on the client network connection to the IP of the SBS box that has the DHCP and DNS.

The software fails the second the name cannot get pinged. What is causing this and what can I try? Thanks!

Remote Client

C:\ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : client3
Primary Dns Suffix . . . . . . . : xxxxx.local
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : xxxxx.local

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : VIA Rhine II Fast Ethernet Adapter
Physical Address. . . . . . . . . : 00-E0-4D-09-E5-31
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.100
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : xx.xx.xxx.101
192.168.2.1
Lease Obtained. . . . . . . . . . : Wednesday, December 12, 2007 7:22:48 AM
Lease Expires . . . . . . . . . . : Thursday, December 13, 2007 7:22:48 AM

PPP adapter VPN:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
Physical Address. . . . . . . . . : 00-53-45-00-00-00
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : xx.xx.xxx.15
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : xx.xx.xxx.15
DNS Servers . . . . . . . . . . . : xx.xx.xxx.101
Primary WINS Server . . . . . . . : xx.xx.xxx.101


Local Client

C:\ ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : CLIENT1
Primary Dns Suffix . . . . . . . : xxxxx.local
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : xxxxx.local

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . : xxxxx.local
Description . . . . . . . . . . . : Marvell Yukon 88E8001/8003/8010 PCI Gigabit Ethernet
Physical Address. . . . . . . . . : 00-15-F2-77-0C-D1
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::2d71:6ba1:fe63:4c7f%8(Preferred)
IPv4 Address. . . . . . . . . . . : xx.xx.xxx.20(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Wednesday, December 12, 2007 3:13:25 AM
Lease Expires . . . . . . . . . . : Thursday, December 20, 2007 3:13:24 AM
Default Gateway . . . . . . . . . : xx.xx.xxx.1
DHCP Server . . . . . . . . . . . : xx.xx.xxx.101
DHCPv6 IAID . . . . . . . . . . . : 201332210
DNS Servers . . . . . . . . . . . : xx.xx.xxx.101
Primary WINS Server . . . . . . . : xx.xx.xxx.101
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Local Area Connection* 6:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 02-00-54-55-4E-01
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 7:

Connection-specific DNS Suffix . : xxxxx.local
Description . . . . . . . . . . . : isatap.xxxxx.local
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::5efe:xx.xx.xxx.20%12(Preferred)
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : xx.xx.xxx.101
NetBIOS over Tcpip. . . . . . . . : Disabled
  • +
    0 Votes
    Churdoo

    Ideally of course it's best to fix whatever this intermittent DNS resolution issue is that's going on here, but that may be difficult to do through this forum.

    If you need to do a slam dunk here, you can put an entry in the remote client's %systemroot%/system32/drivers/etc/hosts. file mapping the DNS name of the application server to its IP address. Resolution via the local hosts. file takes precedence over every other resolution method thereby bypassing whatever is causing the flaky resolution.

    +
    0 Votes
    mellow52

    Thanks I will try this. So on the remote client I will add to the hosts file the IP and name of the local client it is having trouble pinging via name.

    I will report back.

    +
    0 Votes
    Churdoo

    Add a line in the hosts file as you have described.

    Plus I agree with bwilmot to remove IPv6 from those boxes.

    +
    0 Votes
    IC-IT

    First I would remove the IP6 and just use IP4.
    Second I would add another DNS server

    +
    0 Votes
    Dumphrey

    for a built in firewall, and make sure any software firewall on the client is allowing connection to the lan across the vpn. Cisco VPN clients have a built in firewall which can be disabled. You only want 1 firewall at any time to be active either local software or VPN client firewall.
    Are you using static IPs on the remote machine? If so dns info may not be getting refreashed often enough an ipconfig /registerdns may fix that.
    And as another poster up a bit said, you can always add a listing in the host file on the software server for the remote machine, as long as static ips are used.

  • +
    0 Votes
    Churdoo

    Ideally of course it's best to fix whatever this intermittent DNS resolution issue is that's going on here, but that may be difficult to do through this forum.

    If you need to do a slam dunk here, you can put an entry in the remote client's %systemroot%/system32/drivers/etc/hosts. file mapping the DNS name of the application server to its IP address. Resolution via the local hosts. file takes precedence over every other resolution method thereby bypassing whatever is causing the flaky resolution.

    +
    0 Votes
    mellow52

    Thanks I will try this. So on the remote client I will add to the hosts file the IP and name of the local client it is having trouble pinging via name.

    I will report back.

    +
    0 Votes
    Churdoo

    Add a line in the hosts file as you have described.

    Plus I agree with bwilmot to remove IPv6 from those boxes.

    +
    0 Votes
    IC-IT

    First I would remove the IP6 and just use IP4.
    Second I would add another DNS server

    +
    0 Votes
    Dumphrey

    for a built in firewall, and make sure any software firewall on the client is allowing connection to the lan across the vpn. Cisco VPN clients have a built in firewall which can be disabled. You only want 1 firewall at any time to be active either local software or VPN client firewall.
    Are you using static IPs on the remote machine? If so dns info may not be getting refreashed often enough an ipconfig /registerdns may fix that.
    And as another poster up a bit said, you can always add a listing in the host file on the software server for the remote machine, as long as static ips are used.