Questions

Problem Installing Cisco SDM on Cisco Router

+
0 Votes
Locked

Problem Installing Cisco SDM on Cisco Router

snabibax
Hello everyone, I am having a problem installing the Cisco SDM on my Cisco Router. The error message I get implies that HTTP or HTTPS is not enabled. However, I did enable the HTTP and HTTPS.

For HTTP, the status output is as below:


ROUTER1841#sh ip http server status
HTTP server status: Enabled
HTTP server port: 80
HTTP server authentication method: local
HTTP server access class: 23
HTTP server base path:
Maximum number of concurrent server connections allowed: 5
Server idle time-out: 600 seconds
Server life time-out: 86400 seconds
Maximum number of requests allowed on a connection: 10000
HTTP server active session modules: ALL
HTTP secure server capability: Present
HTTP secure server status: Enabled
HTTP secure server port: 443
HTTP secure server ciphersuite: 3des-ede-cbc-sha des-cbc-sha rc4-128-md5 rc4-128
-sha
HTTP secure server client authentication: Disabled
HTTP secure server trustpoint:
HTTP secure server active session modules: ALL
ROUTER1841#

For HTTPS, the status output is as below:

ROUTER1841#sh ip http server secure status
HTTP secure server status: Enabled
HTTP secure server port: 443
HTTP secure server ciphersuite: 3des-ede-cbc-sha des-cbc-sha rc4-128-md5 rc4-128
-sha
HTTP secure server client authentication: Disabled
HTTP secure server trustpoint:
HTTP secure server active session modules: ALL
ROUTER1841#
  • +
    0 Votes

    ...

    Apoorv182

    ...

    +
    0 Votes
    snabibax

    I still get the same error message as below even after following the steps you provided in that file.

    Unable to launch SDM due to one or more of the following reasons:
    (1) The IP address or hostname you provided is not a valid router address or is not reachable.
    (2)HTTP/HTTPS is disabled on the router
    SDM requires HTTP or HTTPS to be enabled on the router. If you are running HTTP or HTTPS on a custom port, specify the port number along with the device IP address or hostname (e.g. 10.10.10.1:<port number>).
    After you have fixed these problems, try again.

    +
    0 Votes

    ...

    Apoorv182

    ...

    +
    0 Votes
    snabibax

    thanks anyway though the problem still exists

    +
    0 Votes
    CG IT

    The IP address or hostname you provided is not a valid router address or is not reachable.

    That probably is the reason if you have http and https enabled on the router.

    What's your loopback address?

    what's the route table look like? [sh ip route]

    note: if you use a host name, you need a hosts file that can translate name to address [or DNS].

    +
    0 Votes
    snabibax

    F0/0 is 192.168.1.1 and this is what I use to ssh or telnet the router.

    The route table is as below:

    Gateway of last resort is 166.0.29.109 to network 0.0.0.0

    C 192.168.1.0/24 is directly connected, FastEthernet0/0
    166.0.29.0/30 is subnetted, 1 subnets
    C 166.0.29.108 is directly connected, Serial0/0/0:1
    10.0.0.0/32 is subnetted, 1 subnets
    C 10.0.0.1 is directly connected, Loopback0
    S* 0.0.0.0/0 [1/0] via 166.0.29.109

    +
    0 Votes
    CG IT

    if it's 192.168.1.1 then you should be able to access the router's web GUI

    +
    0 Votes
    NetMan1958

    I was just looking at this line from your "sh ip http server status" output:
    HTTP server access class: 23
    Do you have an access-list 23 configured? If so, what does it look like?

    +
    0 Votes
    snabibax

    Yes I do and here's how it looks like.

    Standard IP access list 23
    10 permit 10.10.10.0, wildcard bits 0.0.0.255

    +
    0 Votes
    NetMan1958

    are you trying to access it from ? The closest IP to 10.10.10.0/24 you have configured on the device is "C 10.0.0.1 is directly connected, Loopback0". If you are trying to access SDM from the LAN, then you need access-list 23 to look like this:
    "access list 23 permit 192.168.1.0 0.0.0.255"

  • +
    0 Votes

    ...

    Apoorv182

    ...

    +
    0 Votes
    snabibax

    I still get the same error message as below even after following the steps you provided in that file.

    Unable to launch SDM due to one or more of the following reasons:
    (1) The IP address or hostname you provided is not a valid router address or is not reachable.
    (2)HTTP/HTTPS is disabled on the router
    SDM requires HTTP or HTTPS to be enabled on the router. If you are running HTTP or HTTPS on a custom port, specify the port number along with the device IP address or hostname (e.g. 10.10.10.1:<port number>).
    After you have fixed these problems, try again.

    +
    0 Votes

    ...

    Apoorv182

    ...

    +
    0 Votes
    snabibax

    thanks anyway though the problem still exists

    +
    0 Votes
    CG IT

    The IP address or hostname you provided is not a valid router address or is not reachable.

    That probably is the reason if you have http and https enabled on the router.

    What's your loopback address?

    what's the route table look like? [sh ip route]

    note: if you use a host name, you need a hosts file that can translate name to address [or DNS].

    +
    0 Votes
    snabibax

    F0/0 is 192.168.1.1 and this is what I use to ssh or telnet the router.

    The route table is as below:

    Gateway of last resort is 166.0.29.109 to network 0.0.0.0

    C 192.168.1.0/24 is directly connected, FastEthernet0/0
    166.0.29.0/30 is subnetted, 1 subnets
    C 166.0.29.108 is directly connected, Serial0/0/0:1
    10.0.0.0/32 is subnetted, 1 subnets
    C 10.0.0.1 is directly connected, Loopback0
    S* 0.0.0.0/0 [1/0] via 166.0.29.109

    +
    0 Votes
    CG IT

    if it's 192.168.1.1 then you should be able to access the router's web GUI

    +
    0 Votes
    NetMan1958

    I was just looking at this line from your "sh ip http server status" output:
    HTTP server access class: 23
    Do you have an access-list 23 configured? If so, what does it look like?

    +
    0 Votes
    snabibax

    Yes I do and here's how it looks like.

    Standard IP access list 23
    10 permit 10.10.10.0, wildcard bits 0.0.0.255

    +
    0 Votes
    NetMan1958

    are you trying to access it from ? The closest IP to 10.10.10.0/24 you have configured on the device is "C 10.0.0.1 is directly connected, Loopback0". If you are trying to access SDM from the LAN, then you need access-list 23 to look like this:
    "access list 23 permit 192.168.1.0 0.0.0.255"