Questions

problem setting up internet / file sharing between two PCS via crossover

Tags:
+
0 Votes
Locked

problem setting up internet / file sharing between two PCS via crossover

rc9608
Greetings

My name is Ryan and I am fairly new to this whole forum discussion thing, please be gentle. (And I hope I am in the right spot)

I have two PCs, both with windows XP. Both have an ethernet card installed. One has a wireless internet connection (I share this connection with my roomate over a wireless router [that isn't anywhere near my setup so I cannot plug directly into the router itself]).

What I want to do is network both computers together so they can share files and the internet connection.

I purchased a crossover cable (yes I made sure)and connected both PCs together with it. I ran the network setup wizard on both PCs (which was a little confusing so I dont know if I did it right) It setup a connection but it has a big red "X" on it and it cannot find the network cable (on both machines). On both computers it says the cable is unplugged. And now I sometimes lose my internet connection on the host computer. If I disable the new local network connection I setup on the host I get internet back.

I know it can work, I know its possible to setup it up this way because I have done it before on windows 98. XP is a little different and I don't know what the heck I am doing or even what I am doing wrong. Do I need to manually setup TCP/IP? IPX? I've been reading the forums on this issue and it's all pretty confusing, pretty much everyone has a different solution for this.

I would appreciate any help you guys could give, I do thank you for your time.
  • +
    0 Votes
    OH Smeg

    On the Host Computer run the Network Setup Wizard. When approaching the section tell the unit that it connects directly to the Internet and that other computers connect through it. Share File & printers and when you reach the end shut off the Wizard.

    Plug in the crossover cable and make sure that the cable is reconsigned as plugged in at both ends. If it's not change the cable as it may be faulty.

    Then once you are being told that the LAN Cards have a Cable Plugged in run the Network Setup Wizard on the other computer and tell it that it connects to the Internet through another computer on the Network or a Residential Gateway and share the Files & Printers. When you reach the end of this wizard shut down without doing anything else.

    If the systems ask to be rebooted reboot and then you should have a working LAN.

    Lets know how you get on.

    Col

    +
    0 Votes
    rc9608

    I followed your instructions to the "T", no go. I think I might have purchased the wrong cable?

    The box says "Nexxtech Crossover Patch Cable CAT5e. Connects computer to computer or hub to hub"

    It said crossover so I bought it. However inspecting the connections on both ends, they both look the same. Aren't they supposed to be different?

    +
    0 Votes
    OH Smeg

    While the connections are supposed to be different they are only at the actual Wiring Stage where Lead 1 goes to Lead 2 and lead 2 goes to lead 1 and so on all through the 4 Pair Wiring. So you would need a Cable Tester to check the cable.

    It's possible that the cable could have been incorrectly labeled or it may not have been checked properly when it was made and have a faulty plug on it. There are so many options and without a Cable Tester there is nothing that you can do to test the cable.

    Just as an afterthought most Crossover Cables are a different color to the Standard Blue Cat 5e cable color and they should have some identification on them which from the big cable makers is generally a piece of sticky paper with Crossover printed on it.

    Col

    +
    0 Votes
    rc9608

    The package says "crossover patch cable". The cable itself is not labeled and it is grey in color. The funny thing is is the manufacturer Nexxtech (dist. by circuit city) does not have a listing for this product on their website.

    I've looked at color diagrams of crossovers ... etc and the one I have the connections both look identical to me. maybe it is the wrong cable.
    I think I'll go and try to exchange it and try the new one and see what happens.

    Man, you would think for $30 for this tiny cable they would package the correct friggin cable! or package a working one.

    +
    0 Votes
    OH Smeg

    Once I spent the best part of a week trying to get a LAN working. Naturally Nothing had been done to it to stop it working and I did specifically ask if any Network Leads had been changed. The reply was No there was no need.

    Well they made up their own CAT5 cables and some smart *** had tested a crossover cable on the main patch panel. When it didn't work it was left there and the next day when the entire LAN was down no one could find the problem.

    When I finally decided that I had to test every lead in the place I spent 2 days with a Cable Tester checking each and every lead. Naturally the Problem lead was the last one that I looked at.

    Col

    +
    0 Votes
    rc9608

    OK SO ... I went back to Circuit City (with my crossover cable) and they determined that they in fact have a bad batch of Nexxtech Crossover cables! So they let me exchange my faulty cable for a Belkin Gold Crossover cable. I got home, plugged it in and BOOM instant file sharing! Friggin Nexxtech! BUYER BEWARE: if you go to Circuit City and purchase a Nexxtech Crossover cable, it may not be a crossover cable.

    Ok now I have a good crossover cable and file sharing but I still cannot get internet connection sharing. When I open internet explorer on the "guest" computer it tries to detect the proxy settings for a minute (as if it was going to work) then it then pops up the dreaded "page cannot be displayed". I ran the wizard again and setup up everything again. got file sharing but still no internet sharing. any ideas?

    +
    0 Votes
    rc9608

    I forgot I needed to allow internet connection sharing. duh. So I went on the host computer and checked the "allow internet connection sharing" box. When I do this on the internet connection it says "connected, shared" on the host and "Internet Gateway: Wireless connection on HOST. Connected" on the GUEST computer. However I still do not have an internet connection on the GUST computer. Any ideas? I have IP addresses manually setup on both computers. Is that possibly the problem? (host=192.168.0.01, guest=192.168.0.2 subnet mask=255.255.255.0)

    +
    0 Votes
    ComputerCookie

    also what is the IP address of the modem?

    +
    0 Votes

    yes

    rc9608

    yes that is correct. typo.

    +
    0 Votes
    OH Smeg

    Reset he IP Address to Auto Configure you don't know what else is using that IP Range and what Address they have. Or how the WiFi Access point is allocating Addresses.

    If that doesn't work you could try Bridging the WiFi and LAN Connections. But I would set the IP & DNS to Auto Detect rather than Statically before you try to lock down the system. It's easier to work out problems if you haven't introduced any yourself in an attempt to stop problems occurring.

    Col

    +
    0 Votes
    rc9608

    thank you for your time and advice. very much appreciated. networking is so much fun.

    +
    0 Votes
    rc9608

    I set both the HOST and GUEST computers to obtain IP addresses & DNS automatically. Now on both PCs I get "Local Area Connection. Limited or no connectivity. This connection has limited or no connectivity. You might not be able to access the internet or some network resources."
    If I manually set IP address on both PCs again then I get my crossover connection back again. But still no internet. I see the option to bridge the connections, what exactly does that do? If I bridge the internet and network connections, do I do this on both PCs?

    Thanks again.

    +
    0 Votes
    OH Smeg

    No just the one that is the Host.

    As to what it does it basically creates a direct connection between the two Network Devices. Stick with manually setting the IP address as you are sort of stuck with it and try the bridge option but it may be that you need to reinstall the OS. A couple of months ago I had a bad Patch come down from M$ which killed all Networking on the XP machines but for some reason when reloaded & patched the same machine worked.

    If you think networking is hard now you should have tried it back in the DOS Days today It's positively easy.

    Col

    +
    0 Votes
    rc9608

    bump

    +
    0 Votes
    CG IT

    there's only 4 wires used in both straight through and crossover.

    here's a link with a diagram.

    http://www.gccprinters.com/support/doc/crossover.html

    now to share the internet connection on one computer that has internet with another that doesn't, you either connect to your wireless router via wireless NIC or you connect to the wireless router via another NIC. gotta have 2 NICs.

    Also note that the 2 NICs using the cross over have to have addressing assigned to it which is on the same subnet. if you get DHCP addressing from a DHCP server, I'd suggest you use static. less complicated to troubleshoot.

    When you run the ICS wizard on the computer with 2 NICs, make sure you create an ICS network disk to use on the other machine.

    Run the ICS wizard first on the machine that will be used to share it's internet connection. Establish that you can connect to the internet. Then take the ICS network disk to the other machine and run the ICS wizard and choose the disk option. This will setup that computer to use the other one for internet. Note: the computer with 2 NICs must always be on for the other computer to access the internet.

    +
    0 Votes

    ok

    rc9608

    I've looked at color diagrams of crossovers ... etc and the one I have the connections both look identical to me. maybe it is the wrong cable.
    I think I'll go and try to exchange it.

    As for the network disk, I do not have a floppy drive on either computer. There is no room for one. I might be able to swing it if I can create a network disk on a CD.

    +
    0 Votes

    n

    rc9608

    n

    +
    0 Votes
    Churdoo

    If it is in fact a crossover cable and is good, the connection would not have the red X on it. Plus if you can see the colors on the internal wires of the cable and they look like they're mapped the same at each end, then clearly it's a straight-through i.e. standard patch cable as opposed to a crossover cable.

    If crossover, you'd see the orange pair going into pins 1,2 on one end and into pins 3,6 on the other, while the green pair goes from 3,6 on the first end to 1,2 on the other.

    As for no floppy drives, no worries. Run the Network setup wizard from each PC and don't bother making the floppy; just be sure to enter the same settings as you run the wizard from each PC.

    +
    0 Votes
    rc9608

    yeah I think they packaged the wrong cable. I mean, the package says "crossover patch cable" yet both connections on the cable look identical. ugh this makes me angry, I spent $30 on this friggin thing and now I have to waste more gas and more of my time to go back and exchange it. what a hassle! friggin circuit city.

    +
    0 Votes
    rc9608

    thanks for all your guys help by the way. I really appreciate your time.

    +
    0 Votes
    seanferd

    It's just that wires are crossed within the cable.

    Doesn't mean the cable isn't bad, though.

    +
    0 Votes

    no

    rc9608

    no I ment the wireing. They are both identical

    +
    0 Votes
    seanferd

    Make sure that when you are setting up the crossover connection that you are configuring the wired ethernet card, not the wireless one.
    Make sure that both wired cards are installed properly (physically, and in the OS).

    Try disabling the wireless while you do this if nothing else is working?

    [Had a similar issue setting up a wired connection to a wireless/wired router. "Network cable unplugged." Darn wireless wouldn't stay off and was overriding the cable connection, and I had no wireless NIC.]

    +
    0 Votes
    rc9608

    bump

    +
    0 Votes
    Churdoo

    If it is in fact a crossover cable and is good, the connection would not have the red X on it. Plus if you can see the colors on the internal wires of the cable and they look like they're mapped the same at each end, then clearly it's a straight-through i.e. standard patch cable as opposed to a crossover cable.

    If crossover, you'd see the orange pair going into pins 1,2 on one end and into pins 3,6 on the other, while the green pair goes from 3,6 on the first end to 1,2 on the other.

    As for no floppy drives, no worries. Run the Network setup wizard from each PC and don't bother making the floppy; just be sure to enter the same settings as you run the wizard from each PC.

  • +
    0 Votes
    OH Smeg

    On the Host Computer run the Network Setup Wizard. When approaching the section tell the unit that it connects directly to the Internet and that other computers connect through it. Share File & printers and when you reach the end shut off the Wizard.

    Plug in the crossover cable and make sure that the cable is reconsigned as plugged in at both ends. If it's not change the cable as it may be faulty.

    Then once you are being told that the LAN Cards have a Cable Plugged in run the Network Setup Wizard on the other computer and tell it that it connects to the Internet through another computer on the Network or a Residential Gateway and share the Files & Printers. When you reach the end of this wizard shut down without doing anything else.

    If the systems ask to be rebooted reboot and then you should have a working LAN.

    Lets know how you get on.

    Col

    +
    0 Votes
    rc9608

    I followed your instructions to the "T", no go. I think I might have purchased the wrong cable?

    The box says "Nexxtech Crossover Patch Cable CAT5e. Connects computer to computer or hub to hub"

    It said crossover so I bought it. However inspecting the connections on both ends, they both look the same. Aren't they supposed to be different?

    +
    0 Votes
    OH Smeg

    While the connections are supposed to be different they are only at the actual Wiring Stage where Lead 1 goes to Lead 2 and lead 2 goes to lead 1 and so on all through the 4 Pair Wiring. So you would need a Cable Tester to check the cable.

    It's possible that the cable could have been incorrectly labeled or it may not have been checked properly when it was made and have a faulty plug on it. There are so many options and without a Cable Tester there is nothing that you can do to test the cable.

    Just as an afterthought most Crossover Cables are a different color to the Standard Blue Cat 5e cable color and they should have some identification on them which from the big cable makers is generally a piece of sticky paper with Crossover printed on it.

    Col

    +
    0 Votes
    rc9608

    The package says "crossover patch cable". The cable itself is not labeled and it is grey in color. The funny thing is is the manufacturer Nexxtech (dist. by circuit city) does not have a listing for this product on their website.

    I've looked at color diagrams of crossovers ... etc and the one I have the connections both look identical to me. maybe it is the wrong cable.
    I think I'll go and try to exchange it and try the new one and see what happens.

    Man, you would think for $30 for this tiny cable they would package the correct friggin cable! or package a working one.

    +
    0 Votes
    OH Smeg

    Once I spent the best part of a week trying to get a LAN working. Naturally Nothing had been done to it to stop it working and I did specifically ask if any Network Leads had been changed. The reply was No there was no need.

    Well they made up their own CAT5 cables and some smart *** had tested a crossover cable on the main patch panel. When it didn't work it was left there and the next day when the entire LAN was down no one could find the problem.

    When I finally decided that I had to test every lead in the place I spent 2 days with a Cable Tester checking each and every lead. Naturally the Problem lead was the last one that I looked at.

    Col

    +
    0 Votes
    rc9608

    OK SO ... I went back to Circuit City (with my crossover cable) and they determined that they in fact have a bad batch of Nexxtech Crossover cables! So they let me exchange my faulty cable for a Belkin Gold Crossover cable. I got home, plugged it in and BOOM instant file sharing! Friggin Nexxtech! BUYER BEWARE: if you go to Circuit City and purchase a Nexxtech Crossover cable, it may not be a crossover cable.

    Ok now I have a good crossover cable and file sharing but I still cannot get internet connection sharing. When I open internet explorer on the "guest" computer it tries to detect the proxy settings for a minute (as if it was going to work) then it then pops up the dreaded "page cannot be displayed". I ran the wizard again and setup up everything again. got file sharing but still no internet sharing. any ideas?

    +
    0 Votes
    rc9608

    I forgot I needed to allow internet connection sharing. duh. So I went on the host computer and checked the "allow internet connection sharing" box. When I do this on the internet connection it says "connected, shared" on the host and "Internet Gateway: Wireless connection on HOST. Connected" on the GUEST computer. However I still do not have an internet connection on the GUST computer. Any ideas? I have IP addresses manually setup on both computers. Is that possibly the problem? (host=192.168.0.01, guest=192.168.0.2 subnet mask=255.255.255.0)

    +
    0 Votes
    ComputerCookie

    also what is the IP address of the modem?

    +
    0 Votes

    yes

    rc9608

    yes that is correct. typo.

    +
    0 Votes
    OH Smeg

    Reset he IP Address to Auto Configure you don't know what else is using that IP Range and what Address they have. Or how the WiFi Access point is allocating Addresses.

    If that doesn't work you could try Bridging the WiFi and LAN Connections. But I would set the IP & DNS to Auto Detect rather than Statically before you try to lock down the system. It's easier to work out problems if you haven't introduced any yourself in an attempt to stop problems occurring.

    Col

    +
    0 Votes
    rc9608

    thank you for your time and advice. very much appreciated. networking is so much fun.

    +
    0 Votes
    rc9608

    I set both the HOST and GUEST computers to obtain IP addresses & DNS automatically. Now on both PCs I get "Local Area Connection. Limited or no connectivity. This connection has limited or no connectivity. You might not be able to access the internet or some network resources."
    If I manually set IP address on both PCs again then I get my crossover connection back again. But still no internet. I see the option to bridge the connections, what exactly does that do? If I bridge the internet and network connections, do I do this on both PCs?

    Thanks again.

    +
    0 Votes
    OH Smeg

    No just the one that is the Host.

    As to what it does it basically creates a direct connection between the two Network Devices. Stick with manually setting the IP address as you are sort of stuck with it and try the bridge option but it may be that you need to reinstall the OS. A couple of months ago I had a bad Patch come down from M$ which killed all Networking on the XP machines but for some reason when reloaded & patched the same machine worked.

    If you think networking is hard now you should have tried it back in the DOS Days today It's positively easy.

    Col

    +
    0 Votes
    rc9608

    bump

    +
    0 Votes
    CG IT

    there's only 4 wires used in both straight through and crossover.

    here's a link with a diagram.

    http://www.gccprinters.com/support/doc/crossover.html

    now to share the internet connection on one computer that has internet with another that doesn't, you either connect to your wireless router via wireless NIC or you connect to the wireless router via another NIC. gotta have 2 NICs.

    Also note that the 2 NICs using the cross over have to have addressing assigned to it which is on the same subnet. if you get DHCP addressing from a DHCP server, I'd suggest you use static. less complicated to troubleshoot.

    When you run the ICS wizard on the computer with 2 NICs, make sure you create an ICS network disk to use on the other machine.

    Run the ICS wizard first on the machine that will be used to share it's internet connection. Establish that you can connect to the internet. Then take the ICS network disk to the other machine and run the ICS wizard and choose the disk option. This will setup that computer to use the other one for internet. Note: the computer with 2 NICs must always be on for the other computer to access the internet.

    +
    0 Votes

    ok

    rc9608

    I've looked at color diagrams of crossovers ... etc and the one I have the connections both look identical to me. maybe it is the wrong cable.
    I think I'll go and try to exchange it.

    As for the network disk, I do not have a floppy drive on either computer. There is no room for one. I might be able to swing it if I can create a network disk on a CD.

    +
    0 Votes

    n

    rc9608

    n

    +
    0 Votes
    Churdoo

    If it is in fact a crossover cable and is good, the connection would not have the red X on it. Plus if you can see the colors on the internal wires of the cable and they look like they're mapped the same at each end, then clearly it's a straight-through i.e. standard patch cable as opposed to a crossover cable.

    If crossover, you'd see the orange pair going into pins 1,2 on one end and into pins 3,6 on the other, while the green pair goes from 3,6 on the first end to 1,2 on the other.

    As for no floppy drives, no worries. Run the Network setup wizard from each PC and don't bother making the floppy; just be sure to enter the same settings as you run the wizard from each PC.

    +
    0 Votes
    rc9608

    yeah I think they packaged the wrong cable. I mean, the package says "crossover patch cable" yet both connections on the cable look identical. ugh this makes me angry, I spent $30 on this friggin thing and now I have to waste more gas and more of my time to go back and exchange it. what a hassle! friggin circuit city.

    +
    0 Votes
    rc9608

    thanks for all your guys help by the way. I really appreciate your time.

    +
    0 Votes
    seanferd

    It's just that wires are crossed within the cable.

    Doesn't mean the cable isn't bad, though.

    +
    0 Votes

    no

    rc9608

    no I ment the wireing. They are both identical

    +
    0 Votes
    seanferd

    Make sure that when you are setting up the crossover connection that you are configuring the wired ethernet card, not the wireless one.
    Make sure that both wired cards are installed properly (physically, and in the OS).

    Try disabling the wireless while you do this if nothing else is working?

    [Had a similar issue setting up a wired connection to a wireless/wired router. "Network cable unplugged." Darn wireless wouldn't stay off and was overriding the cable connection, and I had no wireless NIC.]

    +
    0 Votes
    rc9608

    bump

    +
    0 Votes
    Churdoo

    If it is in fact a crossover cable and is good, the connection would not have the red X on it. Plus if you can see the colors on the internal wires of the cable and they look like they're mapped the same at each end, then clearly it's a straight-through i.e. standard patch cable as opposed to a crossover cable.

    If crossover, you'd see the orange pair going into pins 1,2 on one end and into pins 3,6 on the other, while the green pair goes from 3,6 on the first end to 1,2 on the other.

    As for no floppy drives, no worries. Run the Network setup wizard from each PC and don't bother making the floppy; just be sure to enter the same settings as you run the wizard from each PC.