Questions

Problem to access Internet from Cisco ASA 5505

+
0 Votes
Locked

Problem to access Internet from Cisco ASA 5505

lind
I have setuped for Cisco ASA5505 firewall for Internet connection for our network, but it does not work. The problem is that it cannot ping the ip address from inside network to outside network. I have tried to configure the access list to enable the connection from inside to outside, but did not succeed.

The following is my configuration for the firewall:
ciscoasa# show run
: Saved
:
ASA Version 7.2(3)
!
hostname ciscoasa
domain-name mweb.com.na
enable password xxxxx encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.2.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
pppoe client vpdn group Mweb
ip address xx.xx.34.135 255.255.255.255 pppoe setroute
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd nZZ6/5qG4wBrg9bw encrypted
ftp mode passive
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
name-server xx.xx.72.27
name-server xx.xx.72.28
domain-name mweb.com.na
access-list inside_access_out extended deny tcp 192.168.2.0 255.255.255.0 eq telnet any eq telnet
access-list inside_access_out extended permit tcp any eq ftp any eq ftp
access-list inside_access_out extended permit tcp any eq smtp any eq smtp
access-list inside_access_out extended permit tcp any eq pop3 any eq pop3
access-list inside_access_out extended permit tcp any eq www any eq www
access-list inside_access_out extended permit tcp any eq https any eq https
access-list inside_access_out extended permit udp any eq echo any eq echo
access-list inside_access_out extended permit ip 192.168.2.0 255.255.255.0 host xx.xx.34.135
access-list inside_access_out extended permit ip host 192.168.2.0 host xx.xx.34.135
access-list inside_access_out extended permit ip 192.168.2.0 255.255.255.0 xx.xx.34.0 255.255.255.0
access-list inside_access_out extended permit icmp 192.168.2.0 255.255.255.0 host xx.xx.34.135
access-list outside_access_in extended deny tcp any eq telnet any eq telnet
access-list outside_access_in extended deny tcp any eq ftp any eq ftp
access-list outside_access_in extended permit ip xx.xx.34.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list outside_access_in extended permit ip host xx.xx.34.135 192.168.2.0 255.255.255.0
access-list inside_access_in extended permit ip host 192.168.2.0 host xx.xx.34.135
access-list inside_access_in extended permit ip xx.xx.34.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list inside_access_in extended permit ip 192.168.2.0 255.255.255.0 host xx.xx.34.135
access-list inside_access_in extended permit ip 192.168.2.0 255.255.255.0 xx.xx.34.0 255.255.255.0
access-list inside_access_in extended permit ip host 192.168.2.0 xx.xx.34.0 255.255.255.0
access-list inside_access_in extended permit ip host xx.xx.34.135 any
access-list inside extended permit ip 192.168.2.0 255.255.255.0 host xx.xx.34.135
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 1 192.168.2.0 255.255.255.0 dns
access-group inside_access_in in interface inside
access-group inside_access_out out interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.30.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.2.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh 192.168.3.0 255.255.255.0 inside
ssh 192.168.2.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
vpdn group Mweb request dialout pppoe
vpdn group Mweb localname silnam1
vpdn group Mweb ppp authentication chap
vpdn username silnam1 password *********
dhcpd auto_config outside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
username lind password xxxxx encrypted
prompt hostname context
Cryptochecksum:bfc7d2bebcf253e88799eb459e1c555e
: end

May anyone please help me to see whether there is something miss or wrong for my configuration.

Thank you

Daniel Lin
+
0 Votes
SYNner

You don't have a route... more specifically, your default route is pointing to some unknown interface.

+
0 Votes
lind

Hi,

I have a default route for the firewall which is configured for the following line:
route outside 0.0.0.0 0.0.0.0 192.168.30.1 1

The only problem is that I cannot access this default route from my inside network, it seems to be blocked by the ACL. I need to know how to enable inside network to communicate with outside network. Do you have any idea?

Thanks

Daniel

+
0 Votes
pijlgroms

did anyone find a solution for this issue ?? i'm experience the
same.

+
0 Votes
kd_shah2001

yeah i can solve ur problem pls send me a copy of running-config file..

+
0 Votes

Set them to "1499", and then try the connection again, you might have to reboot the cisco router/switch for the changes to take affect.
(mtu inside 1500)
(mtu outside 1500)

Please post back if you have more problems or questions.

+
0 Votes
kd_shah2001

(1) 1'st U remove ur all access-list.
(2) Apply new access-list permit any to any
(3) modify ur default route as 0.0.0.0 0.0.0.0 xx.xx.34.135
(4) Also config NAT any to any
(5) now check ping from inside pc
(6) Apply one by ony ur denied access condition and check it out after every steps.

+
0 Votes
career

I don't think default route is the problem here, since you are dynamically setting that using PPPoE.