Questions

RAID drive failure: Bad luck, or false failure?

Tags:
+
0 Votes
Locked

RAID drive failure: Bad luck, or false failure?

robo_dev
Dell dimension E520 Desktop with Intel SATA Raid Controller configured for RAID 0 (mirroring).

Initially I had a pair of Seagate 500 GB drives in there, but only after a week, the flashing red 'drive failure' Icon was there, indicating that the secondary drive had failed.

In preparation for returning the drive, I put it in a SATA drive enclosure, ran SeaTools Diags on it (passed), and then did a DBAN data erase on the drive with no problems.

After returning the Seagate to my friends at Fry's Electronics, I put in a shiny brand new Hitachi 1TB SATA drive as my secondary (I plan to make the primary be an identical Hitachi drive, BTW).

The drive re-mirrored itself without a hitch, seemed happy as a clam, then two days later it shows the Hitachi is in 'failed' state.

Am I just having bad luck?

Is something killing my secondary hard drive?

Or is this a 'false failure'? What would cause the PC to think a drive has failed when it has not?

I plan to swap SATA cables and check for BIOS updates.
  • +
    0 Votes

    If not then that might be the cause of your problem. For any drive in a Raid setup they have to be identical in make and memory. I have a similar error but with four 500gb drives and one is just slightly different than the rest and it is (or it seems to be) failing but in reality it is fine, runs good and holds data so far. But just in case i have ordered another drive to take its place as a spare, this is in a Raid 1/0 setup.
    Answer to your question i would say it is a false failure, but (if you can) get another drive and have it as a spare in the same setup so when it does happen again it would automatically switch over to the spare.

    +
    0 Votes
    robo_dev

    I noticed that the Dell site shows all kinds of firmware updates for every hard drive offered for this model, leading me to believe that the storage subsystem may have issues.

    I have had good luck with Intel RAID-0 on these Dell Dimension PCs in general, I have several of them running as security DVRs without problems.

    Right now these drives are NOT identical at all.

    At this point I am thinking that the Seagate drive that failed really did go bad, and that this Hitachi is a false failure since it is very different from it's mate, the Seagate.

    +
    0 Votes

    To see if it holds good if not then you have your answer.
    Another question, do you have the drives as hotswap?
    If not then this might help you out faster if one of the drives does fail again.

    +
    0 Votes
    Charles Bundy

    http://download.intel.com/support/motherboards/server/sb/intelraidbasictroubleshootingguidev1_0.pdf

    BTW if it's a mirror we're talking RAID-1 right? If it seems to be the second drive faulting consistently I'd say reseat your cabling assuming it isn't off a backplane. It almost sounds like the second drive is not responding in a timely fashion, or that there are channel communication problems versus platter issues. Same RPM right? Not trying to mix 7K or 5K? Watch adaptive spindle green drives! Drive differences are pretty much moot in modern controllers (host and drive) except that RPM can play havoc with timing.

  • +
    0 Votes

    If not then that might be the cause of your problem. For any drive in a Raid setup they have to be identical in make and memory. I have a similar error but with four 500gb drives and one is just slightly different than the rest and it is (or it seems to be) failing but in reality it is fine, runs good and holds data so far. But just in case i have ordered another drive to take its place as a spare, this is in a Raid 1/0 setup.
    Answer to your question i would say it is a false failure, but (if you can) get another drive and have it as a spare in the same setup so when it does happen again it would automatically switch over to the spare.

    +
    0 Votes
    robo_dev

    I noticed that the Dell site shows all kinds of firmware updates for every hard drive offered for this model, leading me to believe that the storage subsystem may have issues.

    I have had good luck with Intel RAID-0 on these Dell Dimension PCs in general, I have several of them running as security DVRs without problems.

    Right now these drives are NOT identical at all.

    At this point I am thinking that the Seagate drive that failed really did go bad, and that this Hitachi is a false failure since it is very different from it's mate, the Seagate.

    +
    0 Votes

    To see if it holds good if not then you have your answer.
    Another question, do you have the drives as hotswap?
    If not then this might help you out faster if one of the drives does fail again.

    +
    0 Votes
    Charles Bundy

    http://download.intel.com/support/motherboards/server/sb/intelraidbasictroubleshootingguidev1_0.pdf

    BTW if it's a mirror we're talking RAID-1 right? If it seems to be the second drive faulting consistently I'd say reseat your cabling assuming it isn't off a backplane. It almost sounds like the second drive is not responding in a timely fashion, or that there are channel communication problems versus platter issues. Same RPM right? Not trying to mix 7K or 5K? Watch adaptive spindle green drives! Drive differences are pretty much moot in modern controllers (host and drive) except that RPM can play havoc with timing.