Questions

Remote Desktop console session issues between Vista SP1 and Server 2003

+
0 Votes
Locked

Remote Desktop console session issues between Vista SP1 and Server 2003

g0dFather
Our file server runs Windows Server 2003. My work machine has XP Pro and I can easily access the server console session by creating a shortcut to my .rdp file and adding /admin at the end.

I have Vista SP1 at home. I can only access the console session by typing "mstsc /admin" in the Run prompt. Making a shortcut to the saved .rdp file and adding /admin at the end does not work.

Is this intentional on Microsoft's part or am I missing something?

Thanks in advance.
  • +
    0 Votes
    Jacky Howe

    seem to have changed since SP1. This is how I set it up this morning from Vista to SBS2003.
    <br><br>

    Click Start, Programs, Accessories and Remote Desktop Connection. At Computer type in the IP address and click Options. Type in the Username and tick the box Allow me to save credentials. Configure your settings. Select Save as and save it to the Desktop. Close out of the setup and double click on the new Shortcut. Enter your password and you can click on Options and it should give you the proper Domain name. Click on OK and you should be good to go. You will receive two connection messages that can be disabled.
    <br><br>
    <i>Keep us informed as to your progress if you require further assistance.</i>
    <br><br>
    <i>If you think that any of the posts that have been made by all TR Members, have solved or contributed to solving the problem, please Mark them as <b>Helpful</b> so that others may benefit from the outcome.
    </i>

    +
    0 Votes
    Jacky Howe

    that I am using Vista Business.

    +
    0 Votes
    g0dFather

    No dice, it doesn't get me to the console session.

    The way I was taught (and it works with XP) was to setup and save your .rdp file. Create a shortcut to the .rdp file and add /admin to the end of the target line.

    Example:
    "D:\My Documents\Default.rdp" /admin

    With Vista, I can only get the console session if I click Start > Run > mstsc /admin, set the RDP settings and click Connect.

    +
    0 Votes
    Jacky Howe

    of Vista are you using. Your method works in Vista Business by just typing mstsc or by adding the /admin switch. Have you tried saving a Shortcut to the Desktop and double clicking it. Have you still got UAC running.

    +
    0 Votes
    g0dFather

    Vista Ultimate SP1 x64 with UAC completely off.

    A shortcut to mstsc will work and I suppose I could do that, but the server 2003 box is just one of many machines that I RDP into. Launching it from the corresponding shortcut/.rdp file is faster. Plus, it works properly in XP Pro x86.

    +
    0 Votes
    Jacky Howe

    click my shortcut the logon screen is there almost straight away. I don't see how having a shortcut to it is any quicker as it is an extra step.

    +
    0 Votes
    g0dFather

    on different pages. Think of it as double-clicking on an MP3 file and your default media player opens, or double-clicking on a PDF opens Adobe Reader, etc.

    I have created individual .rdp files for each machine that I remote into by opening Remote Desktop Connection, configuring it for each machine, then Save As. Any .rdp files that point to a Server 2003 machine have an adjoining shortcut that includes /admin at the end.

    On my Windows XP Pro SP3 x86 machine, I double-click the shortcut pointing to the .rdp file. It automatically opens and takes me to the Server 2003 login window. I log in and get the console session.

    On my Vista Ultimate SP1 x64 machine, I set things up the same way. I double-click the shortcut and it also brings me to the Server login screen, but it does not give me the console session.

    In summary, XP Pro accepts the /admin command both when launching mstsc or an .rdp file. Vista only accepts the /admin command when launching mstsc.

    It becomes more steps because I have to launch mstsc /admin, then select Open, choose the .rdp file, then Connect.

    I'm not trying to talk down to you. I'm just trying to be as detailed as possible.

    +
    0 Votes
    Jacky Howe

    1. mstsc.exe /v:111.222.333.111 /admin /w:800 /h:600
    <br>
    2. %windir%\system32\mstsc.exe c:\test.rdp /admin /w:800 /h:600
    <br><br>

    Helpful Tip: Create a Remote Desktop Shortcut
    <br>
    http://cybernetnews.com/2007/10/31/helpful-tip-create-a-remote-desktop-shortcut/
    <br><br>

    1. will take you to the logon screen and you will have to enter all information.
    <br><br>
    2. will run the .RDP with the admin switch and you have to enter the password.
    <br>
    I am sure that you used to be able to save the password prior to RDC 6.
    <br><br>
    < just to add that you still can save by clicking Allow me to save credentials. >
    <br><br>
    <i>Keep us informed as to your progress if you require further assistance.</i>
    <br><br>
    <i>If you think that any of the posts that have been made by all TR Members, have solved or contributed to solving the problem, please Mark them as <b>Helpful</b> so that others may benefit from the outcome.
    </i>

    +
    0 Votes
    g0dFather

    I went with the number 2 suggestion (minus the width/height since it's already in the .rdp file) and it worked perfectly. It makes sense too, kind of annoyed at myself now.

    I also appreciate the link. I'm interested in trying that Royal TS that some people promoted in the Comments section.

    Thank you Jacky!

    +
    0 Votes
    Jacky Howe

    now I have to fix my shortcuts as the width/height is effecting them. Global effect.

    +
    0 Votes
    jfairbairn

    thats one less technical pain in the neck today. - J(??j)E

  • +
    0 Votes
    Jacky Howe

    seem to have changed since SP1. This is how I set it up this morning from Vista to SBS2003.
    <br><br>

    Click Start, Programs, Accessories and Remote Desktop Connection. At Computer type in the IP address and click Options. Type in the Username and tick the box Allow me to save credentials. Configure your settings. Select Save as and save it to the Desktop. Close out of the setup and double click on the new Shortcut. Enter your password and you can click on Options and it should give you the proper Domain name. Click on OK and you should be good to go. You will receive two connection messages that can be disabled.
    <br><br>
    <i>Keep us informed as to your progress if you require further assistance.</i>
    <br><br>
    <i>If you think that any of the posts that have been made by all TR Members, have solved or contributed to solving the problem, please Mark them as <b>Helpful</b> so that others may benefit from the outcome.
    </i>

    +
    0 Votes
    Jacky Howe

    that I am using Vista Business.

    +
    0 Votes
    g0dFather

    No dice, it doesn't get me to the console session.

    The way I was taught (and it works with XP) was to setup and save your .rdp file. Create a shortcut to the .rdp file and add /admin to the end of the target line.

    Example:
    "D:\My Documents\Default.rdp" /admin

    With Vista, I can only get the console session if I click Start > Run > mstsc /admin, set the RDP settings and click Connect.

    +
    0 Votes
    Jacky Howe

    of Vista are you using. Your method works in Vista Business by just typing mstsc or by adding the /admin switch. Have you tried saving a Shortcut to the Desktop and double clicking it. Have you still got UAC running.

    +
    0 Votes
    g0dFather

    Vista Ultimate SP1 x64 with UAC completely off.

    A shortcut to mstsc will work and I suppose I could do that, but the server 2003 box is just one of many machines that I RDP into. Launching it from the corresponding shortcut/.rdp file is faster. Plus, it works properly in XP Pro x86.

    +
    0 Votes
    Jacky Howe

    click my shortcut the logon screen is there almost straight away. I don't see how having a shortcut to it is any quicker as it is an extra step.

    +
    0 Votes
    g0dFather

    on different pages. Think of it as double-clicking on an MP3 file and your default media player opens, or double-clicking on a PDF opens Adobe Reader, etc.

    I have created individual .rdp files for each machine that I remote into by opening Remote Desktop Connection, configuring it for each machine, then Save As. Any .rdp files that point to a Server 2003 machine have an adjoining shortcut that includes /admin at the end.

    On my Windows XP Pro SP3 x86 machine, I double-click the shortcut pointing to the .rdp file. It automatically opens and takes me to the Server 2003 login window. I log in and get the console session.

    On my Vista Ultimate SP1 x64 machine, I set things up the same way. I double-click the shortcut and it also brings me to the Server login screen, but it does not give me the console session.

    In summary, XP Pro accepts the /admin command both when launching mstsc or an .rdp file. Vista only accepts the /admin command when launching mstsc.

    It becomes more steps because I have to launch mstsc /admin, then select Open, choose the .rdp file, then Connect.

    I'm not trying to talk down to you. I'm just trying to be as detailed as possible.

    +
    0 Votes
    Jacky Howe

    1. mstsc.exe /v:111.222.333.111 /admin /w:800 /h:600
    <br>
    2. %windir%\system32\mstsc.exe c:\test.rdp /admin /w:800 /h:600
    <br><br>

    Helpful Tip: Create a Remote Desktop Shortcut
    <br>
    http://cybernetnews.com/2007/10/31/helpful-tip-create-a-remote-desktop-shortcut/
    <br><br>

    1. will take you to the logon screen and you will have to enter all information.
    <br><br>
    2. will run the .RDP with the admin switch and you have to enter the password.
    <br>
    I am sure that you used to be able to save the password prior to RDC 6.
    <br><br>
    < just to add that you still can save by clicking Allow me to save credentials. >
    <br><br>
    <i>Keep us informed as to your progress if you require further assistance.</i>
    <br><br>
    <i>If you think that any of the posts that have been made by all TR Members, have solved or contributed to solving the problem, please Mark them as <b>Helpful</b> so that others may benefit from the outcome.
    </i>

    +
    0 Votes
    g0dFather

    I went with the number 2 suggestion (minus the width/height since it's already in the .rdp file) and it worked perfectly. It makes sense too, kind of annoyed at myself now.

    I also appreciate the link. I'm interested in trying that Royal TS that some people promoted in the Comments section.

    Thank you Jacky!

    +
    0 Votes
    Jacky Howe

    now I have to fix my shortcuts as the width/height is effecting them. Global effect.

    +
    0 Votes
    jfairbairn

    thats one less technical pain in the neck today. - J(??j)E