Questions

Remote Desktop won't disconnect

+
0 Votes
Locked

Remote Desktop won't disconnect

gperrow
Running XP Pro, SP 3. When I use remote desktop to connect to a remote machine, it connects properly, but when I try to disconnect, I get an error and have to kill the mstsc process. Whether I log off the remote machine or simply click the 'X' to close the app, I get a dialog saying:

"The connection has been lost. Attempting to reconnect to your session...

The network is not available. The connection will be reinstated when the network is available"

The reconnection never succeeds. Hitting Cancel does nothing.

The network is fine. Other remote desktop sessions are still alive, and I can make new ones. This happens *every* time I use remote desktop, whether it's to a real machine or a VM, and whether I'm in the office (gigabit wired connection) or VPN'ed in from home (wireless). I am having no other network-related problems.

I *think* this started when I installed SP 3 several months ago, but I can't be sure. Has anyone seen this or know how I can fix it?
  • +
    0 Votes
    ddemuth78

    5 or 6?

    To check the version number of Remote Desktop Connection:

    1. Open Remote Desktop Connection
    (The Remote Desktop Connection dialog box appears.)

    2. Click the computer icon in the upper-left corner of the title bar, and then click About.

    +
    0 Votes
    gperrow

    Shell Version 6.0.6001
    Control Version 6.0.6001

    (copyright stuff)

    Network Level Authentication not supported
    Remote Desktop Protocol 6.1 supported

    +
    0 Votes
    ThumbsUp2

    Is WinXP SP3 loaded on the machines you're connecting to, or some other OS/SP level?

    Are these machines within the same LAN, or remote locations?

    +
    0 Votes
    gperrow

    All kinds of Windows machines - XP with SP2 or SP3, Vista, Windows 2003/2008 server, 32-bit and 64-bit, virtual machines and real machines. All of the machines are on my LAN, though it also happens when I'm at home and connected through a VPN.

    +
    0 Votes
    jszivos

    It sounds like a virtual channel is keeping the network connection open. This can be caused by incompatible printer drivers or 3rd-party virtual channels. You should probably try to disable Local Resources (Sound, Disk Drives, Printers, and Serial Ports) in the Remote Desktop Connection.

    3rd-party device drivers are injected by registry keys in HKCU\Software\Microsoft\Terminal Server Client\Default\Addins - the only key in Addins should be RDPDR. You should export any additional keys and delete them. Then you can always restore the keys by running the exported registry script, if necessary.

    +
    0 Votes
    gperrow

    That didn't change anything, but somehow I missed the "Reconnect if connection is dropped" checkbox. Unchecking that solved the problem.

    Thanks all

    +
    0 Votes
    blarman

    I'm getting the same error. I've checked the startup and registry. It seems to correspond to application of updates including SP3. I am mainly connecting to servers (2003,2008), but I have to end task to shut down the connection, where before all I had to do was close the window normally using the x. I even changed the settings to turn off everything local.

    This also seems to appear when I try to hit several web sites - they error out. It is browser agnostic, it happens in both Firefox and IE and seems to be related to websites that redirect from a secure/logged in side.

    +
    0 Votes
    hack

    In the new RDC there is a setting - click on options, experience tab, reconnect if connection is dropped. Make sure that it is unchecked.

  • +
    0 Votes
    ddemuth78

    5 or 6?

    To check the version number of Remote Desktop Connection:

    1. Open Remote Desktop Connection
    (The Remote Desktop Connection dialog box appears.)

    2. Click the computer icon in the upper-left corner of the title bar, and then click About.

    +
    0 Votes
    gperrow

    Shell Version 6.0.6001
    Control Version 6.0.6001

    (copyright stuff)

    Network Level Authentication not supported
    Remote Desktop Protocol 6.1 supported

    +
    0 Votes
    ThumbsUp2

    Is WinXP SP3 loaded on the machines you're connecting to, or some other OS/SP level?

    Are these machines within the same LAN, or remote locations?

    +
    0 Votes
    gperrow

    All kinds of Windows machines - XP with SP2 or SP3, Vista, Windows 2003/2008 server, 32-bit and 64-bit, virtual machines and real machines. All of the machines are on my LAN, though it also happens when I'm at home and connected through a VPN.

    +
    0 Votes
    jszivos

    It sounds like a virtual channel is keeping the network connection open. This can be caused by incompatible printer drivers or 3rd-party virtual channels. You should probably try to disable Local Resources (Sound, Disk Drives, Printers, and Serial Ports) in the Remote Desktop Connection.

    3rd-party device drivers are injected by registry keys in HKCU\Software\Microsoft\Terminal Server Client\Default\Addins - the only key in Addins should be RDPDR. You should export any additional keys and delete them. Then you can always restore the keys by running the exported registry script, if necessary.

    +
    0 Votes
    gperrow

    That didn't change anything, but somehow I missed the "Reconnect if connection is dropped" checkbox. Unchecking that solved the problem.

    Thanks all

    +
    0 Votes
    blarman

    I'm getting the same error. I've checked the startup and registry. It seems to correspond to application of updates including SP3. I am mainly connecting to servers (2003,2008), but I have to end task to shut down the connection, where before all I had to do was close the window normally using the x. I even changed the settings to turn off everything local.

    This also seems to appear when I try to hit several web sites - they error out. It is browser agnostic, it happens in both Firefox and IE and seems to be related to websites that redirect from a secure/logged in side.

    +
    0 Votes
    hack

    In the new RDC there is a setting - click on options, experience tab, reconnect if connection is dropped. Make sure that it is unchecked.