Questions

Server 2003 Remote desktop idle timeout limits

+
0 Votes
Locked

Server 2003 Remote desktop idle timeout limits

jvennix
I am having a problem with remote desktop sessions timeingout after a short time. Is there anyway to increase the time before users RDPing into the server need to log back in?
  • +
    0 Votes
    james6570

    Click Start>Run, Type gpedit.msc and hit enter


    Under local computer policy>Computer configuration>Administritive Templates>Windows componants>Terminal services>Terminal server>Session time limits

    You can configure your time limits there.

    +
    0 Votes
    christianshiflet

    As previously stated, you can use group policy, which will inpact all computers that are joined to your domain. You can also use the Terminal Services Configuration console under Administrative Tools on the server you are connecting to. From there select Connections and right-click and select Properties on the connection you wish to configure. There are a number of tabs available to control how every computer will connect to the server. Exceptions can then be made, if necessary, from Active Directory for individual users.

    +
    0 Votes
    jvennix

    I have tried both of these suggestions however I have not had any success. Under the RDP-Tcp properties I have override user settings checked to never end a disconnected session. As well as having the active session limit set to never same for idle session limit. Still about a 10 window before RDP users are required to log back on.

    +
    0 Votes
    Wizard-09

    If so then the idle timeout is set somewhere else.

    Session timeouts can be set:

    On the Connection object

    Start-->Run-->tscc.msc-->right-click RDP-Tcp-->Properties-->Sessions tab

    On the User object

    Active Directory Users & Comp-->right-click the user-->Properties-->Sessions tab

    On the Group Policy object

    Edit the GPO-->User-->Admin-->Win Comp-->Term Serv-->Sessions

    And

    Edit the GPO-->Comp-->Admin-->Win Comp-->Term Serv-->Sessions

    Keep us informed as to your progress if you require further assistance.

    If you think that any of the posts that have been made by all TR Members, have solved or contributed to solving the problem, please Mark them as Helpful so that others may benefit from the outcome.

    +
    0 Votes
    christianshiflet

    Another possibility, though unlikely to impact all computers identically, is that the computer's network cards are turning off after a certain time. Does the disconnection usually occur when the PC goes into screen saver or standby?

    Also, when the user logs back in, do they return to the previous disconnected session or are they creating a new session? This will atleast let you know if the session is being disconnected or terminated/reset. Let us know.

    +
    0 Votes
    jvennix

    It ended up being a screen saver setting that required a password on resume. Thanks for all the help everyone.

    +
    0 Votes
    jorgon2

    If you are still having trouble, try also extending the time for the screensaver to kick in on the server (Control Panel, Display) and uncheck the "password required to continue" box.

  • +
    0 Votes
    james6570

    Click Start>Run, Type gpedit.msc and hit enter


    Under local computer policy>Computer configuration>Administritive Templates>Windows componants>Terminal services>Terminal server>Session time limits

    You can configure your time limits there.

    +
    0 Votes
    christianshiflet

    As previously stated, you can use group policy, which will inpact all computers that are joined to your domain. You can also use the Terminal Services Configuration console under Administrative Tools on the server you are connecting to. From there select Connections and right-click and select Properties on the connection you wish to configure. There are a number of tabs available to control how every computer will connect to the server. Exceptions can then be made, if necessary, from Active Directory for individual users.

    +
    0 Votes
    jvennix

    I have tried both of these suggestions however I have not had any success. Under the RDP-Tcp properties I have override user settings checked to never end a disconnected session. As well as having the active session limit set to never same for idle session limit. Still about a 10 window before RDP users are required to log back on.

    +
    0 Votes
    Wizard-09

    If so then the idle timeout is set somewhere else.

    Session timeouts can be set:

    On the Connection object

    Start-->Run-->tscc.msc-->right-click RDP-Tcp-->Properties-->Sessions tab

    On the User object

    Active Directory Users & Comp-->right-click the user-->Properties-->Sessions tab

    On the Group Policy object

    Edit the GPO-->User-->Admin-->Win Comp-->Term Serv-->Sessions

    And

    Edit the GPO-->Comp-->Admin-->Win Comp-->Term Serv-->Sessions

    Keep us informed as to your progress if you require further assistance.

    If you think that any of the posts that have been made by all TR Members, have solved or contributed to solving the problem, please Mark them as Helpful so that others may benefit from the outcome.

    +
    0 Votes
    christianshiflet

    Another possibility, though unlikely to impact all computers identically, is that the computer's network cards are turning off after a certain time. Does the disconnection usually occur when the PC goes into screen saver or standby?

    Also, when the user logs back in, do they return to the previous disconnected session or are they creating a new session? This will atleast let you know if the session is being disconnected or terminated/reset. Let us know.

    +
    0 Votes
    jvennix

    It ended up being a screen saver setting that required a password on resume. Thanks for all the help everyone.

    +
    0 Votes
    jorgon2

    If you are still having trouble, try also extending the time for the screensaver to kick in on the server (Control Panel, Display) and uncheck the "password required to continue" box.