Questions

Setting Static IP Doesn't Work on Server

+
0 Votes
Locked

Setting Static IP Doesn't Work on Server

terencewklau
Hi,

I've build a Dell PowerEdge 2950 NAS box with Windows 2000 Server SP4. I've set a static IP for both integrated NIC's. But both connections don't work. I can't ping anything except for its own address and loopback.

But if I let Windows assign an IP address automatically, then both connections work.

I've checked that the static IP's I've set are not being used. The dns ip addresses are the same for all the other servers.

I've tried updating to the latest Broadcom NIC drivers but static IP still doesn't work.

Dell has switched to a new motherboard and the same issue appears. Anyone have any ideas on why this is occurring. Any help would be much appreciated.
  • +
    0 Votes
    shardeth-15902278

    Have you tried statically setting the precise IP, netmask and default gateway as was provided by DHCP?

    +
    0 Votes
    Neon Samurai

    If both cards work when Windows assigns dynamic IP then let it do so and write down all IP information.

    Start -> Run "cmd"
    at cmd prompt type "ipconfig /all"

    make note of IP, gateway, dns, network mask (255.255.255.0 or similar). Once you what Windows thinks it should be, reset your static IP information using the dynamic info as a reference.

    I'm guessing that when you set the static IP for each network card, you missed the gateway. Primary network card should be primary and secondary using primary IP as gateway.

    +
    0 Votes
    AndyKaz

    Let Windows assign the IP settings automatically. Look at what those settings are. You should at least be able to go back to "Use the following IP address", and use the same settings that Windows had automatically assigned. That might point you in the right direction, and let you see what was different between the static settings you were trying to use, and the DHCP generated settings. If you can use DHCP, I would probably rule out any kind of driver issue. It's more than likely a gateway/DNS setting.

    +
    0 Votes
    georgeou

    Once you start messing with dual NICs, you can cause all kinds of havok. Any device with more than one NIC becomes a router. If they're both plugged in to the same switch, you have to use some kind of binding mechanism like EtherChannel to turn the two interfaces in to a single logical interface on the host side and that also has to be done on switch side as well.

    See EtherChannel:
    http://www.cisco.com/en/US/tech/tk389/tk213/technologies_tech_note09186a0080094714.shtml

    http://en.wikipedia.org/wiki/EtherChannel

    If you're not going to configure EtherChannel on the server and on the switch to make two Ethernet connections look like one, don't bother hooking up dual connections to a switch because the STP (Spanning Tree Protocol) will automatically disable one of the ports on the switch side.

    The updated standard from EtherChannel is 802.3ad Link aggregation.

    +
    0 Votes
    terencewklau

    Thanks for all the replies. Apparently, the ports in my office (the entire ground floor in fact) are on a vlan on the 192.168.99.0 subnet. I was trying to set a static ip on the 192.168.100.0 subnet which is what the servers are all on in the basement.

    But I was building the server in my office on the ground floor and just plugged in the network cable into the port in my office.

    I'll find out on Monday if that's the issue.

    +
    0 Votes
    andrew.flaherty

    Morning, I was looking at your posting, I have exactly the same prob, did you ever get it sorted ?
    Cheers
    Andy

    +
    0 Votes
    terencewklau

    Hi Andrew,

    The ports on my office floor are set on a 192.168.99.0 vlan on the cisco switch. Hence I couldn't use a static ip on the 192.168.100.0 subnet.

    If you are familiar with Cisco switches, you can set some of the ports to the subnet that you require.

    Since I'm not familiar with Cisco switches, I brough the server down to the basement where the ports are set to the 192.168.100.0 subnet on that switch.

    Time for me to learn how to configure cisco switches.

    +
    0 Votes
    andrew.flaherty

    Hmm, I have disabled the second nic and all appears fine - wierd, no worries I didnt need it at the mo

  • +
    0 Votes
    shardeth-15902278

    Have you tried statically setting the precise IP, netmask and default gateway as was provided by DHCP?

    +
    0 Votes
    Neon Samurai

    If both cards work when Windows assigns dynamic IP then let it do so and write down all IP information.

    Start -> Run "cmd"
    at cmd prompt type "ipconfig /all"

    make note of IP, gateway, dns, network mask (255.255.255.0 or similar). Once you what Windows thinks it should be, reset your static IP information using the dynamic info as a reference.

    I'm guessing that when you set the static IP for each network card, you missed the gateway. Primary network card should be primary and secondary using primary IP as gateway.

    +
    0 Votes
    AndyKaz

    Let Windows assign the IP settings automatically. Look at what those settings are. You should at least be able to go back to "Use the following IP address", and use the same settings that Windows had automatically assigned. That might point you in the right direction, and let you see what was different between the static settings you were trying to use, and the DHCP generated settings. If you can use DHCP, I would probably rule out any kind of driver issue. It's more than likely a gateway/DNS setting.

    +
    0 Votes
    georgeou

    Once you start messing with dual NICs, you can cause all kinds of havok. Any device with more than one NIC becomes a router. If they're both plugged in to the same switch, you have to use some kind of binding mechanism like EtherChannel to turn the two interfaces in to a single logical interface on the host side and that also has to be done on switch side as well.

    See EtherChannel:
    http://www.cisco.com/en/US/tech/tk389/tk213/technologies_tech_note09186a0080094714.shtml

    http://en.wikipedia.org/wiki/EtherChannel

    If you're not going to configure EtherChannel on the server and on the switch to make two Ethernet connections look like one, don't bother hooking up dual connections to a switch because the STP (Spanning Tree Protocol) will automatically disable one of the ports on the switch side.

    The updated standard from EtherChannel is 802.3ad Link aggregation.

    +
    0 Votes
    terencewklau

    Thanks for all the replies. Apparently, the ports in my office (the entire ground floor in fact) are on a vlan on the 192.168.99.0 subnet. I was trying to set a static ip on the 192.168.100.0 subnet which is what the servers are all on in the basement.

    But I was building the server in my office on the ground floor and just plugged in the network cable into the port in my office.

    I'll find out on Monday if that's the issue.

    +
    0 Votes
    andrew.flaherty

    Morning, I was looking at your posting, I have exactly the same prob, did you ever get it sorted ?
    Cheers
    Andy

    +
    0 Votes
    terencewklau

    Hi Andrew,

    The ports on my office floor are set on a 192.168.99.0 vlan on the cisco switch. Hence I couldn't use a static ip on the 192.168.100.0 subnet.

    If you are familiar with Cisco switches, you can set some of the ports to the subnet that you require.

    Since I'm not familiar with Cisco switches, I brough the server down to the basement where the ports are set to the 192.168.100.0 subnet on that switch.

    Time for me to learn how to configure cisco switches.

    +
    0 Votes
    andrew.flaherty

    Hmm, I have disabled the second nic and all appears fine - wierd, no worries I didnt need it at the mo