Questions

Shutdown Problems on Windows XP Pro SP3

+
0 Votes
Locked

Shutdown Problems on Windows XP Pro SP3

singletaryr
I have updated to the new SP3 on my PC and everything was OK for a day or so, then I noticed that it started taking a while longer to boot down and turn off than normal. I have checked everything I know to. I have run all my Anti-Spyware and Anti-Malaware and Anti-virus software and even ran Advanced Windows Care and I can't seem to find anything changed or wrong! It takes about 2 minutes to shut down on its own and it never took over 20 seconds before. Any Ideas?
  • +
    0 Votes
    OldER Mycroft

    By that I mean, there are probably updates that could not be installed until you had applied SP3 to your system.

    I must say though that 20 seconds seems remarkably fast for a shutdown.

    I have yet to submerge myself in the 'delights' of SP3 so my ideas are just that - ideas. :)

    +
    0 Votes
    nepenthe0

    My initial experience with SP3 was similar to yours - no change in an otherwise very rapid shutdown. I am going to make Old Mycroft walk on his tongue when I say that my shutdown time is <10 seconds.

    Windows services are the usual reason for prolonged shutdown times. The fewer services running, the faster the computer shuts down. Scott Lowe has posted an excellent guide (June'05) for disabling unnecessary Windows services:

    http://tinyurl.com/yohler

    It also takes the computer time to clear the paging file at shutdown. You can defer this if you wish by a simple registry edit:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\
    Control\Session Manager\Memory Management

    Change the value of ClearPageFileAtShutdown to 0.

    Credit for this registry edit goes to Preston Gralla, Windows XP Hacks (O'Reilly, 2005), Hack #3 (p. 13)

    However, from your description, some application is hanging and delaying shutdown. The measures I have described will prove useful, but I don't think these address the primary problem with your computer.

    Some application is misbehaving. Have you installed any new applications since you installed SP3?

    Check the Task Manager and review all the applications/processes that load and run. Identify the processes at:

    http://www.processlibrary.com/

    Disable all unnecessary startup processes, either through msconfig.exe, or through a 3rd party application such as Spybot Search & Destroy:

    http://www.safer-networking.org/en/index.html

    Spybot has a Tools menu that allows you to reversibly disable startup processes.

    With the Task Manager, look for applications that are hogging an inordinate amount of memory. There is probably one outlier that is the culprit. If it is an essential Windows process, you're stuck with it. Otherwise, uninstall it and reinstall it. If it continues to misbehave, permanently uninstall it. The most likely culprit is your antivirus application.

    Hope this helps.

    Rick/Portland, OR

    P.S. - Old Mycroft, eat your heart out, shutdown in <10 seconds...

    +
    0 Votes
    OldER Mycroft

    It makes for a really crap computer!...

    It's a 12V halogen desklight. :^0

  • +
    0 Votes
    OldER Mycroft

    By that I mean, there are probably updates that could not be installed until you had applied SP3 to your system.

    I must say though that 20 seconds seems remarkably fast for a shutdown.

    I have yet to submerge myself in the 'delights' of SP3 so my ideas are just that - ideas. :)

    +
    0 Votes
    nepenthe0

    My initial experience with SP3 was similar to yours - no change in an otherwise very rapid shutdown. I am going to make Old Mycroft walk on his tongue when I say that my shutdown time is <10 seconds.

    Windows services are the usual reason for prolonged shutdown times. The fewer services running, the faster the computer shuts down. Scott Lowe has posted an excellent guide (June'05) for disabling unnecessary Windows services:

    http://tinyurl.com/yohler

    It also takes the computer time to clear the paging file at shutdown. You can defer this if you wish by a simple registry edit:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\
    Control\Session Manager\Memory Management

    Change the value of ClearPageFileAtShutdown to 0.

    Credit for this registry edit goes to Preston Gralla, Windows XP Hacks (O'Reilly, 2005), Hack #3 (p. 13)

    However, from your description, some application is hanging and delaying shutdown. The measures I have described will prove useful, but I don't think these address the primary problem with your computer.

    Some application is misbehaving. Have you installed any new applications since you installed SP3?

    Check the Task Manager and review all the applications/processes that load and run. Identify the processes at:

    http://www.processlibrary.com/

    Disable all unnecessary startup processes, either through msconfig.exe, or through a 3rd party application such as Spybot Search & Destroy:

    http://www.safer-networking.org/en/index.html

    Spybot has a Tools menu that allows you to reversibly disable startup processes.

    With the Task Manager, look for applications that are hogging an inordinate amount of memory. There is probably one outlier that is the culprit. If it is an essential Windows process, you're stuck with it. Otherwise, uninstall it and reinstall it. If it continues to misbehave, permanently uninstall it. The most likely culprit is your antivirus application.

    Hope this helps.

    Rick/Portland, OR

    P.S. - Old Mycroft, eat your heart out, shutdown in <10 seconds...

    +
    0 Votes
    OldER Mycroft

    It makes for a really crap computer!...

    It's a 12V halogen desklight. :^0