Questions

Speed up NVidia AGP video under Ubuntu 10.04

+
0 Votes
Locked

Speed up NVidia AGP video under Ubuntu 10.04

Rick_R
How do I speed up video under Ubuntu 10.04? I'm not talking gaming, just basic YouTube tutorials. The video is so slow it's useless, even playing FLV's from the hard disk. The problem is not limited to FLV's. WMV's are even worse. The audio runs fine on both.

Card: EVGA GeForce4 MX4000 AGP (64MB)
Mobo: Soyo SY-P4VGA, 2.4GHz 1-core Celeron, 1.5GB DDR
Video: Aperture 256MB (also tried 64), Fast write, AGP Master wait states 0 (?)
Drivers: Nvidia 96.43.17 (also tried what Ubuntu originally installed)
Monitor: Sceptre X24WG
Resolution: 1152x864
Colors: 16.7 Million (I just tried reducing that to 65k and haven't restarted.)

Things I am not interested in hearing:

(1) Update the drivers. As far as I know they are the latest. Got them from the Nvidia site. The version I have does not have a performance adjustment.

(2) Replace the video card. Performance is fine in Windows XP. This is a personal "backup" machine from spare parts. If the same hardware works fine under Windows, the difference should be a configuration problem, not hardware. Watching someone talk on camera surely doesn't require high-performance video.

(3) Turn off fancy video effects. Tried it both ways. I have compiz installed but performance was about the same without it. I normally don't use fancy effects.

(4) Switch Linux distros. I'm only learning the basics to install the desktop version as a server (mainly text documents) at a small office (12 employees). The video speed won't matter for our office use and overall Ubuntu will fit well. I'd just like better video performance at home, although I'll continue to use XP as my primary OS.
  • +
    0 Votes
    Rick_R

    Well, after a LOT of searching I have found SOME improvements. I removed Nvidia's drivers and the following still make massive improvements.

    1) Install MPlayer.
    2) Right-click on the MPlayer SCREEN, select Preferences.
    3) Turn on the cache. The default size is 2048. I don't know what that represents (Kb, Mb, etc.) Increase it to something like 65536.
    4) Adjust the audio quality. (The theory is that the CPU may spend less time on audio.)
    Save the changes, restart MPlayer.

    I found an old post about "black screen" problems with MPlayer. It says (around Ubuntu 6.04) that sometimes there are problems with Xv, so in MPlayer Preferences, Video tab, make sure X11 does not include XV in the driver.

    I also found a post saying there was a bug in an AUDIO driver that can slow down the VIDEO.

    1) System => Preferences => Multimedia Systems Selector
    2) Change the Audio output from Autodetect to OSS.

    Chances are just increasing the cache will probably fix most problems, but if not, try some of the others also.

    +
    0 Votes
    Rick_R

    The cache size in MPlayer is in kilobytes, so you probably want to use a setting like 8192 (8MB) rather than 65536.

    +
    0 Votes
    Rick_R

    I reinstalled Nvidia's Linux driver to use Compiz and the videos stopped working. I removed it again and they're working again. Movie Player also works now. The driver is from February 2010. I turned off the fancy effects in Windows 7 because I found them annoying, so it's not that I need them in Linux. YouTube videos still run slow and choppy, but my DSL is fairly slow and I can download and save the ones I need. I'm still trying to find out how to increase cache size in other players since that seems to be what works best.

  • +
    0 Votes
    Rick_R

    Well, after a LOT of searching I have found SOME improvements. I removed Nvidia's drivers and the following still make massive improvements.

    1) Install MPlayer.
    2) Right-click on the MPlayer SCREEN, select Preferences.
    3) Turn on the cache. The default size is 2048. I don't know what that represents (Kb, Mb, etc.) Increase it to something like 65536.
    4) Adjust the audio quality. (The theory is that the CPU may spend less time on audio.)
    Save the changes, restart MPlayer.

    I found an old post about "black screen" problems with MPlayer. It says (around Ubuntu 6.04) that sometimes there are problems with Xv, so in MPlayer Preferences, Video tab, make sure X11 does not include XV in the driver.

    I also found a post saying there was a bug in an AUDIO driver that can slow down the VIDEO.

    1) System => Preferences => Multimedia Systems Selector
    2) Change the Audio output from Autodetect to OSS.

    Chances are just increasing the cache will probably fix most problems, but if not, try some of the others also.

    +
    0 Votes
    Rick_R

    The cache size in MPlayer is in kilobytes, so you probably want to use a setting like 8192 (8MB) rather than 65536.

    +
    0 Votes
    Rick_R

    I reinstalled Nvidia's Linux driver to use Compiz and the videos stopped working. I removed it again and they're working again. Movie Player also works now. The driver is from February 2010. I turned off the fancy effects in Windows 7 because I found them annoying, so it's not that I need them in Linux. YouTube videos still run slow and choppy, but my DSL is fairly slow and I can download and save the ones I need. I'm still trying to find out how to increase cache size in other players since that seems to be what works best.