Questions

the client could not connect to the remote computer.

+
0 Votes
Locked

the client could not connect to the remote computer.

globalsocialite
I am getting the error: "the client could not connect to the remote computer. remote connections might not be enabled or thecomputer might be too busy to accept new connections. it is also possible that network problems are preventing your connection. please try connecting again later. if the problem continues to occur, contact your administrator."

I get this when remoting from home over vpn onto on our 2003 db server in a domain running ad. however, when i remote to another server in the same domain, then from that server remote into the db server with the previous error, i can get in.

does dns forwarding have anything to do with this or should i look somewhere else?
  • +
    0 Votes
    p.j.hutchison

    It depends on how Terminal Services are setup. By default admin TS mode will only allow two sessions at once. To clear a session, the use MUST logout and not just close the TS window.
    Use Terminal Services Manager to logout disconnected sessions.

    +
    0 Votes
    globalsocialite

    Its not the a problem with the default 2 person logons. I cleared them out and tied to log on and no joy.

    +
    0 Votes

    TS

    vp

    Hi I am am having some problems with certain computers not been able to connect to Terminal Server. It is not a license issue as we have enough. Not too sure why my server is blocking certain computers. Any help would be great.

    +
    0 Votes
    juan18_c

    Remeber that forwarding to your ISP is very important you want every IP to be resolved correctly. As of to the setup of your forward-lookup / reverse-lookup zones. it is crucial you have at lest a forward lookup. Can you give us an insight on your network setup.

    +
    0 Votes
    daveo2000

    Check your "hosts" file to make sure that you haven't added the hostname you are trying to reach with a stale IP address.

    Unlikely to be your problem but little things can bite you when you least expect it.

    +
    0 Votes
    globalsocialite

    I havent changed any hosts. but the dns is handeled by another group that actually runs the building (not my company)

    +
    0 Votes
    globalsocialite

    We are having problems connecting to to the server over VPN, but are not having the problem from the office. Last week I had the same problem with a different server and the problem went away the next day.

    Over the VPN I can ping the problem server but cannot telnet to port 3389 on it (rdp port)
    I can telnet to 3389 on any other server over the VPN.

    Everything works fine from a computer inside the network so Im thinking that leaves the VPN as the culprit. Maybe the problem is with the ACL's?

    +
    0 Votes
    Hawk73ku

    I can not do a remote desktop connection through VPN and authenticated through IAS and Active Directory.

    I can use Dameware (remote control) and control the server but terminal services isn't cooperating.

    Previous questions didn't seem to get answers.

    +
    0 Votes
    Hawk73ku

    I could not do a Remote Desktop Connection through VPN and authenticated by IAS and Active Directory. I was receiving the same message "the client could not connect to the remote computer. remote connections might not be enabled or thecomputer might be too busy to accept new connections. it is also possible that network problems are preventing your connection. please try connecting again later. if the problem continues to occur, contact your administrator." I could RDC from the LAN though.

    The hint of port blocking by the routner got me looking at CISCO. I entered the following commands in my CISCO router and all is well.

    access-list 102 permit ip 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255

    interface loopback 0
    ip address 1.1.1.1 255.255.255.255
    no shut

    route-map NONAT permit 10
    match ip address 102
    set interface loopback0

    interface bvi1
    ip policy route-map NONAT

    +
    0 Votes
    jaredt

    Good call. We just replaced our Netopia router with a Cisco 2821 and I started getting the same RDC error on our TSWeb Terminal Server. I allowed https traffic through the FW to the server but forgot to allow port 3389 also.
    Thanks,
    Jared

    +
    0 Votes
    jpierce

    i searched for an answer on this issue for 4 weeks about 2 months ago.. my situation was simular to yours but it was between co-lo's. I had to static the arp route from ip to the nic card i wanted.. i am using Terminal Server Load Balancing and needed a DNS name datacentral pointed to an ip of 156.65.25.100 where the servers (2) has ips of 101,102,103,and 104 100 was broadcast by the load balancing software and pointed to 101 where 101 did the delegation.

    to much info, I know..

    just try the static Arp, it worked for me and i was RELIEVED

    +
    0 Votes
    boca1993

    In my case, after a hotfix, the firewall was reactivated so the vista machine was no longer able to RDP to XP machines. Turning off the firewall took care of it.

    +
    0 Votes
    maheirtt22

    sir ,

    i want to connect lan remote connection...
    pls give me a solution for this ...
    thanks in advance......

  • +
    0 Votes
    p.j.hutchison

    It depends on how Terminal Services are setup. By default admin TS mode will only allow two sessions at once. To clear a session, the use MUST logout and not just close the TS window.
    Use Terminal Services Manager to logout disconnected sessions.

    +
    0 Votes
    globalsocialite

    Its not the a problem with the default 2 person logons. I cleared them out and tied to log on and no joy.

    +
    0 Votes

    TS

    vp

    Hi I am am having some problems with certain computers not been able to connect to Terminal Server. It is not a license issue as we have enough. Not too sure why my server is blocking certain computers. Any help would be great.

    +
    0 Votes
    juan18_c

    Remeber that forwarding to your ISP is very important you want every IP to be resolved correctly. As of to the setup of your forward-lookup / reverse-lookup zones. it is crucial you have at lest a forward lookup. Can you give us an insight on your network setup.

    +
    0 Votes
    daveo2000

    Check your "hosts" file to make sure that you haven't added the hostname you are trying to reach with a stale IP address.

    Unlikely to be your problem but little things can bite you when you least expect it.

    +
    0 Votes
    globalsocialite

    I havent changed any hosts. but the dns is handeled by another group that actually runs the building (not my company)

    +
    0 Votes
    globalsocialite

    We are having problems connecting to to the server over VPN, but are not having the problem from the office. Last week I had the same problem with a different server and the problem went away the next day.

    Over the VPN I can ping the problem server but cannot telnet to port 3389 on it (rdp port)
    I can telnet to 3389 on any other server over the VPN.

    Everything works fine from a computer inside the network so Im thinking that leaves the VPN as the culprit. Maybe the problem is with the ACL's?

    +
    0 Votes
    Hawk73ku

    I can not do a remote desktop connection through VPN and authenticated through IAS and Active Directory.

    I can use Dameware (remote control) and control the server but terminal services isn't cooperating.

    Previous questions didn't seem to get answers.

    +
    0 Votes
    Hawk73ku

    I could not do a Remote Desktop Connection through VPN and authenticated by IAS and Active Directory. I was receiving the same message "the client could not connect to the remote computer. remote connections might not be enabled or thecomputer might be too busy to accept new connections. it is also possible that network problems are preventing your connection. please try connecting again later. if the problem continues to occur, contact your administrator." I could RDC from the LAN though.

    The hint of port blocking by the routner got me looking at CISCO. I entered the following commands in my CISCO router and all is well.

    access-list 102 permit ip 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255

    interface loopback 0
    ip address 1.1.1.1 255.255.255.255
    no shut

    route-map NONAT permit 10
    match ip address 102
    set interface loopback0

    interface bvi1
    ip policy route-map NONAT

    +
    0 Votes
    jaredt

    Good call. We just replaced our Netopia router with a Cisco 2821 and I started getting the same RDC error on our TSWeb Terminal Server. I allowed https traffic through the FW to the server but forgot to allow port 3389 also.
    Thanks,
    Jared

    +
    0 Votes
    jpierce

    i searched for an answer on this issue for 4 weeks about 2 months ago.. my situation was simular to yours but it was between co-lo's. I had to static the arp route from ip to the nic card i wanted.. i am using Terminal Server Load Balancing and needed a DNS name datacentral pointed to an ip of 156.65.25.100 where the servers (2) has ips of 101,102,103,and 104 100 was broadcast by the load balancing software and pointed to 101 where 101 did the delegation.

    to much info, I know..

    just try the static Arp, it worked for me and i was RELIEVED

    +
    0 Votes
    boca1993

    In my case, after a hotfix, the firewall was reactivated so the vista machine was no longer able to RDP to XP machines. Turning off the firewall took care of it.

    +
    0 Votes
    maheirtt22

    sir ,

    i want to connect lan remote connection...
    pls give me a solution for this ...
    thanks in advance......