Questions

This wireless card problem may be the the last straw that pushes me to Mac

+
0 Votes
Locked

This wireless card problem may be the the last straw that pushes me to Mac

neeboy74
I just bought an Acer Aspire 5739G with Windows 7 Home Premium; the price/features made it too good to pass up. However, I have found that the wireless card (Intel 5100) will not use any wireless signal beyond about 8 feet. I have searched far and wide on the net for an answer. I've tried uninstalling/reinstalling the device, updating the drivers, etc, but still the exact same result. This is complete and utter nonsense! This Acer laptop was meant to replace a 3.5 yr old Toshiba Core Duo machine (XP Media Center); I can connect easily to the network at my father's house, my mother's apartment, and at the local public libraries with that older Toshiba, so don't anyone tell me that "my router settings need to be changed." How am I supposed to do that at the library??

On the Acer machine, In the network list, it shows the name of the network, "Excellent" signal strength, the security type (WPA2-PSK), and radio type (802.11n). There are 5 green bars showing the network strength, but again, this laptop refuses to connect at a distance greater than 8 feet or so. AAAGH!
  • +
    0 Votes
    .Martin.

    try altering the settings of the router

    the one you need to look at is the wireless channel. Sometimes changing which channel the router transmits on can fix little problems like these.

    +
    0 Votes
    OldER Mycroft

    That you may be the ONLY component in life's equation that has 802.11n at present.

    Your older Toshiba certainly didn't have 802.11n and, as you said, it performed a lot faster.

    That is more than likely because it was 'talking the same language' as whatever it was connecting to. But your new Acer isn't - it's talking in 802.11n and NOT getting the response it is expecting.

    So, rather than changing the settings on your router (which, by the way you can't anyway - it's too old) you ought to be changing the settings on the Acer!

    You ought to be setting the wireless to transcieve in 802.11b/g mixed mode, which would be what the old Toshiba was transmitting and receiving on. :)

    +
    0 Votes
    OldER Mycroft

    That didn't illuminate a little lightbulb in your skull? It would've in mine - why was the price so good?

    Generally speaking, if it's too good to be true - it is (too good to be true).

    Usually this dichotomy can be easily ratified, one way or the other by doing something like this:

    http://tinyurl.com/ycoqwat

    Also, as I mentioned previously in my other post, don't forget that for 802.11n to work at maximum efficiency it needs to use TWO router channels simultaneously which, if you've not got a router capable of at least 'n draft' speeds will mean the Acer wireless is translating by stepping-down its speed of reception to try and make sense of what it's got coming in, while transmitting on the same channel rather than the other one (that it doesn't have access to due to the age of the router).

    Acer weren't far off the mark if they advise changing the router. You can't buy into bleeding edge technology and just expect that all the old dross you've got already, will be able to keep up.

    +
    0 Votes
    TheChas

    First, I don't believe this is a PC versus Mac issue. This laptop has a lot of features. I could easily see that orientation might affect wireless range. Try rotating the laptop and see if signal strength changes.

    Second, it is possible that the wireless antenna is not connected or has another physical problem.

    As Older Mycroft pointed out, this has N-draft wireless. Your older laptop has just B/G wireless. From the specification sheet.

    "Intel? Wireless WiFi Link network connection supporting 802.11a/b/g/Draft-N wireless LAN, Acer? SignalUp technology for enhanced antenna efficiency, WI-FI CERTIFIED?"

    I also see that Acer posted a BIOS update on 12/14. Contact Acer tech support and see if they recommend the BIOS update.

    While you are at it, it may be a good idea to update the driver for the Intel 5100 wireless. There might be an error in how the laptop is handling the change over to G signals.

    The quick-start guide was lacking in information. Check the Acer Guide on the laptop to see if there are settings that you need to configure so that G works better or is your default wireless connection.

    Chas

    +
    0 Votes
    neeboy74

    I have read this also, but I cannot find it exactly. I also sent a message to Acer tech support, and their solution was for me to download drivers for an Ethernet device that isn't even in my system. Can you send me the link for the BIOS update you found so we're on the same page? Thanks very much for the reply!

    +
    0 Votes
    TheChas

    Here is the base link.

    http://gd.panam.acer.com/home/

    From there, I selected Notebook, Aspire, 5739G and then got the list.

    On the BIOS tab, version 3310 is listed as posted on 2009/12/14.

    On the drivers tab, there are 4 different possible Wireless adapter drivers listed.

    Chas

    +
    0 Votes
    neeboy74

    Thanks again for your help, but the BIOS update did not help, so I gave up and sent the !@#$% thing back to NewEgg for repair

    +
    0 Votes
    TheChas

    If you get a clear report of what was repaired, we would be interested in knowing what the actual problem was.

    I suspect however that once they verify the problem what will happen is that they will send you a different unit. This one will get sent to a refurb center.

    Good luck,

    Chas

    +
    0 Votes

    I have a client with that same model and problem. I replaced the Wi-Fi client with Intel ProWireless and the problem pretty much went away.

    +
    0 Votes
    neeboy74

    Thanks for your reply, I have read about this solution elsewhere; do you have the specific model number of the Intel ProWireless Device you are referring to?

    Also, since I now have your attention, would it be easier for me to get an external USB wireless device? If so, would that give me better signal range than the internal antennas? Thanks in advance for your continued help!

    +
    0 Votes
    bincarnato

    I think he is reffering to going to the Intel site and downloading the Intel Wireless Client plus the driver. Should come as a package. Then uninstall the Acer Wireless manager software and use the Intel. That wireless card you have is one of the newer ones Intel is putting out and should work great. If you have checked the connections and they are all good, seriously consider backing up your data and arranging with Acer to get repaired/replaced. If connections are fine and latest drivers don't work, then you have a hardware issue and as it is brand new, they will repair/replace under warranty.

    +
    0 Votes
    OH Smeg

    If the internal 802 Device is correctly setup it will have a Superior Range to a Plug In USB External 802 WiFi device.

    The reason for this is that the USB ones have the aerial printer as a track onto a Printed Circuit Board and these are small directional and most of the time not the best option. I have seen many cases where these need to be fitted to a USB Extension lead so that they can be moved and twisted around to get the best reception possible.

    The Internal WiFi Device Aerial should run along side the Monitor and give a better range of planes to send/receive in.

    Col

    +
    0 Votes
    Mat Pancha

    This isn't a Windows vs Mac issue, this is hardware related.

    With some older wifi chipsets, cards and routers, the settings aren't optimized to work across the board on all wireless adapters. In your case I don't think its the router, I think its the wireless chip in your laptop. Have you already spoken to Acer support? Do you have this problem everywhere, or just in the library? If its everywhere, maybe its the laptop you have and you should exchange it.

  • +
    0 Votes
    .Martin.

    try altering the settings of the router

    the one you need to look at is the wireless channel. Sometimes changing which channel the router transmits on can fix little problems like these.

    +
    0 Votes
    OldER Mycroft

    That you may be the ONLY component in life's equation that has 802.11n at present.

    Your older Toshiba certainly didn't have 802.11n and, as you said, it performed a lot faster.

    That is more than likely because it was 'talking the same language' as whatever it was connecting to. But your new Acer isn't - it's talking in 802.11n and NOT getting the response it is expecting.

    So, rather than changing the settings on your router (which, by the way you can't anyway - it's too old) you ought to be changing the settings on the Acer!

    You ought to be setting the wireless to transcieve in 802.11b/g mixed mode, which would be what the old Toshiba was transmitting and receiving on. :)

    +
    0 Votes
    OldER Mycroft

    That didn't illuminate a little lightbulb in your skull? It would've in mine - why was the price so good?

    Generally speaking, if it's too good to be true - it is (too good to be true).

    Usually this dichotomy can be easily ratified, one way or the other by doing something like this:

    http://tinyurl.com/ycoqwat

    Also, as I mentioned previously in my other post, don't forget that for 802.11n to work at maximum efficiency it needs to use TWO router channels simultaneously which, if you've not got a router capable of at least 'n draft' speeds will mean the Acer wireless is translating by stepping-down its speed of reception to try and make sense of what it's got coming in, while transmitting on the same channel rather than the other one (that it doesn't have access to due to the age of the router).

    Acer weren't far off the mark if they advise changing the router. You can't buy into bleeding edge technology and just expect that all the old dross you've got already, will be able to keep up.

    +
    0 Votes
    TheChas

    First, I don't believe this is a PC versus Mac issue. This laptop has a lot of features. I could easily see that orientation might affect wireless range. Try rotating the laptop and see if signal strength changes.

    Second, it is possible that the wireless antenna is not connected or has another physical problem.

    As Older Mycroft pointed out, this has N-draft wireless. Your older laptop has just B/G wireless. From the specification sheet.

    "Intel? Wireless WiFi Link network connection supporting 802.11a/b/g/Draft-N wireless LAN, Acer? SignalUp technology for enhanced antenna efficiency, WI-FI CERTIFIED?"

    I also see that Acer posted a BIOS update on 12/14. Contact Acer tech support and see if they recommend the BIOS update.

    While you are at it, it may be a good idea to update the driver for the Intel 5100 wireless. There might be an error in how the laptop is handling the change over to G signals.

    The quick-start guide was lacking in information. Check the Acer Guide on the laptop to see if there are settings that you need to configure so that G works better or is your default wireless connection.

    Chas

    +
    0 Votes
    neeboy74

    I have read this also, but I cannot find it exactly. I also sent a message to Acer tech support, and their solution was for me to download drivers for an Ethernet device that isn't even in my system. Can you send me the link for the BIOS update you found so we're on the same page? Thanks very much for the reply!

    +
    0 Votes
    TheChas

    Here is the base link.

    http://gd.panam.acer.com/home/

    From there, I selected Notebook, Aspire, 5739G and then got the list.

    On the BIOS tab, version 3310 is listed as posted on 2009/12/14.

    On the drivers tab, there are 4 different possible Wireless adapter drivers listed.

    Chas

    +
    0 Votes
    neeboy74

    Thanks again for your help, but the BIOS update did not help, so I gave up and sent the !@#$% thing back to NewEgg for repair

    +
    0 Votes
    TheChas

    If you get a clear report of what was repaired, we would be interested in knowing what the actual problem was.

    I suspect however that once they verify the problem what will happen is that they will send you a different unit. This one will get sent to a refurb center.

    Good luck,

    Chas

    +
    0 Votes

    I have a client with that same model and problem. I replaced the Wi-Fi client with Intel ProWireless and the problem pretty much went away.

    +
    0 Votes
    neeboy74

    Thanks for your reply, I have read about this solution elsewhere; do you have the specific model number of the Intel ProWireless Device you are referring to?

    Also, since I now have your attention, would it be easier for me to get an external USB wireless device? If so, would that give me better signal range than the internal antennas? Thanks in advance for your continued help!

    +
    0 Votes
    bincarnato

    I think he is reffering to going to the Intel site and downloading the Intel Wireless Client plus the driver. Should come as a package. Then uninstall the Acer Wireless manager software and use the Intel. That wireless card you have is one of the newer ones Intel is putting out and should work great. If you have checked the connections and they are all good, seriously consider backing up your data and arranging with Acer to get repaired/replaced. If connections are fine and latest drivers don't work, then you have a hardware issue and as it is brand new, they will repair/replace under warranty.

    +
    0 Votes
    OH Smeg

    If the internal 802 Device is correctly setup it will have a Superior Range to a Plug In USB External 802 WiFi device.

    The reason for this is that the USB ones have the aerial printer as a track onto a Printed Circuit Board and these are small directional and most of the time not the best option. I have seen many cases where these need to be fitted to a USB Extension lead so that they can be moved and twisted around to get the best reception possible.

    The Internal WiFi Device Aerial should run along side the Monitor and give a better range of planes to send/receive in.

    Col

    +
    0 Votes
    Mat Pancha

    This isn't a Windows vs Mac issue, this is hardware related.

    With some older wifi chipsets, cards and routers, the settings aren't optimized to work across the board on all wireless adapters. In your case I don't think its the router, I think its the wireless chip in your laptop. Have you already spoken to Acer support? Do you have this problem everywhere, or just in the library? If its everywhere, maybe its the laptop you have and you should exchange it.