Questions

Trying To connect to Windows 2003 sbs server with Remote desktop

+
0 Votes
Locked

Trying To connect to Windows 2003 sbs server with Remote desktop

purchasing
HI, I have been trying to set up a remote desktop or VPN connection to A windows 2003 server sbs for some time now. The following is the network layout.
2 Servers:
Server No.1 Windows 2003 SBS with exchange and sharepoint- used as a email server.
Server No2: Windows 2000 server with Terminal Server - a stock control program is running on this with internal workstations logging onto it using remote desktop connection port 3389.

Serve No 1 is what I am trying to log on to. Mcafee Total protection is installed without firewall capability.
Sonicwall model tele3pi is connected to a 3com switch ( no router installed on the network). Broadband provided through a netopia Carmen 3304 router provided by the ISP. i have opened the port 3389 on both the sonicwall firewall and the netopia router. I have setup a dynamic dns with dyndns.com as my ISP does not provide this facility. Could you please assist if setting up a VPN is easier and does not conflict the port 3389 being used by the internal terminal server application ( which I think could be the problem, I don't know) the n could you provide me with a set of steps to achieve this.
Your knowledge would be greatly appreciated.
Regards,
Merlin
  • +
    0 Votes
    robo_dev

    Do you have your server in the NAT table in the netopia and/or the Sonicwall?

    So is your config like this:

    Internet ---netopia---sonicwall-----server

    Are you running NAT in both firewalls? This would present a problem because you would need to port forward in each device, AND you may need a static route on each end to router the TS traffic properly.

    +
    0 Votes
    vwsportruck

    This may sound like a dumb question, but is the checkbox in System Properties/Remote checked? Without that, remote desktop can't work.

    +
    0 Votes
    rcfoulk

    This is not an uncommon problem in multi-server environments. VPN certainly works but must be configured on the host server. A quicker fix is to edit the registry. Search the registry (edit/find) for ?portnumber? looking for a value of 3389 (d3d hex). Change the value to another value, for example 3391. Keep repeating the search in that this will need to be changed in several places. You will also need to configure any fire walls to permit that ports pass through. You then simply put 192.168.1.44:3391 or SERVER2003:3391 (as an example) into Remote Desktop and you?re off to the races. From a security point of view it also keeps people from fishing around with remote desktop and finding your servers.

    +
    0 Votes
    jlehman

    From what I read, you are trying to conect from outside of your network. I am a Microsoft Small Business Specialist and can help you.

    Have you run the wizards on your SBS box? Run the connect to Internet wizard, open up the necessary ports and then run the remote access wizard. This will activate your server for remote access. You can't get to it otherwise.

    You will need to open up port 443 on your Sonicwall and point it to your SBS server. Do you have external DNS references pointing to your network? Using an Internet browser, type in https://yourdomainname/remote. You should be able to connect to your SBS server using Remote Web Workplace.

    Once you can connect to your network, you will have the option to connect to your terminal server.

    Here is a link for more information: http://www.microsoft.com/technet/prodtechnol/sbs/2003/support/2e29ae10-75bf-4fa7-868f-e9e162d4a985.mspx?mfr=true. You can even work on the servers when you are out of the office. It's how I provide remote assistance to my clients.

    +
    0 Votes
    jredmon

    I to am using SBS2003 and have it setup as it was explained by jlehman, it works flawlessly, smoothly, and looks downright professional. If you don't have a purchased certificate on the server however, be warned, you will get a notice when you first connect to the server that the certificate is not valid and it recommends that you do not connect. Since it's your server and you know it's safe you can go ahead and connected anyway of course.

    If you have ever used Web Terminal Server, that's basically what this is.

  • +
    0 Votes
    robo_dev

    Do you have your server in the NAT table in the netopia and/or the Sonicwall?

    So is your config like this:

    Internet ---netopia---sonicwall-----server

    Are you running NAT in both firewalls? This would present a problem because you would need to port forward in each device, AND you may need a static route on each end to router the TS traffic properly.

    +
    0 Votes
    vwsportruck

    This may sound like a dumb question, but is the checkbox in System Properties/Remote checked? Without that, remote desktop can't work.

    +
    0 Votes
    rcfoulk

    This is not an uncommon problem in multi-server environments. VPN certainly works but must be configured on the host server. A quicker fix is to edit the registry. Search the registry (edit/find) for ?portnumber? looking for a value of 3389 (d3d hex). Change the value to another value, for example 3391. Keep repeating the search in that this will need to be changed in several places. You will also need to configure any fire walls to permit that ports pass through. You then simply put 192.168.1.44:3391 or SERVER2003:3391 (as an example) into Remote Desktop and you?re off to the races. From a security point of view it also keeps people from fishing around with remote desktop and finding your servers.

    +
    0 Votes
    jlehman

    From what I read, you are trying to conect from outside of your network. I am a Microsoft Small Business Specialist and can help you.

    Have you run the wizards on your SBS box? Run the connect to Internet wizard, open up the necessary ports and then run the remote access wizard. This will activate your server for remote access. You can't get to it otherwise.

    You will need to open up port 443 on your Sonicwall and point it to your SBS server. Do you have external DNS references pointing to your network? Using an Internet browser, type in https://yourdomainname/remote. You should be able to connect to your SBS server using Remote Web Workplace.

    Once you can connect to your network, you will have the option to connect to your terminal server.

    Here is a link for more information: http://www.microsoft.com/technet/prodtechnol/sbs/2003/support/2e29ae10-75bf-4fa7-868f-e9e162d4a985.mspx?mfr=true. You can even work on the servers when you are out of the office. It's how I provide remote assistance to my clients.

    +
    0 Votes
    jredmon

    I to am using SBS2003 and have it setup as it was explained by jlehman, it works flawlessly, smoothly, and looks downright professional. If you don't have a purchased certificate on the server however, be warned, you will get a notice when you first connect to the server that the certificate is not valid and it recommends that you do not connect. Since it's your server and you know it's safe you can go ahead and connected anyway of course.

    If you have ever used Web Terminal Server, that's basically what this is.