Questions

USB 2.0 PCI for DL 380 G3

+
0 Votes
Locked

USB 2.0 PCI for DL 380 G3

Ergo we surrender.
I'm going crazy trying to get USB 2.0 support in my DL 380 G3 server! I'm running Win SBS2003 and otherwise everything is working perfectly with this server.

It has 3 PCI-X slots- Slot 1 is PCI-X 133MHz (non-hot swap) and the other 2 - slots 2 & 3 are PCI-X 100MHz hot swap.

Here's the problem...

Card 1. First card I tried was ST Labs (VIA Chipset)- 3+1 USB 2.0 - Tried it in all 3 slots- the lights on the server front panel flash amber/green (never seen amber before!!) and the server won't boot. Took it out and tried in a desktop gigabyte PC- & of course it works fine!

Card 2. Second card I tried was Chronos (VIA Chipset) 5 Ports.
In Slot 1 the server complains during bios boot that card is PCI header 2 and cannot be configured by BIOS- card will have to be configured by OS... but when 2003 Server screen appears you get a Blue Screen with NMI Parity Error...
In slot 2 or 3 server boots up normally and detects new device. Win2003 loads native VIA USB 2 drivers. All seems OK... but

If you try to plug in a USB flash device (in this case USB 2 imation 1G) wham! the server blue screens and that damn 'NMI parity error is back'. However if you boot with the device attached- all is well and you can read/write to it- no problems.

I also tried a USB 2.0 Tape Drive (HPDAT72). Installs driver okay, seems to work when you use NTBackup to write to the device, but it always seems to fail during the Verify with a 'Hardware error- failure to read from the device'. I've tried a completely new Tape Drive unit- several new tapes and all do the same thing- fails on Verify about at about 85% done. It all leads me to think that the USB 2.0 card is either flaky or the PCI-X bus is doing some weird **it with the USB 2.0 card.

Went out and bought a 3rd card to try. This time a SWANN (NEC Chipset) USB 2.0 5 Port but alas when I went to install it noticed it will not allow me to fit it as there is only one notch in card, but 2 notches in slot.

I'm hoping someone else can help me? Perhaps there is something in the BIOS (hidden advanced settings???) that I can use to make a PCI-X slot in this beast behave?

Thanks. Daz