Questions

USB Flash Drive is write protected - How do I remove it?

Tags:
+
4 Votes

USB Flash Drive is write protected - How do I remove it?

ddelpilar
While transferring files from my PC to my USB Flash Drive. I received an error message - The Disk can not be written because it is write protected. Please remove the write protection from the volume in drive \Device|Harddisk1\DR5.

How do I do this?

Thanks.

Darwin

Clarifications

rebwar_iraqi

me too have a problem tell me how can i remove protet write it

Member Answers

    • +
      1 Votes

      on the usb flash drive its self there may be a switch that will add or remove copy protection

      +
      0 Votes
      da5id_NZ

      I have posted this elsewhere, but...

      I was getting the same error with my flash drive. I also can't see the StorageDevicePolicies setting in regedit. Also, I didn't really want to reformat my drive.

      What I found you can do is get into the drive through a DOS prompt.

      Try this, in Windows XP - goto Start -> All Programs -> Accessories -> Command Prompt. This will open up a DOS window. Now type the name of your flashdrive followed by a colon, eg, mine was drive letter K so I type K:

      Now to list the directory, type DIR
      This will show your directory. At this point I left the DOS window open and went back into Windows and clicked on the drive in Explorer. The write protect error still came up, but after clicking a couple of times I could see and open the files on the drive.

      Anyway, once you're in DOS you should be able to copy any files you want to another drive using the DOS 'copy' or 'xcopy' commands, and format the drive from DOS also. eg, To copy all files and directories (except empty directories) from drive C to drive A, enter

      xcopy c: a: /s

      You can do a search on google to find other DOS commands

      +
      0 Votes
      Jones10

      I did just that but I dont seem to get the results I'm expecting. It keeps saying "disk is write protected". How can I go about this? even formating it brings out the same message!
      Help!!!!

      +
      0 Votes
      TobiF

      If YOU need help solving a problem YOU have today (and not a problem someone else had three years ago), then start your own question thread. Simply click on the button "Ask question".
      If you want to get better quality in the answers, then tell us what kind of USB you have (maybe even model), kind of OS, what you have already tried.

      +
      0 Votes
      cutiecute

      But what if my flash doesn't have switch?
      what am i gonna do?

      +
      2 Votes
      jamesatmaisonverre

      flick the switch with the padlock symbol to unlock on the stick itself

      +
      0 Votes
      thedame72

      thanks! I would never have thought to have looked there

      +
      0 Votes
      cutiecute

      But my Flash drive doesn't have switch. What am i gonna do?

      +
      1 Votes
      m3rlinez

      If you are sure that there is no write-protect switch. You can try low-level format it. I have had similar problem with my Apacer Handy Steno HT 202 and used the lformat program provided at their website and it works! You can visit http://m3rlinez.blogspot.com/2007/01/just-rescued-my-write-protected-usb.html for more info about my case. Hope this helps

      +
      2 Votes
      ingolf.steinbach

      Hi,

      have you solved your problem? I seem to have the same problem with a USB 2.0 PenDrive Mini, 1GB, which has started to report write protection after about 260MB have been copied successfully to the drive. Formatting works, however.

      Kind regards
      Ingolf

      +
      2 Votes
      da5id_NZ

      I have posted this elsewhere, but...

      I was getting the same error with my flash drive. I also can't see the StorageDevicePolicies setting in regedit. Also, I didn't really want to reformat my drive.

      What I found you can do is get into the drive through a DOS prompt.

      Try this, in Windows XP - goto Start -> All Programs -> Accessories -> Command Prompt. This will open up a DOS window. Now type the name of your flashdrive followed by a colon, eg, mine was drive letter K so I type K:

      Now to list the directory, type DIR
      This will show your directory. At this point I left the DOS window open and went back into Windows and clicked on the drive in Explorer. The write protect error still came up, but after clicking a couple of times I could see and open the files on the drive.

      Anyway, once you're in DOS you should be able to copy any files you want to another drive using the DOS 'copy' or 'xcopy' commands, and format the drive from DOS also. eg, To copy all files and directories (except empty directories) from drive C to drive A, enter

      xcopy c: a: /s

      You can do a search on google to find other DOS commands

      +
      0 Votes
      Jacky Howe

      Check out the registry under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies.
      The value 'WriteProtect' should be absent or set to '0'.

      +
      0 Votes
      punit_vyas2005

      IT'S WORKS

      Check out the registry under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies.

      The value 'WriteProtect' should be absent or set to '0'.

      +
      0 Votes
      poooh%%boo booo

      ill try this out and hope it actually works.....

      +
      1 Votes
      hyuganeji1

      So I right clicked my flash drive went to sharing and security--> sharing tab and I added a new share and under permissions I added my username from the network and gave it full control. I clicked ok then everything worked fine. Then I went back to the drive in my computer right clicked it again, went to the sharing and security, then the sharing tab and removed the new share that I just added and things still worked fine. Not sure why but you could give it a try.

      +
      0 Votes
      powermanx84

      it was said go do storage device polices file in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies

      i followed all these files but could not storage device file....what do i do?

      +
      0 Votes
      greengerm

      press start on your screen,go to run,if you have windows 7 like me go to the part where it says search programs and files here,search run,click on it,and type regedit,now in registry editor click on computer once,go to the upper left corner in the window and click file then click export and save it on desktop,this will be a backup,if you mess up your registry then click file then import and import that file,now go to on the rgisrty editor
      HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\control\usbstor
      then click on each folder and go to each file that say devicehack flags,click on it and put the value to 0 and thats it!!

      +
      0 Votes
      t41h4

      hey i cnt find any folder named usbstor
      what shall i do now..?? =S

      +
      0 Votes
      bkile1

      I tried to use this fix, but my registry does not have the final folder: "StorageDevicePolicies" Could there be another name for this folder? I am using XP Pro.
      Thnaks.

      +
      2 Votes
      technik

      Found it! I have a feeling one of my co-workers (A Linux God who disdains us Windows Gurus) was playing a joke on me. The following came from David Kramer.KA at http://davidkramer.wordpress.com It fixed it completely. Thank goodness! Open the command line editor of windows XP (in my case, and in that case hopefully your, if I am to help you). You find that under ?Start?, the choose ?Run?. There you enter ?regedit?. This starts a little program that allows you to operate within the holiest of sites of windows, the registry. Here all kind of actions and behaviors of the system are set. Go to the path: HKEY_LOCAL_MACHINE\System\ CurrentControlSet\Control \StorageDevicePolicies This is simply a folder within a folder and so on? The final folder, the one you are looking for is called StorageDevicePolicies, and as the name suggests contains the settings for how the storage devices (USB flash) should behave. Here you right click on: ?WriteProtect? and select ?modify?. Here you set the value that appears to ?0″. Press enter and that?s it. (In other words: Default value: DWORD=0) Possible values are: 0 ? Disabled 1 ? Enabled Set the value to 0 and your back in business.

      +
      0 Votes
      kimatthews

      Did the StorageDevices thing and it still didn't work, so I did a safe remove of device and then plugged it in again and it worked. I could then format the drive in Explorer.
      1. This USB stick went through a couple/four airport scanners.
      2. Also had the problem after moving from one machine to another without safely remove.

      +
      0 Votes
      Pooshen

      i've tried to open the path that you've given but when i was on this part "HKEY_LOCAL_MACHINE\System\ CurrentControlSet\Control" i can't find the "storageDevicePolicies" i'm using a windows xp service pack 3 could that be an issue?

      +
      0 Votes
      sharmaharsh

      Worked great!!!

      +
      0 Votes
      JohnMich

      This was working like a dream until I got to the Storage Device Policies bit. Too easy says I. But I am using W/Vista Home Basic and guess what there is NO heading Storage Device Policies! Further clicking on the Storage heading does nothing its empty.
      So can someone please tell me what to do now.
      I have copied all the files that were on the G: drive to a separate area on C: (a sort of belt and braces thing) but I can't even format G: because of the write protection.
      What do I do now please?

      +
      0 Votes
      nikhil25

      the best way is to use the regedit only, but if you can afford to format the usb drive, then try "HP usb disk storage format tool" ( http://www.softpedia.com/get/System/Hard-Disk-Utils/HP-USB-Disk-Storage-Format-Tool.shtml ) it is very small utility & quite useful.

      - Nikhil

      +
      1 Votes
      overburned

      click on safely remove hardware & eject media, unplug device, plug it back in, then start saving your files to the flash drive!

      +
      0 Votes
      TobiF

      The problem was raised and the correct solution (a different one than you propose was found) back in 2007!

      +
      1 Votes
      imwhoim

      i have my 256 GB kingston , it wont write any more , it only allow me to copy the files that already in there but when i tried to write more files it tells me that this drive is write protected , i tried to do the regedit but nothing works out , what can i do , is there any help , please !

      +
      5 Votes
      awaheed82

      USB Memory Stick is Write Protected:
      How to remove a write protection from your USB memory Stick if there is no Write protection ON or OFF button on stick then
      1. Shutdown your computer or laptop
      2. Insert USB Memory Stick into your laptop or Computer
      3. Turn on laptop and then immediately start pressing (F8) key then Advanced Boot Options screen will come up
      4. Select Safe Mode with Command Prompt
      5. After loading files if your USB Memory Stick drive letter is (G) for example then write as
      6. C:\windows\system32>G: and press enter
      7. G:\>format G: and press enter
      8. If ask you (Y/N) then press (Y) and press enter
      9. Now a full format will start which remove write protection from USB Memory Stick.
      Note:
      Before removing USB from your computer, Always remove it safely by going into to my computer then right click on USB and click eject.

      +
      0 Votes
      acl

      Did the trick. Thank you imwhoim.

      +
      0 Votes
      jimnycricket65

      I got to line item #7 and crossed my fingers... even in dos it says the drive is write protected. This 16GB Toshiba is from Autodesk - they sent it in this media rather than a DVD. I feel it is close but don't know DOS command to un-write protect.

      +
      0 Votes
      jimnycricket65

      I don't know why I didn't decided to google autodesk media toshiba 16GB flash drive first but when my mind got to it, I found this link and tried the first method but this Edit 2 suggestion did the job for me:
      What Revit Wants: Repurposing the Autodesk USB Media

      Edit 2 - You may want to try Formatter first - Craig at iRevit has hosted the Formatter.zip and tested it (May 2012)

      If you need to do this, go to the url and click on Formatter.zip link for download.

      Thanks everyone.

      +
      5 Votes
      edmundd

      I need help with one of my users flashdisk.

    • +
      1 Votes

      on the usb flash drive its self there may be a switch that will add or remove copy protection

      +
      0 Votes
      da5id_NZ

      I have posted this elsewhere, but...

      I was getting the same error with my flash drive. I also can't see the StorageDevicePolicies setting in regedit. Also, I didn't really want to reformat my drive.

      What I found you can do is get into the drive through a DOS prompt.

      Try this, in Windows XP - goto Start -> All Programs -> Accessories -> Command Prompt. This will open up a DOS window. Now type the name of your flashdrive followed by a colon, eg, mine was drive letter K so I type K:

      Now to list the directory, type DIR
      This will show your directory. At this point I left the DOS window open and went back into Windows and clicked on the drive in Explorer. The write protect error still came up, but after clicking a couple of times I could see and open the files on the drive.

      Anyway, once you're in DOS you should be able to copy any files you want to another drive using the DOS 'copy' or 'xcopy' commands, and format the drive from DOS also. eg, To copy all files and directories (except empty directories) from drive C to drive A, enter

      xcopy c: a: /s

      You can do a search on google to find other DOS commands

      +
      0 Votes
      Jones10

      I did just that but I dont seem to get the results I'm expecting. It keeps saying "disk is write protected". How can I go about this? even formating it brings out the same message!
      Help!!!!

      +
      0 Votes
      TobiF

      If YOU need help solving a problem YOU have today (and not a problem someone else had three years ago), then start your own question thread. Simply click on the button "Ask question".
      If you want to get better quality in the answers, then tell us what kind of USB you have (maybe even model), kind of OS, what you have already tried.

      +
      0 Votes
      cutiecute

      But what if my flash doesn't have switch?
      what am i gonna do?

      +
      2 Votes
      jamesatmaisonverre

      flick the switch with the padlock symbol to unlock on the stick itself

      +
      0 Votes
      thedame72

      thanks! I would never have thought to have looked there

      +
      0 Votes
      cutiecute

      But my Flash drive doesn't have switch. What am i gonna do?

      +
      1 Votes
      m3rlinez

      If you are sure that there is no write-protect switch. You can try low-level format it. I have had similar problem with my Apacer Handy Steno HT 202 and used the lformat program provided at their website and it works! You can visit http://m3rlinez.blogspot.com/2007/01/just-rescued-my-write-protected-usb.html for more info about my case. Hope this helps

      +
      2 Votes
      ingolf.steinbach

      Hi,

      have you solved your problem? I seem to have the same problem with a USB 2.0 PenDrive Mini, 1GB, which has started to report write protection after about 260MB have been copied successfully to the drive. Formatting works, however.

      Kind regards
      Ingolf

      +
      2 Votes
      da5id_NZ

      I have posted this elsewhere, but...

      I was getting the same error with my flash drive. I also can't see the StorageDevicePolicies setting in regedit. Also, I didn't really want to reformat my drive.

      What I found you can do is get into the drive through a DOS prompt.

      Try this, in Windows XP - goto Start -> All Programs -> Accessories -> Command Prompt. This will open up a DOS window. Now type the name of your flashdrive followed by a colon, eg, mine was drive letter K so I type K:

      Now to list the directory, type DIR
      This will show your directory. At this point I left the DOS window open and went back into Windows and clicked on the drive in Explorer. The write protect error still came up, but after clicking a couple of times I could see and open the files on the drive.

      Anyway, once you're in DOS you should be able to copy any files you want to another drive using the DOS 'copy' or 'xcopy' commands, and format the drive from DOS also. eg, To copy all files and directories (except empty directories) from drive C to drive A, enter

      xcopy c: a: /s

      You can do a search on google to find other DOS commands

      +
      0 Votes
      Jacky Howe

      Check out the registry under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies.
      The value 'WriteProtect' should be absent or set to '0'.

      +
      0 Votes
      punit_vyas2005

      IT'S WORKS

      Check out the registry under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies.

      The value 'WriteProtect' should be absent or set to '0'.

      +
      0 Votes
      poooh%%boo booo

      ill try this out and hope it actually works.....

      +
      1 Votes
      hyuganeji1

      So I right clicked my flash drive went to sharing and security--> sharing tab and I added a new share and under permissions I added my username from the network and gave it full control. I clicked ok then everything worked fine. Then I went back to the drive in my computer right clicked it again, went to the sharing and security, then the sharing tab and removed the new share that I just added and things still worked fine. Not sure why but you could give it a try.

      +
      0 Votes
      powermanx84

      it was said go do storage device polices file in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies

      i followed all these files but could not storage device file....what do i do?

      +
      0 Votes
      greengerm

      press start on your screen,go to run,if you have windows 7 like me go to the part where it says search programs and files here,search run,click on it,and type regedit,now in registry editor click on computer once,go to the upper left corner in the window and click file then click export and save it on desktop,this will be a backup,if you mess up your registry then click file then import and import that file,now go to on the rgisrty editor
      HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\control\usbstor
      then click on each folder and go to each file that say devicehack flags,click on it and put the value to 0 and thats it!!

      +
      0 Votes
      t41h4

      hey i cnt find any folder named usbstor
      what shall i do now..?? =S

      +
      0 Votes
      bkile1

      I tried to use this fix, but my registry does not have the final folder: "StorageDevicePolicies" Could there be another name for this folder? I am using XP Pro.
      Thnaks.

      +
      2 Votes
      technik

      Found it! I have a feeling one of my co-workers (A Linux God who disdains us Windows Gurus) was playing a joke on me. The following came from David Kramer.KA at http://davidkramer.wordpress.com It fixed it completely. Thank goodness! Open the command line editor of windows XP (in my case, and in that case hopefully your, if I am to help you). You find that under ?Start?, the choose ?Run?. There you enter ?regedit?. This starts a little program that allows you to operate within the holiest of sites of windows, the registry. Here all kind of actions and behaviors of the system are set. Go to the path: HKEY_LOCAL_MACHINE\System\ CurrentControlSet\Control \StorageDevicePolicies This is simply a folder within a folder and so on? The final folder, the one you are looking for is called StorageDevicePolicies, and as the name suggests contains the settings for how the storage devices (USB flash) should behave. Here you right click on: ?WriteProtect? and select ?modify?. Here you set the value that appears to ?0″. Press enter and that?s it. (In other words: Default value: DWORD=0) Possible values are: 0 ? Disabled 1 ? Enabled Set the value to 0 and your back in business.

      +
      0 Votes
      kimatthews

      Did the StorageDevices thing and it still didn't work, so I did a safe remove of device and then plugged it in again and it worked. I could then format the drive in Explorer.
      1. This USB stick went through a couple/four airport scanners.
      2. Also had the problem after moving from one machine to another without safely remove.

      +
      0 Votes
      Pooshen

      i've tried to open the path that you've given but when i was on this part "HKEY_LOCAL_MACHINE\System\ CurrentControlSet\Control" i can't find the "storageDevicePolicies" i'm using a windows xp service pack 3 could that be an issue?

      +
      0 Votes
      sharmaharsh

      Worked great!!!

      +
      0 Votes
      JohnMich

      This was working like a dream until I got to the Storage Device Policies bit. Too easy says I. But I am using W/Vista Home Basic and guess what there is NO heading Storage Device Policies! Further clicking on the Storage heading does nothing its empty.
      So can someone please tell me what to do now.
      I have copied all the files that were on the G: drive to a separate area on C: (a sort of belt and braces thing) but I can't even format G: because of the write protection.
      What do I do now please?

      +
      0 Votes
      nikhil25

      the best way is to use the regedit only, but if you can afford to format the usb drive, then try "HP usb disk storage format tool" ( http://www.softpedia.com/get/System/Hard-Disk-Utils/HP-USB-Disk-Storage-Format-Tool.shtml ) it is very small utility & quite useful.

      - Nikhil

      +
      1 Votes
      overburned

      click on safely remove hardware & eject media, unplug device, plug it back in, then start saving your files to the flash drive!

      +
      0 Votes
      TobiF

      The problem was raised and the correct solution (a different one than you propose was found) back in 2007!

      +
      1 Votes
      imwhoim

      i have my 256 GB kingston , it wont write any more , it only allow me to copy the files that already in there but when i tried to write more files it tells me that this drive is write protected , i tried to do the regedit but nothing works out , what can i do , is there any help , please !

      +
      5 Votes
      awaheed82

      USB Memory Stick is Write Protected:
      How to remove a write protection from your USB memory Stick if there is no Write protection ON or OFF button on stick then
      1. Shutdown your computer or laptop
      2. Insert USB Memory Stick into your laptop or Computer
      3. Turn on laptop and then immediately start pressing (F8) key then Advanced Boot Options screen will come up
      4. Select Safe Mode with Command Prompt
      5. After loading files if your USB Memory Stick drive letter is (G) for example then write as
      6. C:\windows\system32>G: and press enter
      7. G:\>format G: and press enter
      8. If ask you (Y/N) then press (Y) and press enter
      9. Now a full format will start which remove write protection from USB Memory Stick.
      Note:
      Before removing USB from your computer, Always remove it safely by going into to my computer then right click on USB and click eject.

      +
      0 Votes
      acl

      Did the trick. Thank you imwhoim.

      +
      0 Votes
      jimnycricket65

      I got to line item #7 and crossed my fingers... even in dos it says the drive is write protected. This 16GB Toshiba is from Autodesk - they sent it in this media rather than a DVD. I feel it is close but don't know DOS command to un-write protect.

      +
      0 Votes
      jimnycricket65

      I don't know why I didn't decided to google autodesk media toshiba 16GB flash drive first but when my mind got to it, I found this link and tried the first method but this Edit 2 suggestion did the job for me:
      What Revit Wants: Repurposing the Autodesk USB Media

      Edit 2 - You may want to try Formatter first - Craig at iRevit has hosted the Formatter.zip and tested it (May 2012)

      If you need to do this, go to the url and click on Formatter.zip link for download.

      Thanks everyone.

      +
      5 Votes
      edmundd

      I need help with one of my users flashdisk.