Questions

Vista VPN not able to access Network shares

+
0 Votes
Locked

Vista VPN not able to access Network shares

van_den_heuvel
Hi all,

I recently got a new laptop from work with Vista. I have set up a microsoft VPN connection to my workplace and can connect to it. I can ping the file and print server on the network, however, I cannot access the share. I have my home PC with XP and there everything works fine. It is therefore a setting in Windows Vista. Can anyone help me with this?

Thanks.
  • +
    0 Votes
    peluca__

    Hi
    I have the exact same problem. It is driving me crazy and it is only the Vista machine who struggles, the other XP machines works just fine.
    I'm able to ping and remote the server and that works fine.

    I have a SBS 2003 server on the other side of the VPN tunnel and I've changed the authentication level of security in local policies so the server sends both LM and NTLM responses (set to only NTLM by default). On the Vista machine I changed to the same values and nothing..
    I've tried to map in the cmd prompt and nothing..
    I've tried to map using both server name and IP adress and nothing..
    I've tried to search for the server in the find field and nothing..

    The error message only says that the path is can not be founded.

    I'm out of ideas

    I have read that many people are expiriencing the same problem, all with the sam symptoms and all with pretty much the same suggestions but NO ONE with a solution. Isnt there NOBODY who actually fixed this?
    If so PLEASE post the solution. Would be mostly much very mucho eternally appreciated.
    Thanx for posting!

    +
    0 Votes
    noemailforme

    1.) open regedit
    2.) find HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netbt\Linkage
    3.) copy the value of the bind entry to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\smb\Linkage
    4.) reboot

    http://support.microsoft.com/kb/933468

    +
    0 Votes
    paul.roullier

    I have had among many this problem with Vista. The VPN Allows connection to Container Domain (The Domain the computer belongs) But would not allow access to other trusted domains. This fixed it and made the sales director very happy.

    Regards

    (Sigh, any one know how to add account category code to MS CRM 4 system)

    +
    0 Votes
    rentageekla

    http://support.microsoft.com/kb/933468/en-us

    1. Click Start, type regedit in the Start Search box, and then click regedit.exe in the Programs list.
    If you are prompted for the administrator password or for a confirmation, type your password, or click Continue.
    2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netbt\Linkage
    3. On the File menu, click Export.
    4. In the Save box, specify a location where you want to save the file.
    5. In the File name box, enter a name for the file.
    6. In the Save as type box, click Registry Files.
    7. In the Export range box, click Selected branch, and then click Save.
    8. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netbt\Linkage
    9. In the details pane, right-click the Bind registry entry in the Name column, click Modify, and then copy the data in the Value data box to the clipboard.
    10. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\smb\Linkage
    11. In the details pane, right-click the Bind entry in the Name column, click Modify, paste the data from the clipboard to the Value data text box to override the original data, and then click OK.
    12. Exit Registry Editor, and restart the computer

    +
    0 Votes
    Darren B - KC

    This fix did NOT work for my Vista Home Premium laptop. Both keys described here already had the same data. Still cannot access remote resources through the VPN.

    +
    0 Votes
    SuicideTaxi

    This is totally maddening and I can't believe a solution is so hard to come by....

    +
    0 Votes

    DNS

    Nimmo

    Try adding the domain as a DNS suffix on your Vista PC. Because your PC isn't part of the domain you will not be getting DNS from the domain server therefore (basically) you wont be able to access shares.

    +
    0 Votes
    Sue T

    I can't say this will fix the problem but is fast and simple so worth a shot. Open the Local Security Policy, select Local Policies, Security Options. Look for Network Security LAN Manager Authenicate Level and change it to Set to Send LM & NTLM responses. Not sure I have everything worded a 100% correctly but that should get you there.
    Good luck.

  • +
    0 Votes
    peluca__

    Hi
    I have the exact same problem. It is driving me crazy and it is only the Vista machine who struggles, the other XP machines works just fine.
    I'm able to ping and remote the server and that works fine.

    I have a SBS 2003 server on the other side of the VPN tunnel and I've changed the authentication level of security in local policies so the server sends both LM and NTLM responses (set to only NTLM by default). On the Vista machine I changed to the same values and nothing..
    I've tried to map in the cmd prompt and nothing..
    I've tried to map using both server name and IP adress and nothing..
    I've tried to search for the server in the find field and nothing..

    The error message only says that the path is can not be founded.

    I'm out of ideas

    I have read that many people are expiriencing the same problem, all with the sam symptoms and all with pretty much the same suggestions but NO ONE with a solution. Isnt there NOBODY who actually fixed this?
    If so PLEASE post the solution. Would be mostly much very mucho eternally appreciated.
    Thanx for posting!

    +
    0 Votes
    noemailforme

    1.) open regedit
    2.) find HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netbt\Linkage
    3.) copy the value of the bind entry to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\smb\Linkage
    4.) reboot

    http://support.microsoft.com/kb/933468

    +
    0 Votes
    paul.roullier

    I have had among many this problem with Vista. The VPN Allows connection to Container Domain (The Domain the computer belongs) But would not allow access to other trusted domains. This fixed it and made the sales director very happy.

    Regards

    (Sigh, any one know how to add account category code to MS CRM 4 system)

    +
    0 Votes
    rentageekla

    http://support.microsoft.com/kb/933468/en-us

    1. Click Start, type regedit in the Start Search box, and then click regedit.exe in the Programs list.
    If you are prompted for the administrator password or for a confirmation, type your password, or click Continue.
    2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netbt\Linkage
    3. On the File menu, click Export.
    4. In the Save box, specify a location where you want to save the file.
    5. In the File name box, enter a name for the file.
    6. In the Save as type box, click Registry Files.
    7. In the Export range box, click Selected branch, and then click Save.
    8. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netbt\Linkage
    9. In the details pane, right-click the Bind registry entry in the Name column, click Modify, and then copy the data in the Value data box to the clipboard.
    10. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\smb\Linkage
    11. In the details pane, right-click the Bind entry in the Name column, click Modify, paste the data from the clipboard to the Value data text box to override the original data, and then click OK.
    12. Exit Registry Editor, and restart the computer

    +
    0 Votes
    Darren B - KC

    This fix did NOT work for my Vista Home Premium laptop. Both keys described here already had the same data. Still cannot access remote resources through the VPN.

    +
    0 Votes
    SuicideTaxi

    This is totally maddening and I can't believe a solution is so hard to come by....

    +
    0 Votes

    DNS

    Nimmo

    Try adding the domain as a DNS suffix on your Vista PC. Because your PC isn't part of the domain you will not be getting DNS from the domain server therefore (basically) you wont be able to access shares.

    +
    0 Votes
    Sue T

    I can't say this will fix the problem but is fast and simple so worth a shot. Open the Local Security Policy, select Local Policies, Security Options. Look for Network Security LAN Manager Authenicate Level and change it to Set to Send LM & NTLM responses. Not sure I have everything worded a 100% correctly but that should get you there.
    Good luck.