Questions

Vista VPN not able to access Network shares

Tags:
+
0 Votes
Locked

Vista VPN not able to access Network shares

van_den_heuvel
Hi all,

I recently received a new laptop with Windows Vista. I have set up a VPN connection to my workplace and get connected to it. I can ping all servers in the office (also file & print). However, when I try to access a share on the file server, this will not work. I get an error message 'Windows cannot find 10.x.x.x'. I also tried the name of the server and the FQ name of the server. They all can be pinged, but not accessed.
I also have a desktop PC with XP at home. When I connect through VPN to my workplace, I can access the shares on the file server. It therefore should be one of the settings in Windows Vista.
Can anyone help me with this?
  • +
    0 Votes
    guaroa

    You must enable Netbios Over tcp/ip on the server....it is located on the wins tab of tcp/ip configuration of your network card.

    +
    0 Votes
    rentageekla

    On your Vista machine:

    1. Click Start, type regedit in the Start Search box, and then click regedit.exe in the Programs list.
    If you are prompted for the administrator password or for a confirmation, type your password, or click Continue.
    2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netbt\Linkage
    3. On the File menu, click Export.
    4. In the Save box, specify a location where you want to save the file.
    5. In the File name box, enter a name for the file.
    6. In the Save as type box, click Registry Files.
    7. In the Export range box, click Selected branch, and then click Save.
    8. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netbt\Linkage
    9. In the details pane, right-click the Bind registry entry in the Name column, click Modify, and then copy the data in the Value data box to the clipboard.
    10. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\smb\Linkage
    11. In the details pane, right-click the Bind entry in the Name column, click Modify, paste the data from the clipboard to the Value data text box to override the original data, and then click OK.
    12. Exit Registry Editor, and restart the computer

    From: http://support.microsoft.com/kb/933468/en-us

    +
    0 Votes
    darin.ganitch

    Initially,I was having issues with accessing shares. I could connect to the VPN and I could see traffic going out but not coming back. The Cisco site posted this fix related to the below mentioned VPN client. Additionally a link is provided for this client for you to download. I believe it is the most current at the time of this posting. Otherwise search the net.

    vpnclient-win-msi-5.0.03.0530-k9.exe

    Workarounds for Vista:
    use the following keyword in connection profile (*.pcf):UseLegacyIKEPort=1

    The profile should be located C:\Program Files\Cisco Systems\VPN Client\Profiles\*.pcf

    http://160.78.48.20/vpn/software/Windows/VersioniPiu'Aggiornate/

  • +
    0 Votes
    guaroa

    You must enable Netbios Over tcp/ip on the server....it is located on the wins tab of tcp/ip configuration of your network card.

    +
    0 Votes
    rentageekla

    On your Vista machine:

    1. Click Start, type regedit in the Start Search box, and then click regedit.exe in the Programs list.
    If you are prompted for the administrator password or for a confirmation, type your password, or click Continue.
    2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netbt\Linkage
    3. On the File menu, click Export.
    4. In the Save box, specify a location where you want to save the file.
    5. In the File name box, enter a name for the file.
    6. In the Save as type box, click Registry Files.
    7. In the Export range box, click Selected branch, and then click Save.
    8. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netbt\Linkage
    9. In the details pane, right-click the Bind registry entry in the Name column, click Modify, and then copy the data in the Value data box to the clipboard.
    10. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\smb\Linkage
    11. In the details pane, right-click the Bind entry in the Name column, click Modify, paste the data from the clipboard to the Value data text box to override the original data, and then click OK.
    12. Exit Registry Editor, and restart the computer

    From: http://support.microsoft.com/kb/933468/en-us

    +
    0 Votes
    darin.ganitch

    Initially,I was having issues with accessing shares. I could connect to the VPN and I could see traffic going out but not coming back. The Cisco site posted this fix related to the below mentioned VPN client. Additionally a link is provided for this client for you to download. I believe it is the most current at the time of this posting. Otherwise search the net.

    vpnclient-win-msi-5.0.03.0530-k9.exe

    Workarounds for Vista:
    use the following keyword in connection profile (*.pcf):UseLegacyIKEPort=1

    The profile should be located C:\Program Files\Cisco Systems\VPN Client\Profiles\*.pcf

    http://160.78.48.20/vpn/software/Windows/VersioniPiu'Aggiornate/