Questions

VPN setup W2k3 Speedtouch 510

Tags:
+
0 Votes
Locked

VPN setup W2k3 Speedtouch 510

rcoelho
Many answers I've seen but none worked, maybe you can see what I'm doing wrong

I have a Speedtouch 510 v4.2 that connects to the internet and has a ADSL Static IP. Behind that is a Windows2003 server that I want to setup as a VPN server. It has 2 NIC but I also read that it can work with only one. One NIC is connected to the router and the other NIC is connected to a switch that is also connected to the same adsl router.

The manual configured IP for the first NIC is 10.0.0.100 in subnet 255.0.0.0 gateway 10.0.0.138. For the second NIC is 10.0.0.101 in subnet 255.0.0.0 no gateway. The DHCP server is running from the router and the router is also configured to open port 1723, protocol 47 and even udp 500 (don't really know if this is needed). When I try to connect from an external computer I have error 800 (cannot reach the server). I can ping the static IP with no problem from an outside computer. Can anyone see what I'm doing wrong? Is there any way of testing the setup to find what is preventing the access to the server? Also when I use the VPN wizard and choose the first NIC as the one connecting to the internet, as soon as the wizard finishes I can't access this computer using remote desktop for instance. The server completely disappears from the intranet. I can send more details if needed and even send the details for you to connect from your own computer to help
Thanks in advance
  • +
    0 Votes
    matrixduke

    hey i had the same problem over the settings you want to apply , the event viewer reported that the GRE protocol is not enabled on the Router , sent the problem to Speed touch site ans they replied with the Configuration to use and it worked fine.
    hope this helps

    +
    0 Votes
    eno_col

    what you are doing is very correct but let me point out to you the possible problem. if you have opened port 1723 on the router that is OK but then you should also fine a way of saying traffic passing through port 1723 should reach the ip address 10.0.0.100. on other systems NAT (Network Address Translation) is used. so, try to configure the router is that traffic passing thought port 1723 (which is PPTP i think) should be directed to the ip address of the NIC connected to the router. if that option is not available, then maybe that router will not perform that job for you. you will need another model or brand which supports NAT.

  • +
    0 Votes
    matrixduke

    hey i had the same problem over the settings you want to apply , the event viewer reported that the GRE protocol is not enabled on the Router , sent the problem to Speed touch site ans they replied with the Configuration to use and it worked fine.
    hope this helps

    +
    0 Votes
    eno_col

    what you are doing is very correct but let me point out to you the possible problem. if you have opened port 1723 on the router that is OK but then you should also fine a way of saying traffic passing through port 1723 should reach the ip address 10.0.0.100. on other systems NAT (Network Address Translation) is used. so, try to configure the router is that traffic passing thought port 1723 (which is PPTP i think) should be directed to the ip address of the NIC connected to the router. if that option is not available, then maybe that router will not perform that job for you. you will need another model or brand which supports NAT.