Questions

VPN will Connect but can not map drive

Tags:
+
1 Votes
Locked

VPN will Connect but can not map drive

bigos2
I set up a VPN on a windows XP at home and set up Server 2003 to except VPN. At home I can log on to server, but I can't map drives, read data, etc. Can anybody help me. What am i forgetting?
  • +
    0 Votes
    vlape

    can you see the shares by \\<server name>, if not how bout \\<ip address>?
    post output from ipconfig /all of the VPN connection.

    +
    0 Votes
    luc_andre

    If you have a software firewall, like Norton Security, it could be blocking the allowance of network connections like File Sharing and NetBios (in Norton, found under Advanced Settings > Networking)

    +
    0 Votes
    Kjell_Andorsen

    I have seen the same issue, it appears to be a shortcoming of XP home. It has issues connecting to certain network reosurces on a Domain. Only way I found around it was to upgrade the end-user to XP pro, which instantly resolved the issue.

    I believe it's an issue with XP home not authenticating properly to an AD Domain.

    +
    0 Votes
    vlape

    I have never had an issue with XP Home or Media edition authenticating against a domain via VPN. The operating system has no relevance. if DHCP is not passing thru the proper information such as domain suffix, dns, gateway because the firewall is not configured to do as such you will have a problem accessing network resources by name.

    Installing another operating system is NOT the answer to this problem. Proper configuration of your firewall is the solution.

    +
    0 Votes
    Kjell_Andorsen

    I've had the Win XP Home users AUTHENTICATE and be able to log on to VPN, that was not the problem, but the problem is that because XP home doesn't support Group policy and File level access control, they were not able to access network drives and folders on the network once they had logged on to the domain. This appears to be the problem the poster is having, and I don't really see it as being a firewall issue. The test is of course to simply disable the firewall on the VPN client and see if it works.

    +
    0 Votes
    vlape

    i am not going to get into a flame match with you about this however you are WAY off the mark here. A NON DOMAIN computer making a VPN connection to a domain will NEVER process a gp. the workstation does not even know the domain controller exists. File access control had nothing to do with the clent computer being part of the domain, this is why users have the ability to auth with user@domain or domain\user. This authentication is done when the VPN connection is established. (remember the user is authenticating NOT the machine)

    This is nothing more than a firewall configuration issue. The firewall is not handling dns from vpn side to internal and most likeley the user did not properly setup dhcp relay agent or configure dhcp properly therefore the client pc is not getting enough information to use netbios names over the netowrk. I would bet anything he can connect using IP addresses to everything on his netowrk wothout any problems.

    I am sure the poster appriciates your help / information however if you do not completely know that you are talking about and provide incorrect informaiton it will only add confusion to the situation. Anyhow just my two cents.

    +
    0 Votes
    scottmelcher

    I have set up my XP home to accept incoming connections via a VPN. I am able to connect to this VPN fine from outside my network. However, I cannot then map a drive. I have tried disabling the firewall to no avail.

    +
    0 Votes
    scottmelcher

    I am also trying to map the drives via IP address and not name.

    +
    0 Votes
    ameza

    how many network adapters do you have on the server? for full VPN functionality you need two.
    see: http://support.microsoft.com/kb/217766/en-us

    +
    0 Votes
    blaynepeacock

    Dear vlape:

    forgive my ignorance, but would a normal wireless router have the dhcp relay agent you mentioned? Other than setting up the router firewall seeting to allow the VPN traffic, how to I alter the DHCP settings?

    thanks

    +
    0 Votes
    vic.speedypcrepair

    Try changing the IP and IP range of your local router at home. If you are getting the same address as the computer you are logging into or even the same range you'll probably not be able to connect.

    The following will probably work.
    Server = 192.168.1.1(router) and server range 192.168.1.100 to 192.168.1.253
    home computer = 192.168.2.1(router) and server range 192.168.2.100 to 192.168.2.253

    The catch to this is the domain issue which was answered elsewhere in this thread.

    +
    0 Votes
    elmakrani

    I've had the same problem. I fixed it with using the server name instead of IP address. And I had to disable the firewall on my vpn client(XP Pro) as well.
    Hope this helps...

    +
    0 Votes
    tgrizzel

    So I was experiencing the same issues you were having...Current mapped drives would not work while using wireless and vpn on another network. On some users computers it would and others in wont (all xp pro sp2). I tried everything, checked dns, dhcp newer vpn client, diff network and at the same time as all of these my firewall/antivirus settings. Finally I was so fed up I was reconfiging everything back to a useable state on a users computer and as soon as I fully configured his norton firewall (to defaults) it began working. I need to try this on other pc's however I thought for sure if I had a firewall issue it would work when the firewall was completely disabled and not fully configured.

    +
    0 Votes
    ananga

    Use the fully qualified domain name when mapping your network drives. If your domain name is viper. instead of
    \\galileo\folder as your share folder,
    make it \\Galileo.viper.com\folder.

    +
    0 Votes
    laura

    Having the same problem. Would love to know what fixed it. We cannot figure it out. Old VPN worked with SBC DSL and Windows XP but not this one. We can connect but cannot map drive it--DSL appears to be blocking it.

    +
    0 Votes
    zzoldi

    I had the same problem.
    I have win 2003 server and tried to access it from XP sp2 and Vista. When I tried to access the file server (\\server) it could not find it. After i specified a folder on the server it found it!!! eg. "\\server\Company Files" Finally i can access my work files from home without remote desktop.
    //What is weird, i still can not browse for the folder when i want to map it. Can it be a privilege issue?

    +
    0 Votes
    IT

    I believe the previous poster explained it- you need to provide the FQDN in your mapping (script of manual) for the drive.

    So it should be "\\server.domain.local\Company Files" rather than just "\\server\Company Files"

    +
    0 Votes
    Nimmo

    If you are connecting to a domain VIA a VPN then your PC is acting as if it is on the local network so mapping a share is the same
    i.e. \\server\share.

    Ping the server when you are connected to the domain via the VPN if you can't connect do a ipconfig /all and check your settings especially DNS and also subnet mask.

    Make sure your computer is a member of the domain, if you dont wan't it to be then you must make sure you have put the domain DNS servers in as a suffix on your workstation, otherwise your not going to resolve hosts.

    You will soon know if its just DNS if you can browse via shares via \\server ip address\share name not hostname.

    +
    0 Votes
    mtucker

    In the connection client uncheck the "Use default gateway on remote network." Then you will be able to map a drive. You will find this in the Advance button in the properties of the TCPIP Protocol

    +
    1 Votes
    fetz

    On the server go to Firewall, Exceptions, Hilight "File & Printer Sharing", Edit, Change Scope. Select "Any Computer" . Good luck

  • +
    0 Votes
    vlape

    can you see the shares by \\<server name>, if not how bout \\<ip address>?
    post output from ipconfig /all of the VPN connection.

    +
    0 Votes
    luc_andre

    If you have a software firewall, like Norton Security, it could be blocking the allowance of network connections like File Sharing and NetBios (in Norton, found under Advanced Settings > Networking)

    +
    0 Votes
    Kjell_Andorsen

    I have seen the same issue, it appears to be a shortcoming of XP home. It has issues connecting to certain network reosurces on a Domain. Only way I found around it was to upgrade the end-user to XP pro, which instantly resolved the issue.

    I believe it's an issue with XP home not authenticating properly to an AD Domain.

    +
    0 Votes
    vlape

    I have never had an issue with XP Home or Media edition authenticating against a domain via VPN. The operating system has no relevance. if DHCP is not passing thru the proper information such as domain suffix, dns, gateway because the firewall is not configured to do as such you will have a problem accessing network resources by name.

    Installing another operating system is NOT the answer to this problem. Proper configuration of your firewall is the solution.

    +
    0 Votes
    Kjell_Andorsen

    I've had the Win XP Home users AUTHENTICATE and be able to log on to VPN, that was not the problem, but the problem is that because XP home doesn't support Group policy and File level access control, they were not able to access network drives and folders on the network once they had logged on to the domain. This appears to be the problem the poster is having, and I don't really see it as being a firewall issue. The test is of course to simply disable the firewall on the VPN client and see if it works.

    +
    0 Votes
    vlape

    i am not going to get into a flame match with you about this however you are WAY off the mark here. A NON DOMAIN computer making a VPN connection to a domain will NEVER process a gp. the workstation does not even know the domain controller exists. File access control had nothing to do with the clent computer being part of the domain, this is why users have the ability to auth with user@domain or domain\user. This authentication is done when the VPN connection is established. (remember the user is authenticating NOT the machine)

    This is nothing more than a firewall configuration issue. The firewall is not handling dns from vpn side to internal and most likeley the user did not properly setup dhcp relay agent or configure dhcp properly therefore the client pc is not getting enough information to use netbios names over the netowrk. I would bet anything he can connect using IP addresses to everything on his netowrk wothout any problems.

    I am sure the poster appriciates your help / information however if you do not completely know that you are talking about and provide incorrect informaiton it will only add confusion to the situation. Anyhow just my two cents.

    +
    0 Votes
    scottmelcher

    I have set up my XP home to accept incoming connections via a VPN. I am able to connect to this VPN fine from outside my network. However, I cannot then map a drive. I have tried disabling the firewall to no avail.

    +
    0 Votes
    scottmelcher

    I am also trying to map the drives via IP address and not name.

    +
    0 Votes
    ameza

    how many network adapters do you have on the server? for full VPN functionality you need two.
    see: http://support.microsoft.com/kb/217766/en-us

    +
    0 Votes
    blaynepeacock

    Dear vlape:

    forgive my ignorance, but would a normal wireless router have the dhcp relay agent you mentioned? Other than setting up the router firewall seeting to allow the VPN traffic, how to I alter the DHCP settings?

    thanks

    +
    0 Votes
    vic.speedypcrepair

    Try changing the IP and IP range of your local router at home. If you are getting the same address as the computer you are logging into or even the same range you'll probably not be able to connect.

    The following will probably work.
    Server = 192.168.1.1(router) and server range 192.168.1.100 to 192.168.1.253
    home computer = 192.168.2.1(router) and server range 192.168.2.100 to 192.168.2.253

    The catch to this is the domain issue which was answered elsewhere in this thread.

    +
    0 Votes
    elmakrani

    I've had the same problem. I fixed it with using the server name instead of IP address. And I had to disable the firewall on my vpn client(XP Pro) as well.
    Hope this helps...

    +
    0 Votes
    tgrizzel

    So I was experiencing the same issues you were having...Current mapped drives would not work while using wireless and vpn on another network. On some users computers it would and others in wont (all xp pro sp2). I tried everything, checked dns, dhcp newer vpn client, diff network and at the same time as all of these my firewall/antivirus settings. Finally I was so fed up I was reconfiging everything back to a useable state on a users computer and as soon as I fully configured his norton firewall (to defaults) it began working. I need to try this on other pc's however I thought for sure if I had a firewall issue it would work when the firewall was completely disabled and not fully configured.

    +
    0 Votes
    ananga

    Use the fully qualified domain name when mapping your network drives. If your domain name is viper. instead of
    \\galileo\folder as your share folder,
    make it \\Galileo.viper.com\folder.

    +
    0 Votes
    laura

    Having the same problem. Would love to know what fixed it. We cannot figure it out. Old VPN worked with SBC DSL and Windows XP but not this one. We can connect but cannot map drive it--DSL appears to be blocking it.

    +
    0 Votes
    zzoldi

    I had the same problem.
    I have win 2003 server and tried to access it from XP sp2 and Vista. When I tried to access the file server (\\server) it could not find it. After i specified a folder on the server it found it!!! eg. "\\server\Company Files" Finally i can access my work files from home without remote desktop.
    //What is weird, i still can not browse for the folder when i want to map it. Can it be a privilege issue?

    +
    0 Votes
    IT

    I believe the previous poster explained it- you need to provide the FQDN in your mapping (script of manual) for the drive.

    So it should be "\\server.domain.local\Company Files" rather than just "\\server\Company Files"

    +
    0 Votes
    Nimmo

    If you are connecting to a domain VIA a VPN then your PC is acting as if it is on the local network so mapping a share is the same
    i.e. \\server\share.

    Ping the server when you are connected to the domain via the VPN if you can't connect do a ipconfig /all and check your settings especially DNS and also subnet mask.

    Make sure your computer is a member of the domain, if you dont wan't it to be then you must make sure you have put the domain DNS servers in as a suffix on your workstation, otherwise your not going to resolve hosts.

    You will soon know if its just DNS if you can browse via shares via \\server ip address\share name not hostname.

    +
    0 Votes
    mtucker

    In the connection client uncheck the "Use default gateway on remote network." Then you will be able to map a drive. You will find this in the Advance button in the properties of the TCPIP Protocol

    +
    1 Votes
    fetz

    On the server go to Firewall, Exceptions, Hilight "File & Printer Sharing", Edit, Change Scope. Select "Any Computer" . Good luck