Questions

Why am I not getting an IP Address?

+
0 Votes
Locked

Why am I not getting an IP Address?

Deacq
I recently discovered that I lost my network connection between my Win 7 and Win XP sp3 machine. I didn't take it seriously because I never had good connection eversince I upgraded one of my machine to Win7. I decided to investigate the XP machine, typed ipconfig /all and the IP Address and Subnet Mask showed all 0's, and Default Gateway was blank. Does this mean that my network card on the XP machine is dead? If not, what other tests can I perform to verify if the card is ok? I am using a D-Link DI 604 cable router between mahines.

I appreciate your help.
Thanks,
Deacq
  • +
    1 Votes
    Mr_Threepwood

    Sounds like its not hitting dhcp server (probably your router). Solve this problem like any network problem:

    1. Is the cable good, does the port where the network cable plugs into the pc have the connection lights on it?
    2. If the connection is good, do an ipconfig /release, then ipconfig /renew see if dhcp gives it an ip address.
    3. is your pc set up to do dhcp? Did you accidently configure it with a static ip or is it trying to hit a dhcp server?

    If you've got another pc on the network and its working then your router is probably fine, I doubt the card is broken since that's pretty rare. Make sure you have the right network card driver.

    +
    0 Votes
    Deacq

    Thanks for all your help guys! I did everything as suggested... replaced the old network cable with a new one, disabled then enabled adapter, removed TCP/IP then added it again. I am now getting a connection but its only one way. The Win 7 machine can see the XP machine, but not the other way. Atleast I am now connecting! Thanks very much.

    +
    0 Votes
    asotelo

    disable the adapter, and enable it again. If you see the animation with the words: "Acquiring network address", and this takes a long time and you get no address, then you might be infected with malware or a virus, something has affected your protocol. Try setting in a static address and see if it helps, if you still have a problem, then I suggest cleaning up the XP computer with malware bytes, or similar infection cleaner.

  • +
    1 Votes
    Mr_Threepwood

    Sounds like its not hitting dhcp server (probably your router). Solve this problem like any network problem:

    1. Is the cable good, does the port where the network cable plugs into the pc have the connection lights on it?
    2. If the connection is good, do an ipconfig /release, then ipconfig /renew see if dhcp gives it an ip address.
    3. is your pc set up to do dhcp? Did you accidently configure it with a static ip or is it trying to hit a dhcp server?

    If you've got another pc on the network and its working then your router is probably fine, I doubt the card is broken since that's pretty rare. Make sure you have the right network card driver.

    +
    0 Votes
    Deacq

    Thanks for all your help guys! I did everything as suggested... replaced the old network cable with a new one, disabled then enabled adapter, removed TCP/IP then added it again. I am now getting a connection but its only one way. The Win 7 machine can see the XP machine, but not the other way. Atleast I am now connecting! Thanks very much.

    +
    0 Votes
    asotelo

    disable the adapter, and enable it again. If you see the animation with the words: "Acquiring network address", and this takes a long time and you get no address, then you might be infected with malware or a virus, something has affected your protocol. Try setting in a static address and see if it helps, if you still have a problem, then I suggest cleaning up the XP computer with malware bytes, or similar infection cleaner.