Questions

Why I am unable to delete some files in Windows 7?

Tags:
+
1 Votes
Locked

Why I am unable to delete some files in Windows 7?

Khurram.Shahid
Hi, I cannot delete certain files in Windows 7. They are mostly in ".mp4" & ".mkv" format. These files cannot be renamed also. I recieve the below message when I try to delete these files:

"THE ACTION CANNOT BE COMPLETED BECAUSE THE FILE IS OPEN IN WINDOWS EXPLORER.CLOSE & TRY AGAIN"

What is causing this problem & how to fix it? Looking forward to your response. Thanks :)
  • +
    0 Votes
    LocoLobo

    Have you tried rebooting? That may get the offending program to release the files.

    If you know which program it is you could use task manager to kill it. I assume 7 still has task manager or the equivalent.

    +
    0 Votes
    Khurram.Shahid

    That didnt work.......

    +
    1 Votes
    markp24

    have your tried rebooting the system, then deleteing the files?
    if that didnt work try rebooting, hit F8 after the bios screen, choose safe mode, try deleteing the files
    If that fails try downloading and using "unlocker" (http://www.filehippo.com/download_unlocker/)
    that should do it,

    let us know how it goes.

    +
    0 Votes
    Khurram.Shahid

    Thanks a lot ............"unlocker" did the trick :)

    +
    0 Votes
    OH Smeg

    "THE ACTION CANNOT BE COMPLETED BECAUSE THE FILE IS OPEN IN WINDOWS EXPLORER.CLOSE & TRY AGAIN"

    Windows is telling you that these files are in Use. Files that are in use can not be Deleted or Renamed so if you want/need to delete or rename these files you need to shut the Program that is accessing them.

    As you tell us that they are mainly MP4 or MKV Files both of which are Audio/Video Files what Audio or Video Editor/Player do you have open. These include Players that index all MP4 or MKV Files that it finds on the HDD even if the actual player isn't running at that exact moment in time playing something.

    Anything on a Play List will be locked and to delete/rename them you need to shut down the Program that is running either by starting in Safe Mode or Using the Task Manager and shutting down the Program.

    Col

    +
    0 Votes
    Khurram.Shahid

    No player is running whenever i try to delete the files or rename them. I think its a conflict in associating files between Windows media player & Real Player. Thanks though :)

    +
    0 Votes
    rahbm

    Because after 25 years, Windows STILL sucks. Granted, it has improved over that time, but then so it should!

    Am forced to use Windows at work and this problem often bites me; you close a file and then try to delete it, but Windows 7 still thinks it is open somewhere - just because it is still highlighted in Windows Explorer!

    Yes, a reboot will overcome this problem, but that is a rather drastic action to have to take to overcome a simple bug which shouldn't be there in the first place!

    +
    0 Votes
    Khurram.Shahid

    Reboot was the first option I tried but it didnt work

    +
    1 Votes
    Chomps

    After struggling with this problem for the last 3 weeks, I finally worked out a solution (for me at least).
    Open up Windows Explorer and see if you have the "preview panel" enabled, if yes then disable it (next to the ? at the top right). Then try the rename/delete the file.
    I find the "preview panel" handy for looking inside file without opening them up in an app (eg Office or Media Player) but the problem you describe had me stumped for a couple of weeks. Hope this helps.
    Peter

    +
    0 Votes
    Khurram.Shahid

    Tried it but no luck

    +
    0 Votes
    wsir45

    I believe maybe a system process is using the file.

    Download iobit unlocker. It is absolutely free from http://www.iobit.com/iobit-unlocker.html. Install, and right click the file you want to delete, hit unlock and you are done. Let me know how it goes.

    +
    1 Votes
    drabzz

    To fix this:

    1. Save any work you have open and close any applications you may have running.
    2. Now open Task Manager, Processes tab, and right-click on the entry for Explorer.
    3. Select End Process Tree. All windows and the desktop will close, and you will be left with only the Task Manager open.
    4. Select File, New Task (Run) and enter Explorer, then hit OK. Your Windows Desktop will now reload.

    You should now be able to navigate to the file or folder and delete it.

    +
    0 Votes
    miguelone

    dollars to donuts. It could be something else, but chances are, if it was something obvious like some suggested, you probably would have called the Geek Squad, instead of looking here. If it was something obscure, well I guess a lot of the other answers would be more helpfukl. Windows by default makes an index if your files, which it is updating all of the time, especially if you are in the process of moving and renaming. For reasons unknown to me it will lock the file while it sucks whatever info it needs and move on to trap some other hapless file.
    Come back a little later, make sure it is nmot open in another window, and it should delete/move/rename/whatever.
    If it is REEEAAALLY geting on your nerves, and you don't need to find files fast using the little "search" box in the upper right hand corner of explorer, just Google "stop indexing windows 7", and someone smarter than me will step you through it

    +
    1 Votes
    JimHjr73

    Windows Explorer is locking the thumbs.db file. To fix it is simple and nowhere near as complicated as the other answers.

    Press Alt + F, from Windows 7 Explorer
    * Select Tools
    * Select Folder Options
    * Select the View tab
    * Check the box that says "Always show icons, never thumbnails"

    +
    0 Votes
    PhillipMatlou

    This seems to be a common bug to all windows 7 users. Please take note that this problem also happened with XP. (Like other users I did not bother with MS Vista).

    After some research by a friend, we found that this solution worked the best:

    RD /S /Q

  • +
    0 Votes
    LocoLobo

    Have you tried rebooting? That may get the offending program to release the files.

    If you know which program it is you could use task manager to kill it. I assume 7 still has task manager or the equivalent.

    +
    0 Votes
    Khurram.Shahid

    That didnt work.......

    +
    1 Votes
    markp24

    have your tried rebooting the system, then deleteing the files?
    if that didnt work try rebooting, hit F8 after the bios screen, choose safe mode, try deleteing the files
    If that fails try downloading and using "unlocker" (http://www.filehippo.com/download_unlocker/)
    that should do it,

    let us know how it goes.

    +
    0 Votes
    Khurram.Shahid

    Thanks a lot ............"unlocker" did the trick :)

    +
    0 Votes
    OH Smeg

    "THE ACTION CANNOT BE COMPLETED BECAUSE THE FILE IS OPEN IN WINDOWS EXPLORER.CLOSE & TRY AGAIN"

    Windows is telling you that these files are in Use. Files that are in use can not be Deleted or Renamed so if you want/need to delete or rename these files you need to shut the Program that is accessing them.

    As you tell us that they are mainly MP4 or MKV Files both of which are Audio/Video Files what Audio or Video Editor/Player do you have open. These include Players that index all MP4 or MKV Files that it finds on the HDD even if the actual player isn't running at that exact moment in time playing something.

    Anything on a Play List will be locked and to delete/rename them you need to shut down the Program that is running either by starting in Safe Mode or Using the Task Manager and shutting down the Program.

    Col

    +
    0 Votes
    Khurram.Shahid

    No player is running whenever i try to delete the files or rename them. I think its a conflict in associating files between Windows media player & Real Player. Thanks though :)

    +
    0 Votes
    rahbm

    Because after 25 years, Windows STILL sucks. Granted, it has improved over that time, but then so it should!

    Am forced to use Windows at work and this problem often bites me; you close a file and then try to delete it, but Windows 7 still thinks it is open somewhere - just because it is still highlighted in Windows Explorer!

    Yes, a reboot will overcome this problem, but that is a rather drastic action to have to take to overcome a simple bug which shouldn't be there in the first place!

    +
    0 Votes
    Khurram.Shahid

    Reboot was the first option I tried but it didnt work

    +
    1 Votes
    Chomps

    After struggling with this problem for the last 3 weeks, I finally worked out a solution (for me at least).
    Open up Windows Explorer and see if you have the "preview panel" enabled, if yes then disable it (next to the ? at the top right). Then try the rename/delete the file.
    I find the "preview panel" handy for looking inside file without opening them up in an app (eg Office or Media Player) but the problem you describe had me stumped for a couple of weeks. Hope this helps.
    Peter

    +
    0 Votes
    Khurram.Shahid

    Tried it but no luck

    +
    0 Votes
    wsir45

    I believe maybe a system process is using the file.

    Download iobit unlocker. It is absolutely free from http://www.iobit.com/iobit-unlocker.html. Install, and right click the file you want to delete, hit unlock and you are done. Let me know how it goes.

    +
    1 Votes
    drabzz

    To fix this:

    1. Save any work you have open and close any applications you may have running.
    2. Now open Task Manager, Processes tab, and right-click on the entry for Explorer.
    3. Select End Process Tree. All windows and the desktop will close, and you will be left with only the Task Manager open.
    4. Select File, New Task (Run) and enter Explorer, then hit OK. Your Windows Desktop will now reload.

    You should now be able to navigate to the file or folder and delete it.

    +
    0 Votes
    miguelone

    dollars to donuts. It could be something else, but chances are, if it was something obvious like some suggested, you probably would have called the Geek Squad, instead of looking here. If it was something obscure, well I guess a lot of the other answers would be more helpfukl. Windows by default makes an index if your files, which it is updating all of the time, especially if you are in the process of moving and renaming. For reasons unknown to me it will lock the file while it sucks whatever info it needs and move on to trap some other hapless file.
    Come back a little later, make sure it is nmot open in another window, and it should delete/move/rename/whatever.
    If it is REEEAAALLY geting on your nerves, and you don't need to find files fast using the little "search" box in the upper right hand corner of explorer, just Google "stop indexing windows 7", and someone smarter than me will step you through it

    +
    1 Votes
    JimHjr73

    Windows Explorer is locking the thumbs.db file. To fix it is simple and nowhere near as complicated as the other answers.

    Press Alt + F, from Windows 7 Explorer
    * Select Tools
    * Select Folder Options
    * Select the View tab
    * Check the box that says "Always show icons, never thumbnails"

    +
    0 Votes
    PhillipMatlou

    This seems to be a common bug to all windows 7 users. Please take note that this problem also happened with XP. (Like other users I did not bother with MS Vista).

    After some research by a friend, we found that this solution worked the best:

    RD /S /Q