Questions

why is that my windows XP pc does not recognise a newly fitted Samsung 22x dvd writer.

Tags:
+
1 Votes
Locked

why is that my windows XP pc does not recognise a newly fitted Samsung 22x dvd writer.

didierjohn
I have changed the jumpers on dvd writer my BIOS can now detect it but unable to load the provided drivers from the cd. it is automatically loading a default one from windows xp which is not compatible. the device manager shows a yellow question mark against the loaded driver. It is an IDE DVD writer please help
  • +
    1 Votes
    OH Smeg

    But at a guess your new DVD Drive is a SATA Drive and you have previously had a IDE Drive and no installed SATA Drives.

    If that is the case you need to add the SATA Driver as XP doesn't natively support SATA Devices.

    If this is the only Optical Drive you have you can always download the SATA Driver from the Samsung Web Site or if you are using a SATA Controller Card you'll need it's driver which you can get from it's maker.

    Col

    +
    0 Votes
    didierjohn

    Thanks for suggestion but it is an IDE 22x dvd writer not a SATA, the one before was also an IDE.

    +
    1 Votes
    sathis2study

    my guess chk in bios weather it is detecting otherwise enable sata in bios and chk ur sata cable weather it is properly connected or not..
    enjoyy

    +
    0 Votes
    didierjohn

    Thanks for suggestion but it is an IDE 22x dvd writer not a SATA, the one before was also an IDE.

    +
    1 Votes
    OH Smeg

    It is the Jumper incorrectly placed here that is the problem.

    It needs to be set the same way as the one that came out of the unit to either Master, Slave or Cable Select CS.

    This jumper is a row of 3 Pins 2 wide between the IDE Lead and the Audio Out Connector.

    Col

    +
    0 Votes
    didierjohn

    Thanks for the help, i have changed the jumpers on dvd writer my BIOS can now detect it but unable to load the provided drivers from the cd. it is automatically loading a default one from windows xp which is not compatible. the device manager shows a yellow question mark against the loaded driver. It is an IDE DVD writer please help

    +
    0 Votes
    OH Smeg

    Well then you are going to have to load the drivers some other way.

    I would suggest going to Samsung Web Site and downloading the drivers, unzipping as required and then Open the Device Manager and right Clicking on the Device and choosing Update Driver from the selection.

    When you are prompted for the location of the driver point it to where you saved the driver and let it install.

    Col

    +
    1 Votes
    rahbm

    Is the unit recognised by a Live CD Linux, eg Ubuntu? If so, then the hardware is OK and the problem is with Windows (ie probably driver) but otherwise there may be a problem with the unit itself. In the latter case, double check by trying to install it on another PC.

    +
    1 Votes
    sathis2study

    my guess chk in bios weather it is detecting otherwise enable sata in bios and chk ur sata cable weather it is properly connected or not..
    enjoyy

    +
    1 Votes
    OH Smeg

    It is the Jumper incorrectly placed here that is the problem.

    It needs to be set the same way as the one that came out of the unit to either Master, Slave or Cable Select CS.

    This jumper is a row of 3 Pins 2 wide between the IDE Lead and the Audio Out Connector.

    Col

    +
    1 Votes
    rahbm

    Is the unit recognised by a Live CD Linux, eg Ubuntu? If so, then the hardware is OK and the problem is with Windows (ie probably driver) but otherwise there may be a problem with the unit itself. In the latter case, double check by trying to install it on another PC.

  • +
    1 Votes
    OH Smeg

    But at a guess your new DVD Drive is a SATA Drive and you have previously had a IDE Drive and no installed SATA Drives.

    If that is the case you need to add the SATA Driver as XP doesn't natively support SATA Devices.

    If this is the only Optical Drive you have you can always download the SATA Driver from the Samsung Web Site or if you are using a SATA Controller Card you'll need it's driver which you can get from it's maker.

    Col

    +
    0 Votes
    didierjohn

    Thanks for suggestion but it is an IDE 22x dvd writer not a SATA, the one before was also an IDE.

    +
    1 Votes
    sathis2study

    my guess chk in bios weather it is detecting otherwise enable sata in bios and chk ur sata cable weather it is properly connected or not..
    enjoyy

    +
    0 Votes
    didierjohn

    Thanks for suggestion but it is an IDE 22x dvd writer not a SATA, the one before was also an IDE.

    +
    1 Votes
    OH Smeg

    It is the Jumper incorrectly placed here that is the problem.

    It needs to be set the same way as the one that came out of the unit to either Master, Slave or Cable Select CS.

    This jumper is a row of 3 Pins 2 wide between the IDE Lead and the Audio Out Connector.

    Col

    +
    0 Votes
    didierjohn

    Thanks for the help, i have changed the jumpers on dvd writer my BIOS can now detect it but unable to load the provided drivers from the cd. it is automatically loading a default one from windows xp which is not compatible. the device manager shows a yellow question mark against the loaded driver. It is an IDE DVD writer please help

    +
    0 Votes
    OH Smeg

    Well then you are going to have to load the drivers some other way.

    I would suggest going to Samsung Web Site and downloading the drivers, unzipping as required and then Open the Device Manager and right Clicking on the Device and choosing Update Driver from the selection.

    When you are prompted for the location of the driver point it to where you saved the driver and let it install.

    Col

    +
    1 Votes
    rahbm

    Is the unit recognised by a Live CD Linux, eg Ubuntu? If so, then the hardware is OK and the problem is with Windows (ie probably driver) but otherwise there may be a problem with the unit itself. In the latter case, double check by trying to install it on another PC.

    +
    1 Votes
    sathis2study

    my guess chk in bios weather it is detecting otherwise enable sata in bios and chk ur sata cable weather it is properly connected or not..
    enjoyy

    +
    1 Votes
    OH Smeg

    It is the Jumper incorrectly placed here that is the problem.

    It needs to be set the same way as the one that came out of the unit to either Master, Slave or Cable Select CS.

    This jumper is a row of 3 Pins 2 wide between the IDE Lead and the Audio Out Connector.

    Col

    +
    1 Votes
    rahbm

    Is the unit recognised by a Live CD Linux, eg Ubuntu? If so, then the hardware is OK and the problem is with Windows (ie probably driver) but otherwise there may be a problem with the unit itself. In the latter case, double check by trying to install it on another PC.