Questions

Why Outlook 2007 converts incoming HTML email to plain text?

+
0 Votes
Locked

Why Outlook 2007 converts incoming HTML email to plain text?

maache
I use Outlook 2007 and the problem is following:

Sometimes (too often, but not always) I receive email in plain text format even though it was sent in HTML format.
(I have tested this with my friend who is also using Outlook 2007)

Also if I send HTML email to myself, I am often (almost always) receiving it in plain text.

I cannot isolate the reason for this (I am not an expert).

My preferred style is set to HTML. Note: I do receive html emails sometimes - so this problem is kind of random/mysterious to me.

How I could fix this annoying "feature"?

All help appreciated!!
  • +
    1 Votes
    matthewham

    Tools > Trust Center > Email Security > uncheck 'read all messages as plain text'.

    Edit: Oh I didnt read too closely, you do get html sometimes. It could just be that the people sending the email are sending in plain text instead of html.

    +
    0 Votes
    Dumphrey

    since its a huge security risk.

    +
    0 Votes
    maache

    ...in business between trusted parties it is very often the only reasonable way (screenshots, tables, etc).

    +
    0 Votes
    Dumphrey

    but attachments work well and can be pre-scanned, as well as being zippable to reduce the size of the mail message.
    the problem with html mail is that you can't turn it on only for trusted parties, and some html email exploits do not require you to read the email, clicking on it to delete it is enough.
    But your point is well taken. If you have little contact with random emails from strangers or spam, it is safe enough to leave on.

    +
    0 Votes
    gcitcah

    Did you ever figure out what was causing your problem? My Outlook 2007 is doing the same thing. When other people send me HTML mail, I can read it as HTML mail, but when I create an HTML mail and send it to others as well as myself, the other people seem to be able to read it as HTML, but my own email reads it as plain text, and I've already made sure no settings say "read as plain text"

    +
    0 Votes
    david

    This solved the problem for me, found at...

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3269993&SiteID=17


    I found that the problem was from a new installation of AVG 8.0 free edition, on the client.

    AVG scans every email and attach a "no virus ...." at the end.

    I disabled the notification, and it's working fine.

    +
    0 Votes
    snthorne

    You are absolutely right, brilliant, brilliant!

    +
    0 Votes
    ewaldner

    Disabling this notification fixed my problem as well. Thanks

    +
    0 Votes
    priva

    No matter how many ways I entered in the words for search on MS's sites, I got no hint. AVG didn't help either. Your answer was clear, clean an worked. I owe a debt of gratitude.

    +
    0 Votes
    dstannard

    I should have checked here 1st. Good lesson on productivity.

    Life was fine until I upgraded AVG from 7.5 to 8.x. But the intermittent nature and the lack of identifiable changes to settings & behaviors by AVG made me think that the problem was with the send - until I realized that I was losing HTML when downloading to Outlook.

    Thanks for the solution

    +
    0 Votes
    Kim.Williams

    Even the tech guy we hire couldn't figure this one out. I appreciate your input.

    +
    0 Votes
    maache

    I actually found that check-box too and it was unchecked. And as you said - I do receive emails in html format too.

    I just noticed that if I have received html-email from external source (for example some newsletter) and when I forward that to myself, I do receive it in html.

    BUT

    When I just create my own message from the scratch and send it to myself, I will receive it as plain text. But I know for sure (I have checked this) that if I would send that same message to some 3rd party recipient, he will received it html format as he should.

    So weird!

    +
    0 Votes
    pr0curve

    I have one user with the same problem of mostly none HTML emails. Even when I know they were sent as HTML. I checked the mail format and Security center options, no dice.

    +
    0 Votes
    ThumbsUp2

    .... turning OFF Word as the HTML editor under the programs tab?

    Just a thought.

    +
    0 Votes
    MrLoganyc

    Thanks guys!!!!!!

    +
    0 Votes
    gcapp99

    I know it's an old post, but I still want to let you know I appreciate your info. I run Outlook 2003 and needed a quick answer for the problem on 2007. You provided it and I thank you.

    +
    0 Votes
    snthorne

    Did you ever find a solution to this problem?

    +
    0 Votes
    ctmcswain

    It would seem that I am having this very same issue. I receive daily e-mail updates from TechRepublic and they used to come formatted as HTML. However, just in the past week or so they have been coming to my inbox as just text with hyperlinks. Any ideas?

    Compounding the issue, we just recently migrated our Exchange server. Possibly something with that migration? Thanks.

    +
    0 Votes
    ramy3183

    i am facing also same problem..i have one user that is receiving emails from some users in the same company as plain text..
    i have kaspersky antivirus and its working good in all the users.
    any help??? the problem from the sender or receiver or from the server?

  • +
    1 Votes
    matthewham

    Tools > Trust Center > Email Security > uncheck 'read all messages as plain text'.

    Edit: Oh I didnt read too closely, you do get html sometimes. It could just be that the people sending the email are sending in plain text instead of html.

    +
    0 Votes
    Dumphrey

    since its a huge security risk.

    +
    0 Votes
    maache

    ...in business between trusted parties it is very often the only reasonable way (screenshots, tables, etc).

    +
    0 Votes
    Dumphrey

    but attachments work well and can be pre-scanned, as well as being zippable to reduce the size of the mail message.
    the problem with html mail is that you can't turn it on only for trusted parties, and some html email exploits do not require you to read the email, clicking on it to delete it is enough.
    But your point is well taken. If you have little contact with random emails from strangers or spam, it is safe enough to leave on.

    +
    0 Votes
    gcitcah

    Did you ever figure out what was causing your problem? My Outlook 2007 is doing the same thing. When other people send me HTML mail, I can read it as HTML mail, but when I create an HTML mail and send it to others as well as myself, the other people seem to be able to read it as HTML, but my own email reads it as plain text, and I've already made sure no settings say "read as plain text"

    +
    0 Votes
    david

    This solved the problem for me, found at...

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3269993&SiteID=17


    I found that the problem was from a new installation of AVG 8.0 free edition, on the client.

    AVG scans every email and attach a "no virus ...." at the end.

    I disabled the notification, and it's working fine.

    +
    0 Votes
    snthorne

    You are absolutely right, brilliant, brilliant!

    +
    0 Votes
    ewaldner

    Disabling this notification fixed my problem as well. Thanks

    +
    0 Votes
    priva

    No matter how many ways I entered in the words for search on MS's sites, I got no hint. AVG didn't help either. Your answer was clear, clean an worked. I owe a debt of gratitude.

    +
    0 Votes
    dstannard

    I should have checked here 1st. Good lesson on productivity.

    Life was fine until I upgraded AVG from 7.5 to 8.x. But the intermittent nature and the lack of identifiable changes to settings & behaviors by AVG made me think that the problem was with the send - until I realized that I was losing HTML when downloading to Outlook.

    Thanks for the solution

    +
    0 Votes
    Kim.Williams

    Even the tech guy we hire couldn't figure this one out. I appreciate your input.

    +
    0 Votes
    maache

    I actually found that check-box too and it was unchecked. And as you said - I do receive emails in html format too.

    I just noticed that if I have received html-email from external source (for example some newsletter) and when I forward that to myself, I do receive it in html.

    BUT

    When I just create my own message from the scratch and send it to myself, I will receive it as plain text. But I know for sure (I have checked this) that if I would send that same message to some 3rd party recipient, he will received it html format as he should.

    So weird!

    +
    0 Votes
    pr0curve

    I have one user with the same problem of mostly none HTML emails. Even when I know they were sent as HTML. I checked the mail format and Security center options, no dice.

    +
    0 Votes
    ThumbsUp2

    .... turning OFF Word as the HTML editor under the programs tab?

    Just a thought.

    +
    0 Votes
    MrLoganyc

    Thanks guys!!!!!!

    +
    0 Votes
    gcapp99

    I know it's an old post, but I still want to let you know I appreciate your info. I run Outlook 2003 and needed a quick answer for the problem on 2007. You provided it and I thank you.

    +
    0 Votes
    snthorne

    Did you ever find a solution to this problem?

    +
    0 Votes
    ctmcswain

    It would seem that I am having this very same issue. I receive daily e-mail updates from TechRepublic and they used to come formatted as HTML. However, just in the past week or so they have been coming to my inbox as just text with hyperlinks. Any ideas?

    Compounding the issue, we just recently migrated our Exchange server. Possibly something with that migration? Thanks.

    +
    0 Votes
    ramy3183

    i am facing also same problem..i have one user that is receiving emails from some users in the same company as plain text..
    i have kaspersky antivirus and its working good in all the users.
    any help??? the problem from the sender or receiver or from the server?