Questions

win server 2003 dns and ad errors ???

Tags:
+
0 Votes
Locked

win server 2003 dns and ad errors ???

geo85
hi .....

the platform :
1- domain name is : rain.com
2- a server named RON.rain.com
3- OS : windows server 2003 SP1.
4- RON = Root, DNS,DC,AD.

the problem :

for some reason the server was restated, after log on (which took a bit more time than usual) :
1- oped the DNS snap in it shows a red cross, its not started,
2- nslookup = Default Server: Unknown
3- trying to restart the dns = failed
so tried the AD snap in, double click on it it shows the following error message :
naming information cannot be located because the specified domain does not exists or cannot be contacted,

i dont know what cause the problem

checked the event viewer found the following errors:

source : DNS
event ID : 4000
The DNS server was unable to open Active Directory. This DNS server is configured to obtain and use information from the directory for this zone and is unable to load the zone without it. Check that the Active Directory is functioning properly and reload the zone. The event data is the error code.

source : userenv
event id : 1053
windows cannot determine the server or computer name, the system detected
a possible to compromise the security, please ensure that you can contact the server that authenticated you.

source : net logon
event id : 5781
Dynamic registration or deletion of one or more DNS records associated
with DNS domain 'rain.com' failed. These records are used by other
computers to locate this server as a domain controller (if the specified
domain is an Active Directory domain) or as an LDAP server (if the
specified domain is an application partition).

any ideas plz

thank u very much...
  • +
    0 Votes
    seanferd

    That would be where to start.

    No clue about AD, but it sounds like at least one snap-in is hosed, or the DNS server isn't even started.

    +
    0 Votes
    OH Smeg

    It very much sounds as if when it was last restarted it didn't load all of the required services or something has been trashed while it was last running.

    All else being equal it's more likely that the system didn't restart properly particularly if it goes straight into Windows and isn't allowed to have a "Rest" between the Booting process and the Log On Process. I've seen lots of Windows Servers just not load all of the services reliably without a long pause between the time the Log On Screen appears and when the correct details are entered.

    Col

    +
    0 Votes
    geo85

    i did restart the server later on and !!!!!!!!!!
    the same errors appeared in the event viewer, and while i was surfing the net and reading about 15-20 minutes everything started to work i didn't do anything except after restarting did restart the computer browser service (it was not stopped) and server service (it was not stopped) and workstation service (it was not stopped) but the DNS and AD didn't work immediately .
    so again i restarted the server and again the scenario as above . checked the event viewer for any new errors, no new errors....
    what is going on, i have no clue.

    dear seanferd : if the DNS is not working how can i check the records in it.
    but after it started on i did check the records nothing is missing, the settings and config are the same, everything went back to normal.

    dear OH Smeg : if this is the case, what would be the solution???

    thank u all.

  • +
    0 Votes
    seanferd

    That would be where to start.

    No clue about AD, but it sounds like at least one snap-in is hosed, or the DNS server isn't even started.

    +
    0 Votes
    OH Smeg

    It very much sounds as if when it was last restarted it didn't load all of the required services or something has been trashed while it was last running.

    All else being equal it's more likely that the system didn't restart properly particularly if it goes straight into Windows and isn't allowed to have a "Rest" between the Booting process and the Log On Process. I've seen lots of Windows Servers just not load all of the services reliably without a long pause between the time the Log On Screen appears and when the correct details are entered.

    Col

    +
    0 Votes
    geo85

    i did restart the server later on and !!!!!!!!!!
    the same errors appeared in the event viewer, and while i was surfing the net and reading about 15-20 minutes everything started to work i didn't do anything except after restarting did restart the computer browser service (it was not stopped) and server service (it was not stopped) and workstation service (it was not stopped) but the DNS and AD didn't work immediately .
    so again i restarted the server and again the scenario as above . checked the event viewer for any new errors, no new errors....
    what is going on, i have no clue.

    dear seanferd : if the DNS is not working how can i check the records in it.
    but after it started on i did check the records nothing is missing, the settings and config are the same, everything went back to normal.

    dear OH Smeg : if this is the case, what would be the solution???

    thank u all.