Questions

Windows cannot access \\tp-server?

+
0 Votes
Locked

Windows cannot access \\tp-server?

elibarikikilewo
ity says "You may not have the appropriate permission to access the item" which i set to "everyone".. I have been having this problem the whole day with my server which runs XP Pro SP 2 .. i done almost everything in the book but still nothing then i had to restore Local Policy and change the group tittle which is a load of work when u got many machines like i do.. is there anybody knows the quick fix to this shyt?.. i got clients running different O.S.. googlin it didn't help! the server runs SQL 2000 and it has to be up in fifteen hours otherwise am gona have to do the whole thing all over again..

Clarifications

robo_dev

Do you get this error when logged in as administrator?

Is this executable on a mapped drive? (there is a reg setting to disable execution of items on mapped drives)

Is there a firewall on the PC? (including Nvidia lan drivers that have firewall functionality)

Do you have the Internet Explorer advanced security component installed?


Possible Fix:

error ???Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item.???

Fix:

Open Internet Explorer
Click on Tools
Click on Internet Options
Select Internet and click Custom Level
In the Miscellaneous section, set the ???Launching applications and unsafe files??? to Prompt (recommended) as shown in the screen shot below:

  • +
    1 Votes
    Tony Hopkinson

    Take some deep breaths, start at the beginning....

    +
    0 Votes
    oldbaritone

    Windows does some behind-the-scenes user access nonsense, and sometimes it can create headaches. You think you are logging on with a set of credentials, but Windows decides to use something else instead. This is particularly true if the password for your userid is different on the remote machine than on the local machine.

    One work-around I have been able to use sometimes is to access the same server using its IP address: If "myserver" is at address 192.168.1.100, then it may be referenced either as
    \\myserver\
    or
    \\192.168.1.100\

    sometimes this will give you a second chance at the access restrictions.

    Also, since you said access has been granted to "everyone", use credentials for a different user on the remote machine, e.g. if you are signed on your machine as "user_a" try the "connect as different user" option and specify "user_b" for the remote machine.

    Finally, I have also had problems with a password mistake when accessing remote machines. You put in a different password the second try and it doesn't work. When all else fails, reboot and try again.

    Oh, and did I mention, "when all else fails, reboot and try again."

    and if that doesn't work, try rebooting.

    +
    0 Votes
    danekan

    outside of the obvious of trying \\192.168.0.5 or whatever ... does the windows machine itself have "File and Print sharing for microsoft networks" checked/enabled for the network adapters? (under network connections, right click your network adapters and go to properties and verify)

    also, if i recall correctly, XP SP2 had some weird new firewall limitations that blocked a lot of stuff by default. Namely, I think by default the firewall blocks incoming Fire/Print sharing and you have to explicitly go in and modify the firewall policy to allow it, under the Exceptions tab. run wscui.cpl and check. You'll also need to add exceptions for the ports that SQL server uses. Though personally, I would outright disable Windows firewall at least until you've verified everything as functional. I feel like in SP3 they rolled back some of the firewall restrictions (also, is there a reason you aren't running at least SP3?)

    (And uhh, you're running a production SQL server on a windows XP SP2 box? ...for a business?)

    +
    0 Votes
    Tony Hopkinson

    SQL Server on XP works for small applcations, that are never going to get bigger. Any growth though and you are going to get problems, strange ones. Let's hope it's not the @Home version...

    +
    0 Votes
    elibarikikilewo

    Haha!.. all i had to do was buying a Registry Cleaner software online and did a full scan after installation >> then fixed errors>>..then DANG!..>> Haha!.. Am laughing ain't i?.. :)

  • +
    1 Votes
    Tony Hopkinson

    Take some deep breaths, start at the beginning....

    +
    0 Votes
    oldbaritone

    Windows does some behind-the-scenes user access nonsense, and sometimes it can create headaches. You think you are logging on with a set of credentials, but Windows decides to use something else instead. This is particularly true if the password for your userid is different on the remote machine than on the local machine.

    One work-around I have been able to use sometimes is to access the same server using its IP address: If "myserver" is at address 192.168.1.100, then it may be referenced either as
    \\myserver\
    or
    \\192.168.1.100\

    sometimes this will give you a second chance at the access restrictions.

    Also, since you said access has been granted to "everyone", use credentials for a different user on the remote machine, e.g. if you are signed on your machine as "user_a" try the "connect as different user" option and specify "user_b" for the remote machine.

    Finally, I have also had problems with a password mistake when accessing remote machines. You put in a different password the second try and it doesn't work. When all else fails, reboot and try again.

    Oh, and did I mention, "when all else fails, reboot and try again."

    and if that doesn't work, try rebooting.

    +
    0 Votes
    danekan

    outside of the obvious of trying \\192.168.0.5 or whatever ... does the windows machine itself have "File and Print sharing for microsoft networks" checked/enabled for the network adapters? (under network connections, right click your network adapters and go to properties and verify)

    also, if i recall correctly, XP SP2 had some weird new firewall limitations that blocked a lot of stuff by default. Namely, I think by default the firewall blocks incoming Fire/Print sharing and you have to explicitly go in and modify the firewall policy to allow it, under the Exceptions tab. run wscui.cpl and check. You'll also need to add exceptions for the ports that SQL server uses. Though personally, I would outright disable Windows firewall at least until you've verified everything as functional. I feel like in SP3 they rolled back some of the firewall restrictions (also, is there a reason you aren't running at least SP3?)

    (And uhh, you're running a production SQL server on a windows XP SP2 box? ...for a business?)

    +
    0 Votes
    Tony Hopkinson

    SQL Server on XP works for small applcations, that are never going to get bigger. Any growth though and you are going to get problems, strange ones. Let's hope it's not the @Home version...

    +
    0 Votes
    elibarikikilewo

    Haha!.. all i had to do was buying a Registry Cleaner software online and did a full scan after installation >> then fixed errors>>..then DANG!..>> Haha!.. Am laughing ain't i?.. :)