Questions

Windows Vista Remote Desktop.

+
0 Votes
Locked

Windows Vista Remote Desktop.

gpeterden
I am hoping someone could help me with this problem. I upgraded from XP Pro to Vista Ultimate. The problem I am unable to remote desktop to my work (County) computer. When I was using XP my company had me use Checkpoint SSL Internet Extender (VPN) through the web browser and remote desktop my work computer. Now that I'm using Vista, I am able to make the VPN connection using Checkpoint SSL Internet Extender, but unable to remote desktop my work computer. I tried connecting using my sons XP machine and had no problem with remote desktop to my work computer. Is there something special to making Vista remote desktop work once the VPN connection is made with Checkpoint SSL Internet Extender? My IT guys don't have any experance with Vista yet, the County just upgrade to XP a year ago. Please help if you can.

Thanks,
Gregg
  • +
    0 Votes
    georgeou

    Vista has a new RDP setting that only works with Vista clients. You can adjust RDP under "remote settings" system properties in the control panel to "allow connections from computers running any version of Remote Desktop (less secure)".

    +
    0 Votes
    mlightner

    I have not been able to connect to my office computer ever since I upgraded my HOME computer to Vista Ultimate. My office CPU is Windows XP and the server is Windows 2000 Server. I have inputted the computer information as I did before. It then asks for my sign in information and domain and then it says that "This computer can't connect to the remote computer." For the life of me I can not figure this out. On the server we have the access granted for remote access. Clearly it works since my staff connects freely and I used to be able to when I had my XP computer at home.

    Please help if you have som idea of how to correct this issue. My IT people can't seem to figure this out either.

    I already spend too many hours in the office and without this access I will never get home.

    PLEASE HELP!

    +
    0 Votes
    mlightner

    The article is great, however (unless I am not understanding), I am trying to connect FROM a Vista CPU TO a 2000 Server that will link me to my XP Desktop on the job. I am not connecting to a Vista CPU. Does this article relate or am I not understandng?

    Mark

    +
    0 Votes
    georgeou

    You're trying to make a L2TP or PPTP connection to a Win2K server? If that's what you mean, you'll have to describe your environment in detail so that others may assist.

    +
    0 Votes
    tekjam

    I seem to have the same problem. wondering if you have come across a solution/fix? Please advise.

    Lindsey

    +
    0 Votes
    boris.gomiunik

    I'm another one with the same problem.

    I'm also using Windows Vista Ultimate. When connecting to the remote desktop to the server (Windows 2003 Standard or Win2003 SBS) from within LAN, I can connect.

    But from outside I can't. It opens the connection for some seconds and then freezes and eventually looses connection.

    With windows XP I can connect. Maybe some clue to this is also that my messenger also keeps disconnecting every couple of minutes and re-signing in.

    +
    0 Votes
    EricLegault

    I never had problems using Remote Desktop from Vista to another PC over the Internet until I removed OneCare. I've seen this on 2 different PC's now, which is why I suspect it left some dirty little secrets behind. I couldn't get Groove to see other workspaces until I uninstalled OneCare, and I still had to repair some things.

    +
    0 Votes
    zekefive

    ... I've seen this on all of my Vista machines. It used to work fine up until a couple of months ago. RDP works fine on LAN, but remotely or over VPN is hangs when it starts to draw the desktop (about 2% of it).

    My Cisco VPN client stopped working around the same time RPD stopped working.

    Was there a Vista patch that could be causing this?

    +
    0 Votes
    zekefive

    Check this out from another site ...

    re: Vista Remote Desktop Connection
    Hello all,
    I finally found the answer to why I have been having connection problems using my Vista workstation with Remote Desktop trying to connect our 2003 terminal server.
    After first connecting to the terminal server and logging in successfully to the session, the login screen moves really slow, painting the display one pixel at a time and finally just locking up all together.
    Because of Vistas low initial setting on it's Auto Tuning feature I had to create a new shortcut on the desktop. Enter the command "cmd" as the shortcut command.
    Right-click on the shortcut and select "Run as Administrator".[You will be put in a DOS box]

    Type "netsh interface tcp set global autotuninglevel=disabled"

    [You should see a successful message]
    I had to create the shortcut and use the run as command even though my user was an administator equivalent. Not sure why, but it worked.

    +
    0 Votes
    veijo.jones

    I also had the problem with RDP being super-slow from Vista Ultimate to any RDP host. The posted solution by zekefive instantly fixed it - how did you find this solution? Thanks a lot!!

    +
    0 Votes
    rdesrosiers

    Hello,
    I am trying to connect to a Remote Computer for my work. I have Windows Vista on my computer. I can connect, but after a short time, it gets really slow, and then it tells me that my remote desktop connection has disconnected. I'm not sure I understand how to fix this can you please help me????
    Thankyou,
    Rochelle

    +
    0 Votes
    zekefive

    ... I've seen this on all of my Vista machines. It used to work fine up until a couple of months ago. RDP works fine on LAN, but remotely or over VPN is hangs when it starts to draw the desktop (about 2% of it).

    My Cisco VPN client stopped working around the same time RPD stopped working.

    Was there a Vista patch that could be causing this?

    +
    0 Votes
    sherlockossa

    Sorry, I didn't realize someone already posted the solution. I found this fix in March and its worth reading for the RFC cited and the MS explanation.

    I need to credit B-Double-U on google groups for providing the netsh syntax:

    netsh interface tcp set global rss=disabled
    netsh interface tcp set global autotuninglevel=disabled

    Like most of you I was able to RDP internally on the LAN. I was able to RDP via a PPTP connection as well, but not over the internet. I've had issues before due to MTU size set at the router level. This problem relates to the way Vista scales the size of the TCP window. Check out the link below for more technical details.

    Original Google Post

    http://groups.google.com/group/windows-vista/browse_thread/thread/17d2cef98294719c/40c0aeff15146b8c%2340c0aeff15146b8c

    --Sherlock

    +
    0 Votes
    arunguptaonline

    I have exactly same setup and found that Vista has something funny in networking. If there are two network adapters, Vista will use the default gateway on one adapter only. With Checkpint Network SSL Extender, the installation creates a virtual network adpater (vna). Vista will not use the default gateway on the vna. To get connected to your work computers, you will have to create a static route to your work IP address range. Find out the IP address of the gateway to your VPN network. From the route print command, determine the interface number of the Checkpoint SSL Network Extender. Now create a static route as:

    route -p add 200.0.0.0 MASK 255.0.0.0 200.79.15.2 IF 14

    The above assumes that your work computers are in the IP range 200.0.0.0, the subnet mask is 255.0.0.0, the VPN gateway is 200.79.15.2 and the interface number for SSL Network Extender is 14.

    Once you do this, the remote desktop connection will work without a problem.

    Hope this helps.

    +
    0 Votes
    anotherreboot432

    I was recently forced to put two Windows Vista systems into the field before fully testing. Long story short the checkpoint vpn software did not work. Had to upgrade to a new secure client found here http://www.checkpoint.com/downloads/quicklinks/downloads_sr.html
    Also needed to enable IKE encryption on the firewall side for each user. Hope this helps.

    +
    0 Votes
    nathanhdavidson

    I tried your suggestion and viola, we have a connection. I should have known from when I first started with visa and had to add a route for our company VPN.

    +
    0 Votes
    salim

    Check out free Tightvnc.com
    One of the best product. You can connect from any OS to any without much efforts and it is 100% secure.
    http://www.tightvnc.com

    +
    0 Votes
    ushahx

    I was having issues connecting from Vista home Premium/Windows 7 home premium to XP Pro. The solution was on the Windows XP machine I had to goto the Windows Firewall -> Advanced tab and for each network type click on Setting and allow Remote Desktop. You need to do this apart from adding an exception to Remote Desktop in the exceptions tab.

  • +
    0 Votes
    georgeou

    Vista has a new RDP setting that only works with Vista clients. You can adjust RDP under "remote settings" system properties in the control panel to "allow connections from computers running any version of Remote Desktop (less secure)".

    +
    0 Votes
    mlightner

    I have not been able to connect to my office computer ever since I upgraded my HOME computer to Vista Ultimate. My office CPU is Windows XP and the server is Windows 2000 Server. I have inputted the computer information as I did before. It then asks for my sign in information and domain and then it says that "This computer can't connect to the remote computer." For the life of me I can not figure this out. On the server we have the access granted for remote access. Clearly it works since my staff connects freely and I used to be able to when I had my XP computer at home.

    Please help if you have som idea of how to correct this issue. My IT people can't seem to figure this out either.

    I already spend too many hours in the office and without this access I will never get home.

    PLEASE HELP!

    +
    0 Votes
    mlightner

    The article is great, however (unless I am not understanding), I am trying to connect FROM a Vista CPU TO a 2000 Server that will link me to my XP Desktop on the job. I am not connecting to a Vista CPU. Does this article relate or am I not understandng?

    Mark

    +
    0 Votes
    georgeou

    You're trying to make a L2TP or PPTP connection to a Win2K server? If that's what you mean, you'll have to describe your environment in detail so that others may assist.

    +
    0 Votes
    tekjam

    I seem to have the same problem. wondering if you have come across a solution/fix? Please advise.

    Lindsey

    +
    0 Votes
    boris.gomiunik

    I'm another one with the same problem.

    I'm also using Windows Vista Ultimate. When connecting to the remote desktop to the server (Windows 2003 Standard or Win2003 SBS) from within LAN, I can connect.

    But from outside I can't. It opens the connection for some seconds and then freezes and eventually looses connection.

    With windows XP I can connect. Maybe some clue to this is also that my messenger also keeps disconnecting every couple of minutes and re-signing in.

    +
    0 Votes
    EricLegault

    I never had problems using Remote Desktop from Vista to another PC over the Internet until I removed OneCare. I've seen this on 2 different PC's now, which is why I suspect it left some dirty little secrets behind. I couldn't get Groove to see other workspaces until I uninstalled OneCare, and I still had to repair some things.

    +
    0 Votes
    zekefive

    ... I've seen this on all of my Vista machines. It used to work fine up until a couple of months ago. RDP works fine on LAN, but remotely or over VPN is hangs when it starts to draw the desktop (about 2% of it).

    My Cisco VPN client stopped working around the same time RPD stopped working.

    Was there a Vista patch that could be causing this?

    +
    0 Votes
    zekefive

    Check this out from another site ...

    re: Vista Remote Desktop Connection
    Hello all,
    I finally found the answer to why I have been having connection problems using my Vista workstation with Remote Desktop trying to connect our 2003 terminal server.
    After first connecting to the terminal server and logging in successfully to the session, the login screen moves really slow, painting the display one pixel at a time and finally just locking up all together.
    Because of Vistas low initial setting on it's Auto Tuning feature I had to create a new shortcut on the desktop. Enter the command "cmd" as the shortcut command.
    Right-click on the shortcut and select "Run as Administrator".[You will be put in a DOS box]

    Type "netsh interface tcp set global autotuninglevel=disabled"

    [You should see a successful message]
    I had to create the shortcut and use the run as command even though my user was an administator equivalent. Not sure why, but it worked.

    +
    0 Votes
    veijo.jones

    I also had the problem with RDP being super-slow from Vista Ultimate to any RDP host. The posted solution by zekefive instantly fixed it - how did you find this solution? Thanks a lot!!

    +
    0 Votes
    rdesrosiers

    Hello,
    I am trying to connect to a Remote Computer for my work. I have Windows Vista on my computer. I can connect, but after a short time, it gets really slow, and then it tells me that my remote desktop connection has disconnected. I'm not sure I understand how to fix this can you please help me????
    Thankyou,
    Rochelle

    +
    0 Votes
    zekefive

    ... I've seen this on all of my Vista machines. It used to work fine up until a couple of months ago. RDP works fine on LAN, but remotely or over VPN is hangs when it starts to draw the desktop (about 2% of it).

    My Cisco VPN client stopped working around the same time RPD stopped working.

    Was there a Vista patch that could be causing this?

    +
    0 Votes
    sherlockossa

    Sorry, I didn't realize someone already posted the solution. I found this fix in March and its worth reading for the RFC cited and the MS explanation.

    I need to credit B-Double-U on google groups for providing the netsh syntax:

    netsh interface tcp set global rss=disabled
    netsh interface tcp set global autotuninglevel=disabled

    Like most of you I was able to RDP internally on the LAN. I was able to RDP via a PPTP connection as well, but not over the internet. I've had issues before due to MTU size set at the router level. This problem relates to the way Vista scales the size of the TCP window. Check out the link below for more technical details.

    Original Google Post

    http://groups.google.com/group/windows-vista/browse_thread/thread/17d2cef98294719c/40c0aeff15146b8c%2340c0aeff15146b8c

    --Sherlock

    +
    0 Votes
    arunguptaonline

    I have exactly same setup and found that Vista has something funny in networking. If there are two network adapters, Vista will use the default gateway on one adapter only. With Checkpint Network SSL Extender, the installation creates a virtual network adpater (vna). Vista will not use the default gateway on the vna. To get connected to your work computers, you will have to create a static route to your work IP address range. Find out the IP address of the gateway to your VPN network. From the route print command, determine the interface number of the Checkpoint SSL Network Extender. Now create a static route as:

    route -p add 200.0.0.0 MASK 255.0.0.0 200.79.15.2 IF 14

    The above assumes that your work computers are in the IP range 200.0.0.0, the subnet mask is 255.0.0.0, the VPN gateway is 200.79.15.2 and the interface number for SSL Network Extender is 14.

    Once you do this, the remote desktop connection will work without a problem.

    Hope this helps.

    +
    0 Votes
    anotherreboot432

    I was recently forced to put two Windows Vista systems into the field before fully testing. Long story short the checkpoint vpn software did not work. Had to upgrade to a new secure client found here http://www.checkpoint.com/downloads/quicklinks/downloads_sr.html
    Also needed to enable IKE encryption on the firewall side for each user. Hope this helps.

    +
    0 Votes
    nathanhdavidson

    I tried your suggestion and viola, we have a connection. I should have known from when I first started with visa and had to add a route for our company VPN.

    +
    0 Votes
    salim

    Check out free Tightvnc.com
    One of the best product. You can connect from any OS to any without much efforts and it is 100% secure.
    http://www.tightvnc.com

    +
    0 Votes
    ushahx

    I was having issues connecting from Vista home Premium/Windows 7 home premium to XP Pro. The solution was on the Windows XP machine I had to goto the Windows Firewall -> Advanced tab and for each network type click on Setting and allow Remote Desktop. You need to do this apart from adding an exception to Remote Desktop in the exceptions tab.