Questions

WOL from DOS OK, WOL from Windows NOT OK

Tags:
+
0 Votes
Locked

WOL from DOS OK, WOL from Windows NOT OK

KahunaNui
Howdy Forum!

I've sorted out and read though about everything i can find here and the entire Internet on WOL but haven't got a clue why this craziness is happening. I suspect it has something to do with the way certain windows os's shutdown. I've gotten our other newer systems to WOL successfully but need to get an older system to play along.

MB is rock solid but ancient SB440BX-2 w/ 850MHZ P3 w/ 768MB RAM. (I know but it's basically a print server). Running Win2k Pro for OS. NIC is Pro/100 S Desktop 751767-007 w/ latest drivers as this nic is current w/ Intel. Running Win2000 Pro SP4. Yes WOL cable is connected otherwise it wouldn't work at all.

Using Magic Packet app (DOS based) MC-WOL.EXE and all within local LAN. As mentioned other newer systems no problem w/ XP Pro, Win2K & Win2K3 Serv. With this older system however:

1. If shutdown in DOS environment (via power button of course) WOL works flawlessly.

2. If shutdown via windows it will NOT wake up again...UNLESS i do the following:

3. If shutdown via windows and then i turn off the power supply (via the rocker switch on back) and then turn it back on again, WOL works again flawlessly.

4. This tells me that something in the way Win2000 is shutting down determines whether or not it WOL will work.

5. I have even set "Wake on Magic Packet from power off state" enabled. WOL WILL work from Standby.

NOTES: When powering down via windows nic and router/switch lights remain on. When powering off in a DOS environment via pwr button the nic & router/switch lights remain on.

Questions:

1. What on earth is different when i power down from DOS than powering down from Windows?! Lights are all lit up the same. But - unless i'm imagining it - i did note the ACTUAL SOUND when shutting off is different between shutting down in DOS and in Win!!!!!!!!!?????????????? It (the shutdown "click") seemed louder in DOS and more subtle in Win. Is that possible?! It would make sense if the shutdown methods are actually different.

2. Is the S5 State achieved when powering down in DOS or powering down in Windows?

3. What exactly IS S5 and is it the same as a "Soft power down?" (I have not researched what is a "soft power down". Perhaps that is what i'm not getting?

4. There IS some Intel documentation that claims certain OS's (Win98, Win2k, WinXP etc.) are not capable of WOL on S5 but if that's true why are my other systems working? Again, the question of just exactly what IS S5 comes into play.

5. Is there a remedy for this and what is it? I can live with wol/standby but i would prefer to be able to power down and wake up from windows.

Further notes:

1. I suspect this is an ACPI/APM issue, but not sure. I would think i could post this in the Win2k section but hopefully someone will know the score about this.

2. I even tried setting the NIC to "Enable WOL in Legacy OS" in it's ROM. Nothing works.

I thank everyone in advance for any help on this! If anyone thinks it is better in another area please feel free to move it.
  • +
    0 Votes
    Churdoo

    ... with your first note #4 that there's something with the way that Winders (2K) is shutting down that's leaving the rig in a state where WOL is hosed. I also agree that it's probably an ACPI/APM (driver) issue.

    The obvious answer therefore is to check/update all related drivers (chipset, ACPI/APM, etc.), but with the vintage of that rig and O/S I can only assume that you're using the latest and that nothing newer has been or will be released.

    I would be curious if an XP install/upgrade on this rig will not hose WOL on shutdown, and the rig will handle XP as just a print server. If you have a spare hard disk for testing and you're so inclined, you can remove the production disk, do an XP install with the test disk installed, and test the WOL functionality before deciding to upgrade the production instance.

    +
    0 Votes
    CG IT

    according to a search...

    http://msdn.microsoft.com/en-us/library/aa373229(VS.85).aspx

    http://www.osronline.com/ddkx/kmarch/pwrmgmt_919j.htm

    if you don't have ACPI enabled.. or if you do might have a role in how the computer turns off.

    If this is one of those boards that are first generation ATX... might need a BIOS flash to fix potential bugs...

    +
    0 Votes
    KahunaNui

    After looking into my old Tech docs i pretty much know what this is. Simply put, a old DOS environment gives me WOL but a newer/newest OS will not. It is an ACPI issue. Seems S5 is actually "Soft-off" and not the same as powering off in DOS/W95 (or as i've read: "a legacy off") Simply put this MB does not support this type of power off/acpi and in spite of Intel's support documents stating that the boot rom will give you this support it isn't happening. Latest BIOS is in there so i'm toast. What i'd like to know is exactly what is being effected: MB, NIC or both? It's obvious something changes with a soft off from windows but exactly what i'm not sure. Seems nobody else i know understands it either. Seems i now have 4 choices: 1. Disabling ACPI support in W2K - I've done this before but i don't like that route. Especially since everything else is working perfectly.2. Upgrade to newer systems to fill the roles of these machine(s).3. Use Standby as this works. I do not like having to disable PW's coming out of standby however.4. Forget about WOL altogether. If anyone here can help answer my question above, it will be very much appreciated.

    Very doubtful an XP upgrade would work...since this MB does not support acpi. No way i'm going to even try. I'd try Linux first
    EOL

    +
    0 Votes

    BTW

    KahunaNui

    I'm impressed that Churdoo & CG IT took the time to respond and want to thank them. It's been eons since i've been up here and don't remember the procedure(s). Most people would look at my post with the opinion that i'm crazier than a junk yard rat for even posting it. Inquiring minds and all that... Anyway, thank you guys for responding!

    +
    0 Votes
    CG IT

    for all things hardware, especially the old hardware...

    Normally ATX boards are not hard power off, that is to say that when you shut off the computer the motherboard still has power to it, vs a hard off where the motherboard has no power to it. Windows like W9X versions operated with both AT and ATX boards where shutting down Windows put you to a "It is now safe to turn off your machine" message on the comp. This was for AT systems in which "off" really is "off".

    So it's possible that your old board when it's off, it's powered off completely and so Wake on LAN isn't going to work.

    Still suggest you drop TheChas a PM.

    +
    0 Votes
    Who Am I Really

    where a DOS Shutdown doesn't or can't do that

    the default settings for Intel NICs is WOL Disabled

    here's 3 pics (from Device Manager, Device Properties)
    a> win2K with an Intel Integrated 10/100 82559 NIC
    http://i832.photobucket.com/albums/zz249/WhatNameShoudIUse/Intel2K.png?t=1295915075

    b> WinXP with an Intel Integrated gigabit 82566DC NIC
    http://i832.photobucket.com/albums/zz249/WhatNameShoudIUse/Intel-XP.png?t=1295915075

    c> WinXP with an Intel Integrated gigabit 82566DC NIC
    http://i832.photobucket.com/albums/zz249/WhatNameShoudIUse/th_IntelXP.png?t=1295915407

    check your settings to see if they're disabled

    +
    0 Votes
    Who Am I Really

    where a DOS Shutdown doesn't or can't do that

    the default settings for Intel NICs is WOL Disabled

    here's 3 pics (from Device Manager, Device Properties)
    a> win2K with an Intel Integrated 10/100 82559 NIC
    http://i832.photobucket.com/albums/zz249/WhatNameShoudIUse/Intel2K.png?t=1295915075

    b> WinXP with an Intel Integrated gigabit 82566DC NIC
    http://i832.photobucket.com/albums/zz249/WhatNameShoudIUse/Intel-XP.png?t=1295915075

    c> WinXP with an Intel Integrated gigabit 82566DC NIC
    http://i832.photobucket.com/albums/zz249/WhatNameShoudIUse/IntelXP.png?t=1295915689

    check your settings to see if they're disabled

    +
    0 Votes
    dariopadovani

    You can experiment this solution that always runs Lan or Wan.

    http://www.wollydigital.eu

    +
    0 Votes

    More info here:
    http://www.intel.com/support/network/sb/cs-008459.htm

    If you have a network card then you can try this:
    How can I set the Wake Up capabilities?

    1. In Microsoft Windows, right-click the Network Adapter in Network Connections and then click Properties.
    2. Click the Configure button and then the General tab.
    3. Set the "Wake Up Capabilities" parameter to Both, Magic Packet, None, or Wake Up Frame.

    Netware: Only supports DOS WOL and is configured by adding "MagicP=1" parameter to driver load command line in the AUTOEXEC.NCF file. To disable, change value to "0" or do not include parameter, since default is set to disable.

    Linux: The can be done using the "ethtool -g" command. Please refer to the respective man page for command syntax.

    Edited.. Just found more information to your issue:
    http://winhlp.com/node/57

  • +
    0 Votes
    Churdoo

    ... with your first note #4 that there's something with the way that Winders (2K) is shutting down that's leaving the rig in a state where WOL is hosed. I also agree that it's probably an ACPI/APM (driver) issue.

    The obvious answer therefore is to check/update all related drivers (chipset, ACPI/APM, etc.), but with the vintage of that rig and O/S I can only assume that you're using the latest and that nothing newer has been or will be released.

    I would be curious if an XP install/upgrade on this rig will not hose WOL on shutdown, and the rig will handle XP as just a print server. If you have a spare hard disk for testing and you're so inclined, you can remove the production disk, do an XP install with the test disk installed, and test the WOL functionality before deciding to upgrade the production instance.

    +
    0 Votes
    CG IT

    according to a search...

    http://msdn.microsoft.com/en-us/library/aa373229(VS.85).aspx

    http://www.osronline.com/ddkx/kmarch/pwrmgmt_919j.htm

    if you don't have ACPI enabled.. or if you do might have a role in how the computer turns off.

    If this is one of those boards that are first generation ATX... might need a BIOS flash to fix potential bugs...

    +
    0 Votes
    KahunaNui

    After looking into my old Tech docs i pretty much know what this is. Simply put, a old DOS environment gives me WOL but a newer/newest OS will not. It is an ACPI issue. Seems S5 is actually "Soft-off" and not the same as powering off in DOS/W95 (or as i've read: "a legacy off") Simply put this MB does not support this type of power off/acpi and in spite of Intel's support documents stating that the boot rom will give you this support it isn't happening. Latest BIOS is in there so i'm toast. What i'd like to know is exactly what is being effected: MB, NIC or both? It's obvious something changes with a soft off from windows but exactly what i'm not sure. Seems nobody else i know understands it either. Seems i now have 4 choices: 1. Disabling ACPI support in W2K - I've done this before but i don't like that route. Especially since everything else is working perfectly.2. Upgrade to newer systems to fill the roles of these machine(s).3. Use Standby as this works. I do not like having to disable PW's coming out of standby however.4. Forget about WOL altogether. If anyone here can help answer my question above, it will be very much appreciated.

    Very doubtful an XP upgrade would work...since this MB does not support acpi. No way i'm going to even try. I'd try Linux first
    EOL

    +
    0 Votes

    BTW

    KahunaNui

    I'm impressed that Churdoo & CG IT took the time to respond and want to thank them. It's been eons since i've been up here and don't remember the procedure(s). Most people would look at my post with the opinion that i'm crazier than a junk yard rat for even posting it. Inquiring minds and all that... Anyway, thank you guys for responding!

    +
    0 Votes
    CG IT

    for all things hardware, especially the old hardware...

    Normally ATX boards are not hard power off, that is to say that when you shut off the computer the motherboard still has power to it, vs a hard off where the motherboard has no power to it. Windows like W9X versions operated with both AT and ATX boards where shutting down Windows put you to a "It is now safe to turn off your machine" message on the comp. This was for AT systems in which "off" really is "off".

    So it's possible that your old board when it's off, it's powered off completely and so Wake on LAN isn't going to work.

    Still suggest you drop TheChas a PM.

    +
    0 Votes
    Who Am I Really

    where a DOS Shutdown doesn't or can't do that

    the default settings for Intel NICs is WOL Disabled

    here's 3 pics (from Device Manager, Device Properties)
    a> win2K with an Intel Integrated 10/100 82559 NIC
    http://i832.photobucket.com/albums/zz249/WhatNameShoudIUse/Intel2K.png?t=1295915075

    b> WinXP with an Intel Integrated gigabit 82566DC NIC
    http://i832.photobucket.com/albums/zz249/WhatNameShoudIUse/Intel-XP.png?t=1295915075

    c> WinXP with an Intel Integrated gigabit 82566DC NIC
    http://i832.photobucket.com/albums/zz249/WhatNameShoudIUse/th_IntelXP.png?t=1295915407

    check your settings to see if they're disabled

    +
    0 Votes
    Who Am I Really

    where a DOS Shutdown doesn't or can't do that

    the default settings for Intel NICs is WOL Disabled

    here's 3 pics (from Device Manager, Device Properties)
    a> win2K with an Intel Integrated 10/100 82559 NIC
    http://i832.photobucket.com/albums/zz249/WhatNameShoudIUse/Intel2K.png?t=1295915075

    b> WinXP with an Intel Integrated gigabit 82566DC NIC
    http://i832.photobucket.com/albums/zz249/WhatNameShoudIUse/Intel-XP.png?t=1295915075

    c> WinXP with an Intel Integrated gigabit 82566DC NIC
    http://i832.photobucket.com/albums/zz249/WhatNameShoudIUse/IntelXP.png?t=1295915689

    check your settings to see if they're disabled

    +
    0 Votes
    dariopadovani

    You can experiment this solution that always runs Lan or Wan.

    http://www.wollydigital.eu

    +
    0 Votes

    More info here:
    http://www.intel.com/support/network/sb/cs-008459.htm

    If you have a network card then you can try this:
    How can I set the Wake Up capabilities?

    1. In Microsoft Windows, right-click the Network Adapter in Network Connections and then click Properties.
    2. Click the Configure button and then the General tab.
    3. Set the "Wake Up Capabilities" parameter to Both, Magic Packet, None, or Wake Up Frame.

    Netware: Only supports DOS WOL and is configured by adding "MagicP=1" parameter to driver load command line in the AUTOEXEC.NCF file. To disable, change value to "0" or do not include parameter, since default is set to disable.

    Linux: The can be done using the "ethtool -g" command. Please refer to the respective man page for command syntax.

    Edited.. Just found more information to your issue:
    http://winhlp.com/node/57