Questions

XP Networking Suddenly very slow

+
0 Votes
Locked

XP Networking Suddenly very slow

ackray
At a hotel I support I was called in to figure out why the reception workstation had slowed to a crawl.

In this environment we are running four windows XP Pro Dell Optiplex machines about three years old. The workstations are running MS office and one of them functions as the server for a reservation package called Guest tracker. The workstation that functions as a server is also running Carbonite for off site backups.

Initially I ran through all of the AV, Spyware, Power saving, and defrag type of options with no results. Checkdisk resulted in either a 2+ hour scan time or a crash & reboot so the hard drives were replaced. The backup OS image was then written to the HDs with Acronis.

The systems still ran very slow so I changed Carbonite to only run during off hours. Carbonite was the choice of, and was set up by, the hotel owner. I then contacted the developer of Guest Tracker and went through all of his suggestions.

Then after a number of other hardware adjustments I changed out the hub and router.

I then moved the data file off the workstation/server and over to one of my personal computers with a 1 Gig NIC to match up with the new 1 Gig hub. This was faster, but still not good enough.

The owner of the hotel then came back and had me replace everything back to "the way it was" He has now firmly latched on to the Magic DLL theory. That is the theory that one or two DLL files have gone bad and I need to replace just those files.

My next step was going to be bringing in a new client machine with a fresh XP install and running that from my spare server.

While I am fully aware of the fact that I now have two problems I am now looking for a Magic DLL. So any suggestions on troubleshooting this would be appreciated.
  • +
    0 Votes
    Joanne Lowery

    You could check the network status on each XP machine. Control Panel, Network Connections, Check the LAN properties. The first page showing also gives the up time, speed of connection, and packet or byte count for send and receive. Check if any of the machines appears to be incrementing more than would appear normal. If a machine has way more traffic then expected that would be the one to focus on.
    Another idea is to check you haven't wound up with a loop in the network. Do you have just one switch? If you have more than one check that you don't have two network connections going between the switches. Unless you have a managed switch a network loop can cause major issues.

    +
    0 Votes
    Jacky Howe

    A:
    To turn off indexing:

    Open up "My Computer."
    Right-click on your hard drive (usually "C:") and choose "Properties."
    Uncheck the box at the bottom that reads "Allow Indexing Service to..."
    Click OK, and files will be removed from memory. This removal may take a few minutes to complete.

    B:
    To disable the indexing service:

    In the "Start" menu, choose "Run."
    Type "services.msc" and press Enter.
    Scroll-down to "Indexing Service" and double-click it.
    If the service status is "Running", then stop it by pressing the "Stop" button.
    To make sure this service doesn't run again, under "Startup Type:", choose "Disabled."

    C:
    Check to see if Google Desktop is installed or Google Toolbars.


    Speed up network browsing in Windows

    1. Start, Run and type in regedt32 and click OK

    2. Navigate to HKEY_LOCAL_MACHINE/Software/Microsoft/Windows/Current Version/Explorer/RemoteComputer/NameSpace/{D6277990-4C6A-11CF-8D87-00AA0060F5BF}

    3. Backup the Key so that it can be restored at a later time. {D6277990-4C6A-11CF-8D87-00AA0060F5BF}

    4. Right click on on the key and click delete {D6277990-4C6A-11CF-8D87-00AA0060F5BF}

    5. Restart your computer

    E:
    Look at the power saving of the network cards and make sure that it is set to disabled.

    +
    0 Votes

    Have you already verified that it is in fact a network problem and not a PC problem?
    Does Task Manager show low CPU and memory usage on the slow machine(s)?
    Also how locked down are these computers? have they been fully scanned for viruses and spyware? Are they patched? Often a Trojan horse or virus will seem like a network problem.
    Also, if you are using 10/100 Ethernet it often pays to manually configure both the switch port and PC NIC to the desired speed and duplex, instead of "Auto". Often, "Auto" will not properly detect, and cause a speed or duplex mismatch.

    +
    0 Votes
    ackray

    Actually I can transfer the entire data file, a whopping 35 megs, in less than three seconds. However it takes almost twenty seconds to change screens in the program.

    The workstations all have 1 gig of ram and CPU, Memory and networking are all normal.

    One clue is that when the workstation stalls I can match a performance graph between networking traffic and cpu usage. The gaph looks like ^-^ which tells me that the request for data goes out fine then the workstation waits for the data and then loads it.

    However I can find nothing on the 'server' that is delaying the data.

    I did set the server to prioritize background services.

    +
    0 Votes

    Well the fact that you can transfer the file quickly rules out physical networking entirely. If other programs like MS Office work fine, then the culprit is your client application.
    Check to see if firewalls or proxies may be causing issues. Was anything else installed or removed recently?
    Also be sure to check the Event Logs on both machines for any errors or warnings there.
    Next you might want to install Ethereal on the workstation to capture the traffic conversations between client and server. That may give you a clue as to why it is stalling.

    +
    0 Votes
    ackray

    initially there were a few hundred DCOM 1009 errors. But after installing the new hard drive they went away.

    The only consistent error I now get is from the .exe timing out.

    The entire program has been reinstalled and that replaces all of the .dll files.

    Tonights project is to run cables on the floor and bypass the wiring in the wall.

  • +
    0 Votes
    Joanne Lowery

    You could check the network status on each XP machine. Control Panel, Network Connections, Check the LAN properties. The first page showing also gives the up time, speed of connection, and packet or byte count for send and receive. Check if any of the machines appears to be incrementing more than would appear normal. If a machine has way more traffic then expected that would be the one to focus on.
    Another idea is to check you haven't wound up with a loop in the network. Do you have just one switch? If you have more than one check that you don't have two network connections going between the switches. Unless you have a managed switch a network loop can cause major issues.

    +
    0 Votes
    Jacky Howe

    A:
    To turn off indexing:

    Open up "My Computer."
    Right-click on your hard drive (usually "C:") and choose "Properties."
    Uncheck the box at the bottom that reads "Allow Indexing Service to..."
    Click OK, and files will be removed from memory. This removal may take a few minutes to complete.

    B:
    To disable the indexing service:

    In the "Start" menu, choose "Run."
    Type "services.msc" and press Enter.
    Scroll-down to "Indexing Service" and double-click it.
    If the service status is "Running", then stop it by pressing the "Stop" button.
    To make sure this service doesn't run again, under "Startup Type:", choose "Disabled."

    C:
    Check to see if Google Desktop is installed or Google Toolbars.


    Speed up network browsing in Windows

    1. Start, Run and type in regedt32 and click OK

    2. Navigate to HKEY_LOCAL_MACHINE/Software/Microsoft/Windows/Current Version/Explorer/RemoteComputer/NameSpace/{D6277990-4C6A-11CF-8D87-00AA0060F5BF}

    3. Backup the Key so that it can be restored at a later time. {D6277990-4C6A-11CF-8D87-00AA0060F5BF}

    4. Right click on on the key and click delete {D6277990-4C6A-11CF-8D87-00AA0060F5BF}

    5. Restart your computer

    E:
    Look at the power saving of the network cards and make sure that it is set to disabled.

    +
    0 Votes

    Have you already verified that it is in fact a network problem and not a PC problem?
    Does Task Manager show low CPU and memory usage on the slow machine(s)?
    Also how locked down are these computers? have they been fully scanned for viruses and spyware? Are they patched? Often a Trojan horse or virus will seem like a network problem.
    Also, if you are using 10/100 Ethernet it often pays to manually configure both the switch port and PC NIC to the desired speed and duplex, instead of "Auto". Often, "Auto" will not properly detect, and cause a speed or duplex mismatch.

    +
    0 Votes
    ackray

    Actually I can transfer the entire data file, a whopping 35 megs, in less than three seconds. However it takes almost twenty seconds to change screens in the program.

    The workstations all have 1 gig of ram and CPU, Memory and networking are all normal.

    One clue is that when the workstation stalls I can match a performance graph between networking traffic and cpu usage. The gaph looks like ^-^ which tells me that the request for data goes out fine then the workstation waits for the data and then loads it.

    However I can find nothing on the 'server' that is delaying the data.

    I did set the server to prioritize background services.

    +
    0 Votes

    Well the fact that you can transfer the file quickly rules out physical networking entirely. If other programs like MS Office work fine, then the culprit is your client application.
    Check to see if firewalls or proxies may be causing issues. Was anything else installed or removed recently?
    Also be sure to check the Event Logs on both machines for any errors or warnings there.
    Next you might want to install Ethereal on the workstation to capture the traffic conversations between client and server. That may give you a clue as to why it is stalling.

    +
    0 Votes
    ackray

    initially there were a few hundred DCOM 1009 errors. But after installing the new hard drive they went away.

    The only consistent error I now get is from the .exe timing out.

    The entire program has been reinstalled and that replaces all of the .dll files.

    Tonights project is to run cables on the floor and bypass the wiring in the wall.