1 pc in office has no internet, but can reach network

By rmorain ·
I have a client running NT 4 server w/10 Win XP Pro SP2 workstations. 1 pc can not connect to the internet. There are no restrictions imposed. He can connect to everything inside the network. NAV is clean, not in profile. Re-formatted & reinstalled XP. NIC card is on MB, disabled & used USB one, no change. Different cables, switches, pc's - all OK. Can ping out, but no web or email.
Any suggestions would greatly help.

This conversation is currently closed to new comments.

12 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -


by Toivo Talikka In reply to 1 pc in office has no int ...

Yoy mention profile - do all the users on the PC have the same problem? Have you tried a local user, instead of a domain user?

When you say the user has no email, do you mean that he cannot send emails using a server out in the internet? If you can ping an IP address outside your LAN, you can use the IP address of the SMTP server instead of the name of the server.

Have you checked that DNS is working in this PC? Go to the command prompt and type in nslookup and at the prompt type in a domain name and see if it gets resolved.

Collapse -

DNS? response

by rmorain In reply to DNS?

Profiles tried on & off domain. Using POP3 email, no internet, no email.
Pinging an IP address completes, but domain name does not. Same results with Trace route. PC is set to look at ISP DNS which is working correctly with the rest of the computers.

Collapse -


by zach In reply to DNS? response

So, do you have the pc set to a static DNS or or you automatically acquiring it? Have you tried renewing the IP address in the command prompt?

Collapse -

Static DNS & IP

by rmorain In reply to DNS....

Both are set to static. Tried automatic on both no change.

Collapse -

Winsock Perhaps

by willcomp In reply to 1 pc in office has no int ...

Try running this utility (winsockfix). It will reset Windows Sockets. You will need to re-enter IP address, gateway, and DNS server information since DHCP will be enabled after program finishes.

Collapse -

Funny Story

by Dan Powers In reply to Winsock Perhaps

In an earlier life I had a similar issue. I could figure it out. I was running XP and couldn;t get out on the Net but i could access network drive. It was also pulling in the right IP scheme.

For me the answer was in the dead ethernet cable. I finally noticed that I was never really accessing network drives. The ethernet had a good enough connection to allow me to pull my IP most of the times. What I was seeing instead of network drives was a synchornized version of those drives. Good old XP and its sync features fooled me again.

Lesson learned: Make sure you are actually getting onto the network and not dealing with a poor ethernet cable. Even when the early evidence points you else where.

Collapse -

Problem Fixed

by rmorain In reply to Winsock Perhaps

Just wanted to let everyone know that the Winsockfix corrected the problem.
Thanks for all of the help!!

Collapse -

You're Welcome

by willcomp In reply to Problem Fixed

Glad it worked. I've used that little gem numerous times. More reliable and less hassle than using netsh commands.

Collapse -

Name resolution

by rmorain In reply to 1 pc in office has no int ...

If we enter IP addresses it works, but the name resolution does not. We've worked around the e-mail issue with IP addresses, but still unable to type a web address.

Collapse -

Once Again

by willcomp In reply to Name resolution

I would still run winsockfix if DNS addresses are correct. It fixes a lot of glitches in Internet connectivity.

Back to Networks Forum
12 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums