Access Database Problem

By techproblem49 ·
Problem: I designed a small access database and created tables and relationship between them. The database works fine and have no problem. I have stored the database in My Documents on my hard disk but the moment I put it in a folder on the shared network it does not work. The database will open fine 3 or 4 times but 5th time I try to open it will give an error message.
Error message: Microsoft Office has detected that this database is in inconsistent state and this database will attempt to recover the database. During this process a backup copy of the database will be made and all recovered objects will be placed in a new database. Access will then open the new database. The names of the objects that were not successfully recovered will be logged in the ?Recovery Errors? table.
If I click OK for recovery sometimes it recovers the database but sometimes it gives the error message:
?The database can?t be repaired or is not a Microsoft office access database file.?
As a result I loose the database.
I have been trying to find the reason for these errors but no luck.
Can I directly copy or paste the database from my documents to shared network drive. Because what I have been doing so far is saving a backup copy of the database from my document on to the shared network drive. Is this method correct? Or do I need to follow a proper procedure? Do I need to make an ODBC connection?

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Copying is not a problem

by bart777 In reply to Access Database Problem

Assuming that the dataabase is not in use at the time you copy it to the shared drive.

I would be willing to bet that the problem you're having is being caused by the file remianing in an open state on the shared location. Some programs and files don't work well on some storage devices. I've seen this type of issue with a SNAP server and access DB files. You close the program but the storage server thinks that the file is still open. If this happens too many times you will get corrupt files as is keeps opening new copies over and over again.

Collapse -

Thanks for the reply.

by techproblem49 In reply to Copying is not a problem

Hi, many thanks for your reply. I usually make a back up copy of the database which I have saved in my documents on my hard disk and store that copy on the shared network drive. The thing you mentioned is exactly what happening. Even I have closed the database the server it still thinks its open and after some time it corrupts the database. So is there any solution to this problem. I have been trying since month now and cannot find a solution. Can you please tell me what to do and how to make the database work on the on shared drive?
Thanks a lot

Collapse -

This worked for me.

by bart777 In reply to Thanks for the reply.

I had to relocate the Access DB back to a standard windows server share. For some reason the device I was using (SNAP Appliance) just would not clear that lock in the CIFS mount.

Try creating a new share on a different Windows server and run the program from there.

Best of luck

Collapse -


by techproblem49 In reply to Access Database Problem

Hi, many thanks for your reply. I checked with the network administrator we do not have SNMP Server. At the moment I am facing these problems.

1. We are currently using Windows 2003 server. I have still got the same problem of the corrupt database. I don?t understand what is causing this problem.

2. Even if I have closed the database, I can still see the record locking ldb file.

3. The database takes too long to close.

4. I converted the 2007 database to 2003 access database just to see if it works. First it was freezing after every 2 seconds but now it is working fine. But the problem with it is that if I have opened it nobody else can open it. I saved it for shared access even than it does not open in the read only mode so at least we can view the data.

I am unable to find answer?s to these question if answer to my question I will be really grateful.

Many thanks

Collapse -

inconsistent state Access 2007 Vista Ultimate

by mdv3441 In reply to hi

I too have had this problem. What I have found so far pertains only to VISTA Access 2007, Windows Server 2003. The short of it is I move this database into a share under Users on the server and it seems to work ok. This is a 5 year old working database that only fails when a VISTA box talks to it. Verified on another exact configuration at another site. I think it is a security issue. I also tried to execute from Thumb drive and it killed the DB too. Standalone on VISTA worked fine but others have to share the data.

Mike Vance

Collapse -

Reponse To Answer

by RustyRhonda In reply to hi

I have a similar problem. I am running Access 2010 on a Windows 7 (64bit) system. I have recently upgraded laptops and have transferred databases created on my previous laptop, via USB. I get the above message on my new laptop when I try to open these databases. I have tried copying them to the hard drive - that doesn't solve the issue. I have tried to open them on the old laptop (where they originated and used to work) but they won't open there now either. The laptop I am using is from my employers and even though I am logged on locally, I do have the ability (when I am in the office) to connect to their network. Could this have any bearing on any of this? There was one database which was created at work and sat on the server. I copied it onto an external hard drive and worked on it on my laptop. When I tried to transfer it back, via the same external hard drive, I had the above problem. However, when I plugged the network cable in and transferred it that way, it worked fine (luckily). Help! please! as I don't want to have to create these other databases from scratch (heaps of work down the drain).

Back to Software Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums