Audio Device Help

By Qus ·
Dear all,
I use Win XP SP2. One day audio devices are gone and I don't know what caused it. The audio drivers were provided (automatically installed) by XP. I restore system to the point where it was ok. Still Windows can't play audio. But the speaker (which is connected to soundcard output) can beep for windows error message.

I try Windows help for troubleshooting, it doesn't help. Then I try Windows Media player help untill I got "Additional information is not currently available for this error." from Microsoft site.

I delete Audio codecs from device manager, let windows reinstall it. It doesn't solve the problem.

Sound & audio devices properties :
- volume tab : No audio device
- audio tab : No playback, recording and MIDI playback devices (combobox are disabled for configuring)
- voice tab : No playback and recording devices
- hardware tab : several devices, including Realtek AC'97 Audio

Then I run Winamp and configure its Preferences. In Plug-ins tree, output, I configure Directsound Output. Under Device tab I change Primary sound driver to Realtek AC97 Audio. Now Winamp can play audio files, but it can't play audio from video files.

I hope someone give me the solution. Thank you before for your time.


This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Try out Windows XP SP3.....

by Peconet Tietokoneet In reply to Audio Device Help

Download Windows XP SP3 here:

Or goto your Windows XP update site for your SP3.
Hope all goes well.

Collapse -

They solved it In this thread (I have the same problem)

by alainch In reply to Audio Device Help

and I found it .... here:

I just did it .. but not yet rebooted...

MY OS is a Vista But I suppose we got the same problem.

WHY we got this ????

I would like very much somebody able to explain what happened To give me an answer!!!

AlainCh ( curious

Collapse -


by Qus In reply to They solved it In this th ...

I can't reinstall windows for now, I have to check programs installed first and backing up their data or config.
And I don't know why the registry hack works for other but doesn't work for my machine. Maybe there is something I miss.
Thanks to anyone for giving the answer.

Collapse -

Why award Thumbs if the problem still exists ?...

by OldER Mycroft In reply to Thanks

This could be misleading for any other user with the same problem.

You shouldn't give a Thumb just because someone answered - ONLY if the answer solved your problem.

You are likely to get no more replies this way, because the Thumbs are likely to make other Peers think your problem has been solved and they will skip past this thread.

Collapse -

Awarded thumbs

by Qus In reply to Why award Thumbs if the p ...

Actually I'm not very sure whether I should give a thumb or not. But I'm sure sooner or later their answer will be useful (for me or somebody else who has the same problem).

Collapse -

That is hardly justification - if anything it's misleading ...

by OldER Mycroft In reply to Awarded thumbs

How can it possibly be "I'm sure sooner or later their answer will be useful" if you've still got the problem??


Collapse -


by Qus In reply to That is hardly justificat ...

Ok, I think I get the wrong idea of it. Btw, thank for correcting.

Collapse -

And It worked also for me ...

by alainch In reply to They solved it In this th ...

So I solved it doing exactly what they told !!

Hopefully you'll be lucky when you'll able to reboot!!

AlainCh ( happy

Back to Hardware Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums