General discussion


Cannot acquire network address

By acubedwoods3 ·
My home is setup with a router connected to DSL. One of my PCs was working great, and then now it cannot acquire a network IP address from the router. I checked every possible setting, and even used my laptop on the same cables and router, and the laptop connects no problem, but my PC shows the IP address of and when I try to repair it, it says Cannot Acquire Network Address. And then it sits there for hours trying to get the address. The NIC is working properly, and I even tried a different NIC and got the same thing, it shows speed of 100Mbps and Status: Acquiring network address. I tried uninstall and reinstall of the NIC............ anybody got anything?

This conversation is currently closed to new comments.

17 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by HAL 9000 Moderator In reply to Cannot acquire network ad ...

Well first have you installed the TCP/IP protocol or has it been removed by someone or something?

You may need to reset to a single IP address rather than allowing it to obtain an automatic address but I think that you'll find the TCP?IP protocol has somehow been removed or disabled.

If you where to mention what your setup is and how many computers are involved it would be helpful if you are using Windows through a common gateway it is possible that you have exceeded the number of simultaneous connections possible which is knocking this computer off the network or it could be something much simpler but without firs knowing what you are using it is harder to answer this question.


Collapse -

by acubedwoods3 In reply to

Yes TCP/IP is installed, I can see the PC from the Laptop, both computers are running WinXP SP2, and they are the only PCs on a 4-port router using DHCP and NAT. I tried to force an IP address on the PC and it still would not connect to the router.

Collapse -

by CuteElf In reply to Cannot acquire network ad ...

Well, if you know the NIC works, the cable is good, then the router is the next connection to check.

I would disconnect router from modem, and directly connect the internet to the computer.

If this works, then you know its the router.

Have you checked router configuration and seen what's in there?
Some times my Linksys dies and I have to re-enter the information.

If the router is deemed not working, you have a couple choices:
1.Use the reset button on router *in back or front, small, like pin hole size* and dump all config, start from scratch.
2.Install new firmware into router and try that.
3.Buy new router.

Troubleshooting, step by step.

Collapse -

by HAL 9000 Moderator In reply to Cannot acquire network ad ...

OK I take it that you have a combined DSL modem router and since you have the LT working properly on both connections it would appear to be confined to that particular computer.

Now since it was working previously what has been added since to prevent it from working?

I take it that you have tried running the Network Setup Wizard again which would be the normal thing to try and I'm supposing that it has something to do with the installation of SP2 as this is a fairly common problem. So first turn off the firewall that is built into SP2 and see if you then have a connection it is possible that the firewall is blocking the connection although not likely as you can see it from the LT. But can you see the LT from the non working computer?

I've only seen things like this when SP2 was first installed and it corrupted the NIC drivers which you have already reinstalled and I think you said you have even changed the NIC card so that should rule out a Hardware issue although with some of the older NIC cards they didn't like to play nice and sometimes that had to be moved to a different PCI socket to work A basic M'Board problem there and something to do with the BIOS settings.

Now if you can see the LT and actually read a file or folder from this computer the network is working properly and the router is blocking its ability to get an Internet connection.

You'll have to reset the Router and possibly even load an update to it just remember to only have one computer connected when you set it up and make the first connection.

If you can not see the LT or actually read a file or folder with the workstation you are using it is something deeper in that computer.

Collapse -

by HAL 9000 Moderator In reply to

I would first turn it off make sure everything is seated correctly in their sockets and then reboot and run the Network Setup Wizard again if you get to the end of this procedure and you are not asked to reboot then it has not run properly. Remember to allow the File & Printer sharing option and run the Wizard again.

Or if you have added something other than SP2 to the computer you could try removing that to see if it works again a lot of the net-workable games can take control of a LAN and delete other programs ability to gain an Internet connection as they establish their own IP/Subnets etc.

Lets know if that was of any help.


Collapse -

by willcomp In reply to Cannot acquire network ad ...

A question: If you don't have an IP address, how are the 2 PCs communicating?

On PC (laptop) that is connected, try releasing and renewing IP address. From command prompt:

ipconfig /release

ipconfig /renew

If laptop will renew address, DHCP from router is working. If it does not renew, that's your problem (i.e. router is not providing DHCP service).

A DHCP lease is normally 24 hours and problems may not be apparent until lease expires, PC is rebooted, or IP address is renewed. So you can have some connected and some not until IP address is renewed.

Is it a Linksys router?


Collapse -

by ESTechnical In reply to Cannot acquire network ad ...

I had this problem. How I discovered the fix: went directly into my router through IE default password was "admin" and checked the log for errors. What I found was that many times the ip addresses were getting assigned via DHCP (built in)to PCs and not expired and essentially running me out of ip addresses. By the way i made avail on the basic setup page 150 ip addresses. Ok Ok The Fix: shut down all pcs and hit the reset button on the back of the router and everything went back to default factory settings. You are not done yet you now have to setup the router with the setup disc unless you know how to manually do it. I bridged my DSL modem and set my router for PPPoE with my login and password setup. (Experienced user only stuff) Use your disc from your provider it will be easier! Now turn on each PC and you should be ready to go. Good luck!!

Collapse -

by CG IT In reply to Cannot acquire network ad ...

Well the funny thing is that if it's W2K/XP and can't find a DHCP, it will assign itself an address after X period of time. The fact that it's not tends to make me think something isn't right with TCP/IP.

Collapse -

by jbauernfeind In reply to Cannot acquire network ad ...

I have had some dealings with DSL, and sometimes they are a pain because of the software you have to install in order to "see" the connection. Is your DSL service the kind that you have to log into to make the connection, or is it connected all the time? Also, another thing you may try is to configure you Internet options to automaticallly find the IP address settings. Cabling could also be a part of it. Some try to use the software and connect via USB, where I find it easier (especially on DSL Modems) to put a small router behind the DSL Modem and connect the computers to the router. The service provider might also have to have a differnt default gateway setting you may want to check on. Depending on the brand/function and model of your Modem, your computer may only be acquiring an internal address, and the modem will actually acquire the external IP address. Find out which it is and let us know.

James Bauernfeind
System Administrator

Collapse -

by rkuhn In reply to Cannot acquire network ad ...

Check the router to make sure that you don't have MAC address filtering turned on. Many, if not most, consumer routers have IP and MAC filtering.

Back to Desktop Forum
17 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums