Windows

General discussion

Locked

Cannot Open the File: Mk:@MSITStore:C....

By perk ·
I have recently had the dubious pleasure to see the above mentioned message anytime I tried to open any .CHM files on my system. My system is running Windows XP Home SP2. (Yeah, I know, I'd better use Professional, but this one was pre-installed when I bought the system, and I couldn't afford to upgrade.)

The problem appeared when I was about to read an E-book in .CHM format. I tried to solve it by looking in the Help file system, but it wouldn't open... About this time I understood that it was not just a matter of a corrupt file, any .CHM I tried refused to open, no matter if it was residing on the local file system or on the Local Network. I tried to open some common applications and their help files, all with the same result.

Now I knew that the problem was in the system and not related to just a few files, so I turned my attention to the Microsoft Technet, Knowledge Base and Support Center Web sites. I found an article (http://support.microsoft.com/default.aspx?scid=kb;en-us;312456) that had an apt description of the problem. Too bad though, it was only applying to Windows 98 systems... The rest of the articles discussed the unintentional implications of service pack installations (896358, 840315), and only applying to opening .CHM files with MSIE...

I found the solution in a very cryptic instruction in a Forum.

Open a CMD window, type the following on the command line:

regsvr32 %systemroot%\system32\hhctrl.ocx <press enter>
regsvr32 %systemroot%\system32\itss.dll <press enter>

You will receive a success message after each of these commands.

I do not know when it first appeared, nor do I know what caused it (and I don't really care, I'm just very pleased with having found a solution that works for me).

NOTE:
I have not had this problem on any other systems, so I do not know if it applies to anything but XP.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Comments

Collapse -

search not working

by chaosad In reply to Cannot Open the File: Mk: ...

There is another problem I have found. The search function doesn't work, I am not sure if anyone else has the same problem. I am currently looking for a way to fix this so.......

Collapse -

Search not working

by rjpa123 In reply to search not working

What error you r getting ?

if you r getting the error of explorer.exe while doing search option then u need to add explorer.exe into DEP for adding in to edp rightclick--> my computer --> properties--> advace--> performace--> setting-->DEP--ADD

Collapse -

Found a solution

by kcrichards59 In reply to Cannot Open the File: Mk: ...

Rob Worley has the answer to this. I used the first part of his tip and it cleared it up immediately. One of the best and quickest solutions I've found. You can find his solution <a href="http://www.robworley.com/index.php?title=windows_blows&more=1&c=1&tb=1&pb=1">Here</a>

Collapse -

Thanks

by meetsairajesh In reply to Cannot Open the File: Mk: ...

With the details mentioned above, i solved
the problem

Collapse -

Cool!

by karan8002 In reply to Cannot Open the File: Mk: ...

Thanks..........it worked..!

Collapse -

it works

by shanto_lodi In reply to Cannot Open the File: Mk: ...

thnx@Perk...
first i tried to register hhctrl.ocx
--> regsvr32 %systemroot%\system32\hhctrl.ocx
and check if i can open .chm files but i can't. Then i tried to register itss.dll
--> regsvr32 %systemroot%\system32\itss.dll
and then it works. thnx again for the nice solution

Collapse -

Thank you

by Allucard In reply to Cannot Open the File: Mk: ...

I've registered an account just to thank you for this. Thank you so much for this solution which works 100%

Collapse -

Opens EBook

by sameerrdubey In reply to Cannot Open the File: Mk: ...

Great Job Dude
It Works!!!!

regsvr32 %systemroot%\system32\hhctrl.ocx
regsvr32 %systemroot%\system32\itss.dll

Collapse -

Confirmation of solution by perk

by rmirvine In reply to Cannot Open the File: Mk: ...

Thanks Perk - I had the same problem and the solution you came up with worked perfectly.

Collapse -

Unfortunately this hasn't solved my problem, but thanks

by sagasue In reply to Cannot Open the File: Mk: ...

OK here is my problem: I am running Windows XP SP2, and I am using ePublisher Express 2010.1 with FrameMaker 9.0.
I created a Help project in ePublisher Express containing multiple groups and multiple FM files. This compiled correctly and I could open all the chm files.
I added a new chapter to one of the groups in my project, and I then recompiled the whole project.
All the chm files were generated correctly. When I opened my 'root' chm file, the correct links appeared for 3 of my groups, but not for the group that contained the new chapter. When I tried to open the chm file that was missing from the folder structure, I got the "Cannot Open the File: Mk:@MSITStore" error.
I created a new (empty) project and added all the files from my original project, including the new chapter. The project compiled correctly, all groups were created and I could open ALL the chm files.
I then added another new chapter to the project. The sequence of errors repeated itself.
I tried all the fixes mentioned in this thread (thanks for trying) but nothing has made any difference.
Conclusion: If I create a project from scratch in ePublisher, everything works correctly. As soon as I add anything new (even an image file changed it), the chm files are created when I compile it, but the same chm file fails to open every time.
I am due to retire in 5 years. Will I always be left wondering?????

Related Discussions

Related Forums